summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/pinentry/pinentry-0.6.9.ebuild')
-rw-r--r--app-crypt/pinentry/pinentry-0.6.9.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/app-crypt/pinentry/pinentry-0.6.9.ebuild b/app-crypt/pinentry/pinentry-0.6.9.ebuild
index f2aed699cb1e..6be750735b35 100644
--- a/app-crypt/pinentry/pinentry-0.6.9.ebuild
+++ b/app-crypt/pinentry/pinentry-0.6.9.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.6.9.ebuild,v 1.3 2004/04/26 15:51:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.6.9.ebuild,v 1.4 2004/05/31 20:34:34 vapier Exp $
DESCRIPTION="collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
HOMEPAGE="http://www.gnupg.org/aegypten/"
SRC_URI="ftp://ftp.gnupg.org/gcrypt/pinentry/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ~ppc"
IUSE="qt gtk ncurses"
@@ -20,17 +20,19 @@ pkg_setup() {
}
src_compile() {
- econf $(use_enable qt pinentry-qt) \
- $(use_enable gtk pinentry-gtk) \
- $(use_enable ncurses pinentry-curses) \
- $(use_enable ncurses fallback-curses) \
- --disable-dependency-tracking || die "econf failed"
+ econf \
+ $(use_enable qt pinentry-qt) \
+ $(use_enable gtk pinentry-gtk) \
+ $(use_enable ncurses pinentry-curses) \
+ $(use_enable ncurses fallback-curses) \
+ --disable-dependency-tracking \
+ || die "econf failed"
make || die
}
src_install() {
make DESTDIR="${D}" install || die
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
# The other two pinentries don't spit out an insecure memory warning when
# not suid root, and gtk refuses to start if pinentry-gtk is suid root.