summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/ccid/ccid-1.3.2.ebuild')
-rw-r--r--app-crypt/ccid/ccid-1.3.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/ccid/ccid-1.3.2.ebuild b/app-crypt/ccid/ccid-1.3.2.ebuild
new file mode 100644
index 000000000000..59e269b08491
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ccid-1.3.2.ebuild,v 1.1 2008/01/22 20:58:23 alonbl Exp $
+
+inherit eutils
+
+STUPID_NUM="2297"
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="http://pcsclite.alioth.debian.org/ccid.html"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="twinserial nousb"
+RDEPEND=">=sys-apps/pcsc-lite-1.3.3
+ >=dev-libs/libusb-0.1.4"
+
+src_compile() {
+ local myconf
+
+ use nousb && myconf="${myconf} --disable-pcsclite"
+
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-udev \
+ ${myconf} \
+ $(use_enable twinserial) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Cannot install"
+ dodoc README AUTHORS
+ insinto /etc/udev/rules.d
+ newins src/pcscd_ccid.rules 60-pcscd_ccid.rules
+}