summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/bestcrypt')
-rw-r--r--app-crypt/bestcrypt/ChangeLog7
-rw-r--r--app-crypt/bestcrypt/Manifest4
-rw-r--r--app-crypt/bestcrypt/bestcrypt-1.2_p6.ebuild66
-rw-r--r--app-crypt/bestcrypt/files/digest-bestcrypt-1.2_p62
4 files changed, 76 insertions, 3 deletions
diff --git a/app-crypt/bestcrypt/ChangeLog b/app-crypt/bestcrypt/ChangeLog
index fd2b9789cc6a..e929c3e342fa 100644
--- a/app-crypt/bestcrypt/ChangeLog
+++ b/app-crypt/bestcrypt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/bestcrypt
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bestcrypt/ChangeLog,v 1.5 2003/06/25 15:49:46 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bestcrypt/ChangeLog,v 1.6 2003/09/10 22:45:23 lostlogic Exp $
+
+*bestcrypt-1.2_p6 (10 Sep 2003)
+
+ 10 Sep 2003; Brandon Low <lostlogic@gentoo.org> bestcrypt-1.2_p6.ebuild:
+ Bump
25 Jun 2003; Brandon Low <lostlogic@gentoo.org> bestcrypt-1.2_p5.ebuild:
Make it install documentation too
diff --git a/app-crypt/bestcrypt/Manifest b/app-crypt/bestcrypt/Manifest
index d0bfc9c587dc..72a3c66b9483 100644
--- a/app-crypt/bestcrypt/Manifest
+++ b/app-crypt/bestcrypt/Manifest
@@ -1,7 +1,7 @@
-MD5 2cac24be1e91d3b1238bd26867216535 bestcrypt-1.2_p6.ebuild 1852
+MD5 f7717e49d89bea842e45133c59bd1b63 bestcrypt-1.2_p6.ebuild 1853
MD5 2cac24be1e91d3b1238bd26867216535 bestcrypt-1.2_p5.ebuild 1852
MD5 a30bb939acfe4fa73a8a719376980e89 bestcrypt-1.2_p2.ebuild 1631
-MD5 726ba3945490df7e2866d2e53f5c4b33 ChangeLog 927
+MD5 063d2613f18d19f836ebd5884afd1f73 ChangeLog 1043
MD5 4d55e7543ba2eec5715d0a6aae4b811c files/bcrypt 2736
MD5 da7493ab01dda1aa1011a445088054ad files/digest-bestcrypt-1.2_p2 67
MD5 7e7bf1160a8f121d840033a20498e564 files/digest-bestcrypt-1.2_p5 129
diff --git a/app-crypt/bestcrypt/bestcrypt-1.2_p6.ebuild b/app-crypt/bestcrypt/bestcrypt-1.2_p6.ebuild
new file mode 100644
index 000000000000..92d1d4c9abdf
--- /dev/null
+++ b/app-crypt/bestcrypt/bestcrypt-1.2_p6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bestcrypt/bestcrypt-1.2_p6.ebuild,v 1.1 2003/09/10 22:45:23 lostlogic Exp $
+
+MY_PN="bcrypt"
+KEYWORDS="~x86"
+SRC_URI="http://www.jetico.com/linux/BestCrypt-${PV/_p/-}.tar.gz
+ http://www.jetico.com/linux/BestCrypt.doc.tgz"
+HOMEPAGE="http://www.jetico.com"
+DESCRIPTION="Transparent filesystem encryption. This is a Commercially Licensed Package, please read the license and ChangeLog for more information."
+S=${WORKDIR}/${MY_PN}
+LICENSE="bestcrypt"
+SLOT="0"
+DEPEND="virtual/linux-sources"
+
+src_unpack() {
+ unpack ${A}
+ for file in `find . -type f -iname Makefile*`;do
+ mv ${file} ${file}.orig
+ sed -e "s:-O[0-9]:${CFLAGS}:" \
+ -e 's%KVER =.*%KVER = $(shell readlink /usr/src/linux|sed -e "s:linux-\\([0-9]\\+\.[0-9]\\+\\)\..*:\\1:")%' \
+ -e "s%uname -r%readlink /usr/src/linux|sed -e 's:linux-::'%" \
+ ${file}.orig > ${file}
+
+ done
+}
+
+src_compile() {
+ MAKEOPTS="-j1" emake
+}
+
+src_install() {
+ #Install docs
+ dohtml ${WORKDIR}/bchelp/*
+ dodir /usr/share/doc/bestcrypt-1.2_p5/html/img
+ insinto /usr/share/doc/bestcrypt-1.2_p5/html/img
+ doins ${WORKDIR}/bchelp/img/*
+
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/bcrypt
+ dodir /usr/bin \
+ /etc/init.d \
+ /etc/rc.d/rc0.d \
+ /etc/rc.d/rc1.d \
+ /etc/rc.d/rc2.d \
+ /etc/rc.d/rc3.d \
+ /etc/rc.d/rc4.d \
+ /etc/rc.d/rc5.d \
+ /etc/rc.d/rc6.d \
+ /etc/rc0.d \
+ /etc/rc1.d \
+ /etc/rc2.d \
+ /etc/rc3.d \
+ /etc/rc4.d \
+ /etc/rc5.d \
+ /etc/rc6.d \
+ /usr/share/man/man8 \
+ /lib/modules/${KV}/kernel/drivers/block/
+ einstall MAN_PATH="/usr/share/man" \
+ root="${D}" \
+ MOD_PATH=/lib/modules/${KV}/kernel/drivers/block
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/bcrypt
+ rm -rf ${D}/etc/rc*.d
+ dodoc README LICENSE
+}
diff --git a/app-crypt/bestcrypt/files/digest-bestcrypt-1.2_p6 b/app-crypt/bestcrypt/files/digest-bestcrypt-1.2_p6
new file mode 100644
index 000000000000..aee91a2588cc
--- /dev/null
+++ b/app-crypt/bestcrypt/files/digest-bestcrypt-1.2_p6
@@ -0,0 +1,2 @@
+MD5 93d275cf6d351e9e286dc54316e4c1a2 BestCrypt-1.2-6.tar.gz 160552
+MD5 657f778dc5113b359d788cef4507928e BestCrypt.doc.tgz 134173