summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/cdrtools')
-rw-r--r--app-cdr/cdrtools/ChangeLog11
-rw-r--r--app-cdr/cdrtools/cdrtools-2.01.01_alpha34.ebuild123
-rw-r--r--app-cdr/cdrtools/cdrtools-2.01.01_alpha51.ebuild107
-rw-r--r--app-cdr/cdrtools/cdrtools-2.01.01_alpha60.ebuild115
-rw-r--r--app-cdr/cdrtools/cdrtools-2.01.01_alpha65.ebuild (renamed from app-cdr/cdrtools/cdrtools-2.01.01_alpha61.ebuild)39
5 files changed, 27 insertions, 368 deletions
diff --git a/app-cdr/cdrtools/ChangeLog b/app-cdr/cdrtools/ChangeLog
index 6b84668cb102..989914515fff 100644
--- a/app-cdr/cdrtools/ChangeLog
+++ b/app-cdr/cdrtools/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-cdr/cdrtools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/ChangeLog,v 1.234 2009/09/04 16:22:05 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/ChangeLog,v 1.235 2009/09/16 18:22:07 billie Exp $
+
+*cdrtools-2.01.01_alpha65 (16 Sep 2009)
+
+ 16 Sep 2009; Pielmeier Daniel <billie@gentoo.org>
+ -cdrtools-2.01.01_alpha34.ebuild, -cdrtools-2.01.01_alpha51.ebuild,
+ -cdrtools-2.01.01_alpha60.ebuild, -cdrtools-2.01.01_alpha61.ebuild,
+ +cdrtools-2.01.01_alpha65.ebuild:
+ Version bump. Remove old. Defuse some comments and remove useless einfo
+ message.
*cdrtools-2.01.01_alpha64 (04 Sep 2009)
diff --git a/app-cdr/cdrtools/cdrtools-2.01.01_alpha34.ebuild b/app-cdr/cdrtools/cdrtools-2.01.01_alpha34.ebuild
deleted file mode 100644
index e006ac30a83c..000000000000
--- a/app-cdr/cdrtools/cdrtools-2.01.01_alpha34.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-2.01.01_alpha34.ebuild,v 1.15 2009/09/04 16:22:05 billie Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="A set of tools for CD/DVD reading and recording, including cdrecord"
-HOMEPAGE="http://cdrecord.berlios.de/"
-SRC_URI="ftp://ftp.berlios.de/pub/cdrecord/alpha/${P/_alpha/a}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1 CDDL-Schily"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="unicode"
-
-DEPEND="!app-cdr/dvdrtools
- !app-cdr/cdrkit"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}-2.01.01
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-2.01.01a03-warnings.patch
- epatch "${FILESDIR}"/${P}-asneeded.patch
-
- cd "${S}"/DEFAULTS
- local MYARCH="linux"
-
- sed -i "s:/opt/schily:/usr:g" Defaults.${MYARCH}
- sed -i "s:/usr/src/linux/include::g" Defaults.${MYARCH}
- # For dynamic linking:
- sed -i "s:static:dynamic:" Defaults.${MYARCH}
-
- cd "${S}"/librscg
- sed -i "s:/opt/schily:/usr:g" scsi-remote.c
-
- # lame symlinks that all point to the same thing
- cd "${S}"/RULES
- local t
- for t in ppc64 sh4 s390x ; do
- ln -s i586-linux-cc.rul ${t}-linux-cc.rul || die
- ln -s i586-linux-gcc.rul ${t}-linux-gcc.rul || die
- done
-}
-
-src_compile() {
- if use unicode; then
- local flags="$(test-flags -finput-charset=ISO-8859-1 -fexec-charset=UTF-8)"
- if [[ -n ${flags} ]]; then
- append-flags ${flags}
- else
- ewarn "Your compiler does not support the options required to build"
- ewarn "cdrtools with unicode in USE. unicode flag will be ignored."
- fi
- fi
- emake CC="$(tc-getCC) -D__attribute_const__=const" COPTX="${CFLAGS}" CPPOPTX="${CPPFLAGS}" LDOPTX="${LDFLAGS}" || die
-}
-
-src_install() {
- dobin cdda2wav/OBJ/*-*-cc/cdda2wav || die "cdda2wav"
- dobin cdrecord/OBJ/*-*-cc/cdrecord || die "cdrecord"
- dobin mkisofs/OBJ/*-*-cc/mkisofs || die "mkisofs"
- dobin readcd/OBJ/*-*-cc/readcd || die "readcd"
- dosbin rscsi/OBJ/*-*-cc/rscsi || die "rscsi"
-
- insinto /usr/include
- doins incs/*-*-cc/align.h incs/*-*-cc/avoffset.h incs/*-*-cc/xconfig.h || die "include"
-
- cd mkisofs/diag/OBJ/*-*-cc
- dobin devdump isodump isoinfo isovfy || die "dobin"
-
- cd "${S}"
- insinto /etc/default
- doins rscsi/rscsi.dfl
- doins cdrecord/cdrecord.dfl
-
- cd "${S}"/libs/*-*-cc
- dolib.a *.a || die "dolib failed"
-
- cd "${S}"/libs/*-*-cc/pic
- dolib.so * || die "dolib.so failed"
-
- cd "${S}"
- insinto /usr/include/scsilib
- doins include/schily/*.h
- insinto /usr/include/scsilib/scg
- doins include/scg/*.h
-
- cd "${S}"
- dodoc ABOUT Changelog README README.linux-shm START READMEs/README.linux
- doman */*.1
- doman */*.8
-
- cd "${S}"/cdrecord
- docinto cdrecord
- dodoc README*
-
- cd "${S}"/mkisofs
- docinto mkisofs
- dodoc README*
-
- cd "${S}"/cdda2wav
- docinto cdda2wav
- dodoc FAQ Frontends HOWTOUSE README TODO
-
- cd "${S}"/libparanoia
- docinto libparanoia
- dodoc README*
-
- cd "${S}"/doc
- docinto print
- dodoc *.ps
-}
-
-pkg_postinst() {
- echo
- einfo "The command line option 'dev=/dev/hdX' (X is the name of your drive)"
- einfo "should be used for IDE CD writers. And make sure that the permissions"
- einfo "on this device are set properly and your user is in the correct group."
-}
diff --git a/app-cdr/cdrtools/cdrtools-2.01.01_alpha51.ebuild b/app-cdr/cdrtools/cdrtools-2.01.01_alpha51.ebuild
deleted file mode 100644
index 06c6b5d7293c..000000000000
--- a/app-cdr/cdrtools/cdrtools-2.01.01_alpha51.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-2.01.01_alpha51.ebuild,v 1.10 2009/09/04 16:22:05 billie Exp $
-
-inherit multilib eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="A set of tools for CD/DVD reading and recording, including cdrecord"
-HOMEPAGE="http://cdrecord.berlios.de/"
-SRC_URI="ftp://ftp.berlios.de/pub/cdrecord/alpha/${P/_alpha/a}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1 CDDL-Schily"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="unicode"
-
-DEPEND="sys-apps/acl
- !app-cdr/dvdrtools
- !app-cdr/cdrkit"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}-2.01.01
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- #Adjust paths
-
- sed -i -e 's:opt/schily:usr:' \
- $(grep -l --include='*.1' --include='*.8' -r 'opt/schily' .) \
- $(grep -l --include='*.c' --include='*.h' -r 'opt/schily' .) \
- || die "404 on opt-schily sed"
-
- sed -i -e "s:\(^INSDIR=\t\tshare/doc/\):\1${PF}/:" \
- $(grep -l -r 'INSDIR.\+doc' .) \
- || die "404 on doc sed"
-
- sed -i -e "s:\(^INSDIR=\t\t\)lib:\1$(get_libdir):" \
- $(grep -l -r '^INSDIR.\+lib\(/siconv\)\?$' .) \
- || die "404 on multilib-sed"
-
- sed -i -e "s:\(^INSDIR=\t\t\)\(etc/default\):\1../\2:" \
- $(grep -l -r '^INSDIR.\+default' .) \
- || die "404 on etc sed"
-
- #Remove profiled make files
- rm -f $(find . -name '*_p.mk')
-
- epatch "${FILESDIR}"/${PN}-2.01.01a03-warnings.patch
- epatch "${FILESDIR}"/${PN}-2.01.01_alpha50-asneeded.patch
-
- #Schily make setup
- cd "${S}"/DEFAULTS
- local MYARCH="linux"
-
- sed -i "s:/opt/schily:/usr:g" Defaults.${MYARCH}
- sed -i "s:/usr/src/linux/include::g" Defaults.${MYARCH}
-
- # For dynamic linking:
- sed -i "s:static:dynamic:" Defaults.${MYARCH}
-
- # lame symlinks that all point to the same thing
- cd "${S}"/RULES
- local t
- for t in ppc64 sh4 s390x ; do
- ln -s i586-linux-cc.rul ${t}-linux-cc.rul || die
- ln -s i586-linux-gcc.rul ${t}-linux-gcc.rul || die
- done
-
-}
-
-src_compile() {
- if use unicode; then
- local flags="$(test-flags -finput-charset=ISO-8859-1 -fexec-charset=UTF-8)"
- if [[ -n ${flags} ]]; then
- append-flags ${flags}
- else
- ewarn "Your compiler does not support the options required to build"
- ewarn "cdrtools with unicode in USE. unicode flag will be ignored."
- fi
- fi
-
- #If not built with -j1, "sometimes" cdda2wav will not be built. Nasty bug.
- emake -j1 CC="$(tc-getCC) -D__attribute_const__=const" COPTX="${CFLAGS}" CPPOPTX="${CPPFLAGS}" LDOPTX="${LDFLAGS}" || die
-}
-
-src_install() {
- make MANDIR="share/man" INS_BASE="${D}/usr/" install
-
- #These symlinks are for compat with cdrkit.
- dosym schily /usr/include/scsilib
- dosym ../scg /usr/include/schily/scg
-
- dodoc ABOUT Changelog README README.linux-shm START READMEs/README.linux || die "dodoc cdrtools"
-
- cd "${S}"/cdda2wav
- docinto cdda2wav
- dodoc FAQ Frontends HOWTOUSE TODO || die "dodoc cdda2wav"
-
-}
-
-pkg_postinst() {
- echo
- einfo "The command line option 'dev=/dev/hdX' (X is the name of your drive)"
- einfo "should be used for IDE CD writers. And make sure that the permissions"
- einfo "on this device are set properly and your user is in the correct group."
-}
diff --git a/app-cdr/cdrtools/cdrtools-2.01.01_alpha60.ebuild b/app-cdr/cdrtools/cdrtools-2.01.01_alpha60.ebuild
deleted file mode 100644
index f47bc837726b..000000000000
--- a/app-cdr/cdrtools/cdrtools-2.01.01_alpha60.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-2.01.01_alpha60.ebuild,v 1.2 2009/05/28 15:28:35 ssuominen Exp $
-
-EAPI=2
-
-inherit multilib eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="A set of tools for CD/DVD reading and recording, including cdrecord"
-HOMEPAGE="http://cdrecord.berlios.de/"
-SRC_URI="ftp://ftp.berlios.de/pub/cdrecord/alpha/${P/_alpha/a}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2.1 CDDL-Schily"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="unicode acl"
-
-DEPEND="acl? ( sys-apps/acl )
- !app-cdr/dvdrtools
- !app-cdr/cdrkit"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}-2.01.01
-
-src_prepare() {
- #"Adjust paths. Upstream is clearly on drugs, hardcoding paths into .c files.
- sed -i -e 's:opt/schily:usr:' \
- $(grep -l --include='*.1' --include='*.8' -r 'opt/schily' .) \
- $(grep -l --include='*.c' --include='*.h' -r 'opt/schily' .) \
- || die "404 on opt-schily sed"
-
- sed -i -e "s:\(^INSDIR=\t\tshare/doc/\):\1${PF}/:" \
- $(grep -l -r 'INSDIR.\+doc' .) \
- || die "404 on doc sed"
-
- # Upstream should be hanged from the yardarm, possibly keelhauled for
- # not respecting libdir.
- sed -i -e "s:\(^INSDIR=\t\t\)lib:\1$(get_libdir):" \
- $(grep -l -r '^INSDIR.\+lib\(/siconv\)\?$' .) \
- || die "404 on multilib-sed"
-
- # See previous comment s/libdir/--disable-static/
- sed -i -e 's:include\t\t.*rules.lib::' \
- $(grep -l -r '^include.\+rules\.lib' .) \
- || die "404 on rules sed"
- #Remove profiled make files (wtf?)
- rm -f $(find . -name '*_p.mk') || die "rm failed"
-
- epatch "${FILESDIR}"/${PN}-2.01.01a03-warnings.patch
- epatch "${FILESDIR}"/${PN}-2.01.01_alpha50-asneeded.patch
-
- #Schily make setup
- cd "${S}"/DEFAULTS
- local MYARCH="linux"
-
- sed -i "s:/opt/schily:/usr:g" Defaults.${MYARCH} || die "sed schily-opt failed"
- sed -i "s:/usr/src/linux/include::g" Defaults.${MYARCH} || die "sed linux-include failed"
- sed -i "/RUNPATH/ c\RUNPATH= " Defaults.${MYARCH} || die "sed RUNPATH failed"
-
- # For dynamic linking:
- sed -i "s:static:dynamic:" Defaults.${MYARCH} || die "sed static-remove failed"
-
- # lame symlinks that all point to the same thing
- cd "${S}"/RULES
- local t
- for t in ppc64 sh4 s390x ; do
- ln -s i586-linux-cc.rul ${t}-linux-cc.rul || die
- ln -s i586-linux-gcc.rul ${t}-linux-gcc.rul || die
- done
-}
-
-src_configure() { : ; }
-
-src_compile() {
- local ACL="-lacl"
- if use unicode; then
- local flags="$(test-flags -finput-charset=ISO-8859-1 -fexec-charset=UTF-8)"
- if [[ -n ${flags} ]]; then
- append-flags ${flags}
- else
- ewarn "Your compiler does not support the options required to build"
- ewarn "cdrtools with unicode in USE. unicode flag will be ignored."
- fi
- fi
-
- if ! use acl
- then
- CFLAGS="${CFLAGS} -DNO_ACL"
- ACL=""
- fi
- #If not built with -j1, "sometimes" cdda2wav will not be built. Nasty bug.
- emake -j1 CC="$(tc-getCC) -D__attribute_const__=const" COPTX="${CFLAGS}" LIB_ACL_TEST="${ACL}" CPPOPTX="${CPPFLAGS}" LDOPTX="${LDFLAGS}" || die "emake failed"
-}
-
-src_install() {
- emake -j1 MANDIR="share/man" INS_BASE="${D}/usr/" INS_RBASE="${D}" install
-
- #These symlinks are for compat with cdrkit.
- dosym schily /usr/include/scsilib
- dosym ../scg /usr/include/schily/scg
-
- dodoc ABOUT Changelog README README.linux-shm START READMEs/README.linux || die "dodoc cdrtools"
-
- cd "${S}"/cdda2wav
- docinto cdda2wav
- dodoc FAQ Frontends HOWTOUSE TODO || die "dodoc cdda2wav"
-
-}
-
-pkg_postinst() {
- echo
- einfo "The command line option 'dev=/dev/hdX' (X is the name of your drive)"
- einfo "should be used for IDE CD writers. And make sure that the permissions"
- einfo "on this device are set properly and your user is in the correct group."
-}
diff --git a/app-cdr/cdrtools/cdrtools-2.01.01_alpha61.ebuild b/app-cdr/cdrtools/cdrtools-2.01.01_alpha65.ebuild
index 643dc6c9a346..f1c6bb2fbaa1 100644
--- a/app-cdr/cdrtools/cdrtools-2.01.01_alpha61.ebuild
+++ b/app-cdr/cdrtools/cdrtools-2.01.01_alpha65.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-2.01.01_alpha61.ebuild,v 1.1 2009/07/11 10:41:59 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrtools/cdrtools-2.01.01_alpha65.ebuild,v 1.1 2009/09/16 18:22:07 billie Exp $
EAPI=2
@@ -23,7 +23,7 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}-2.01.01
src_prepare() {
- #"Adjust paths. Upstream is clearly on drugs, hardcoding paths into .c files.
+ # Adjusting hardcoded paths.
sed -i -e 's:opt/schily:usr:' \
$(grep -l --include='*.1' --include='*.8' -r 'opt/schily' .) \
$(grep -l --include='*.c' --include='*.h' -r 'opt/schily' .) \
@@ -33,23 +33,22 @@ src_prepare() {
$(grep -l -r 'INSDIR.\+doc' .) \
|| die "404 on doc sed"
- # Upstream should be hanged from the yardarm, possibly keelhauled for
- # not respecting libdir.
+ # Respect libdir.
sed -i -e "s:\(^INSDIR=\t\t\)lib:\1$(get_libdir):" \
$(grep -l -r '^INSDIR.\+lib\(/siconv\)\?$' .) \
|| die "404 on multilib-sed"
- # See previous comment s/libdir/--disable-static/
+ # See previous comment s/libdir/--disable-static/.
sed -i -e 's:include\t\t.*rules.lib::' \
$(grep -l -r '^include.\+rules\.lib' .) \
|| die "404 on rules sed"
- #Remove profiled make files (wtf?)
+
+ # Remove profiled make files.
rm -f $(find . -name '*_p.mk') || die "rm failed"
- epatch "${FILESDIR}"/${PN}-2.01.01a03-warnings.patch
epatch "${FILESDIR}"/${PN}-2.01.01_alpha50-asneeded.patch
- #Schily make setup
+ # Schily make setup.
cd "${S}"/DEFAULTS
local MYARCH="linux"
@@ -57,10 +56,10 @@ src_prepare() {
sed -i "s:/usr/src/linux/include::g" Defaults.${MYARCH} || die "sed linux-include failed"
sed -i "/RUNPATH/ c\RUNPATH= " Defaults.${MYARCH} || die "sed RUNPATH failed"
- # For dynamic linking:
+ # For dynamic linking.
sed -i "s:static:dynamic:" Defaults.${MYARCH} || die "sed static-remove failed"
- # lame symlinks that all point to the same thing
+ # Create additional symlinks needed for some archs.
cd "${S}"/RULES
local t
for t in ppc64 sh4 s390x ; do
@@ -88,14 +87,18 @@ src_compile() {
CFLAGS="${CFLAGS} -DNO_ACL"
ACL=""
fi
- #If not built with -j1, "sometimes" cdda2wav will not be built. Nasty bug.
- emake -j1 CC="$(tc-getCC) -D__attribute_const__=const" COPTX="${CFLAGS}" LIB_ACL_TEST="${ACL}" CPPOPTX="${CPPFLAGS}" LDOPTX="${LDFLAGS}" || die "emake failed"
+ # If not built with -j1, "sometimes" cdda2wav will not be built. Bug?
+ emake -j1 CC="$(tc-getCC) -D__attribute_const__=const" COPTX="${CFLAGS}" \
+ LIB_ACL_TEST="${ACL}" CPPOPTX="${CPPFLAGS}" LDOPTX="${LDFLAGS}" \
+ GMAKE_NOWARN="true" || die "emake failed"
}
src_install() {
- emake -j1 MANDIR="share/man" INS_BASE="${D}/usr/" INS_RBASE="${D}" install
+ # If not built with -j1, "sometimes" manpages are not installed. Bug?
+ emake -j1 MANDIR="share/man" INS_BASE="${D}/usr/" INS_RBASE="${D}" \
+ GMAKE_NOWARN="true" install
- #These symlinks are for compat with cdrkit.
+ # These symlinks are for compat with cdrkit.
dosym schily /usr/include/scsilib
dosym ../scg /usr/include/schily/scg
@@ -104,12 +107,4 @@ src_install() {
cd "${S}"/cdda2wav
docinto cdda2wav
dodoc FAQ Frontends HOWTOUSE TODO || die "dodoc cdda2wav"
-
-}
-
-pkg_postinst() {
- echo
- einfo "The command line option 'dev=/dev/hdX' (X is the name of your drive)"
- einfo "should be used for IDE CD writers. And make sure that the permissions"
- einfo "on this device are set properly and your user is in the correct group."
}