summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/iozone/iozone-3.222.ebuild')
-rw-r--r--app-benchmarks/iozone/iozone-3.222.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/app-benchmarks/iozone/iozone-3.222.ebuild b/app-benchmarks/iozone/iozone-3.222.ebuild
new file mode 100644
index 000000000000..d547f55b29bc
--- /dev/null
+++ b/app-benchmarks/iozone/iozone-3.222.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/iozone-3.222.ebuild,v 1.1 2004/10/28 10:14:02 dragonheart Exp $
+
+# TODO
+# -> linux-arm (32bit) <-
+# -> linux-AMD64 (64bit) <-
+# -> linux-ia64 (64bit) <-
+# -> linux-powerpc (32bit) <-
+# -> linux-S390 (32bit) <-
+# -> linux-S390X (64bit) <-
+#
+# -> freebsd (32bit) <-
+# -> macosx (32bit) <-
+# -> netbsd (32bit) <-
+# -> openbsd (32bit) <-
+# -> openbsd-threads (32bit) <-
+#
+# ~ia64 ~s390 alpha(?) x86-fbsd
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Filesystem benchmarking program"
+HOMEPAGE="http://www.iozone.org/"
+SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/gcc
+ >=sys-apps/sed-4
+ virtual/libc"
+RDEPEND="virtual/libc"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/3.221-gcc.patch
+}
+
+src_compile() {
+ cd src/current
+
+ # Options FIX
+ sed -i -e "s:CC =.*:CC =$(tc-getCC):g" \
+ -e "s:-O3 -Dunix:${CFLAGS} -Dunix:g" makefile
+
+ case ${ARCH} in
+ x86|alpha) PLATFORM="linux";;
+ arm) PLATFORM="linux-arm";;
+ ppc) PLATFORM="linux-powerpc";;
+ amd64) PLATFORM="linux-AMD64";;
+ ia64) PLATFORM="linux-IA64";;
+ s390) PLATFORM="linux-S390";;
+ x86-fbsd) PLATFORM="freebsd";;
+ *) PLATFORM="linux-${ARCH}";;
+ esac
+
+ emake ${PLATFORM} || die "Compile failed"
+}
+
+src_install() {
+ dosbin src/current/iozone || die
+ dodoc docs/I*
+ dodoc docs/Run_rules.doc
+ dodoc src/current/Changes.txt
+ doman docs/iozone.1
+
+ dodir /usr/share/${PF}
+ insinto /usr/share/${PF}
+ cd src/current
+ doins Generate_Graphs Gnuplot.txt gengnuplot.sh gnu3d.dem
+
+ prepall
+}
+
+src_test() {
+ cd ${T}
+ ${S}/src/current/iozone testfile || die "self test failed"
+}