summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/flexbackup/ChangeLog9
-rw-r--r--app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning.patch25
-rw-r--r--app-backup/flexbackup/flexbackup-1.2.1-r11.ebuild82
3 files changed, 106 insertions, 10 deletions
diff --git a/app-backup/flexbackup/ChangeLog b/app-backup/flexbackup/ChangeLog
index a070acbefa96..9615c52babc4 100644
--- a/app-backup/flexbackup/ChangeLog
+++ b/app-backup/flexbackup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-backup/flexbackup
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/ChangeLog,v 1.39 2010/11/09 18:14:05 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/ChangeLog,v 1.40 2010/11/09 18:26:21 graaff Exp $
+
+*flexbackup-1.2.1-r11 (09 Nov 2010)
+
+ 09 Nov 2010; Hans de Graaff <graaff@gentoo.org>
+ +flexbackup-1.2.1-r11.ebuild,
+ files/flexbackup-1.2.1-perl-5.12-deprecation-warning.patch:
+ Fix perl 5.12 deprecation warnings properly by merging both patches.
09 Nov 2010; Hans de Graaff <graaff@gentoo.org>
-flexbackup-1.2.1-r8.ebuild, -flexbackup-1.2.1-r9.ebuild:
diff --git a/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning.patch b/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning.patch
index 760331c4ba6b..2976eab916f1 100644
--- a/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning.patch
+++ b/app-backup/flexbackup/files/flexbackup-1.2.1-perl-5.12-deprecation-warning.patch
@@ -1,22 +1,29 @@
-diff -ubB old/flexbackup new/flexbackup
---- old/flexbackup 2010-07-30 11:44:34.000000000 -0400
-+++ new/flexbackup 2010-07-30 11:46:03.000000000 -0400
-@@ -1050,7 +1050,7 @@
+--- flexbackup.~1~ 2010-10-09 13:19:27.633694860 +0200
++++ flexbackup 2010-10-09 13:21:52.396818511 +0200
+@@ -133,6 +133,9 @@
+ # tar has a limit of this many chars in its volume label
+ $::tar_max_label = 99;
+
++# Define the prune hash to avoid warnings with perl 5.12
++use vars qw( %prune );
++
+ # Get commandline flags
+ %::opt = ();
+ if (! &::GetOptions(\%::opt,
+@@ -1050,6 +1053,6 @@
} else {
$prunekey = $dir;
}
- if (defined(%{$::prune{$prunekey}})) {
-+ if (%{$::prune{$prunekey}}) {
++ if (defined($prune{$prunekey})) {
&log("| NOTE: \$prune is ignored for type=dump");
}
-
-@@ -4882,7 +4882,7 @@
+@@ -4885,7 +4885,7 @@
$prunekey = $dir;
}
- if (defined(%{$::prune{$prunekey}})) {
-+ if (%{$::prune{$prunekey}}) {
++ if (defined($prune{$prunekey})) {
my $rex;
# FreeBSD needs -E (above) and no backslashes around the (|) chars
if ($::uname =~ /FreeBSD/) {
-Only in new/: flexbackup~
diff --git a/app-backup/flexbackup/flexbackup-1.2.1-r11.ebuild b/app-backup/flexbackup/flexbackup-1.2.1-r11.ebuild
new file mode 100644
index 000000000000..48cc4456b1d7
--- /dev/null
+++ b/app-backup/flexbackup/flexbackup-1.2.1-r11.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/flexbackup/flexbackup-1.2.1-r11.ebuild,v 1.1 2010/11/09 18:26:21 graaff Exp $
+
+inherit eutils versionator
+
+DESCRIPTION="Flexible backup script using perl"
+HOMEPAGE="http://flexbackup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-arch/mt-st"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Patch from upstream adds optional lzma compression mode.
+ epatch "${FILESDIR}"/${P}-lzma.patch
+
+ # Fix bug #116510: cannot back up remote machines after patch CAN-2005-2965
+ epatch "${FILESDIR}"/${P}-secure-tempfile.patch
+
+ # Fix bug #96334: incorrectly determines bash 3.x to be bash 1.x
+ epatch "${FILESDIR}"/${P}-bash.patch
+
+ # Fix bug #171205: specifies wrong command line option for mbuffer / other small enhancements
+ epatch "${FILESDIR}"/${P}-mbuffer-switch.patch
+
+ # Fix bug #173672: remote host buffer test is broken
+ epatch "${FILESDIR}"/${P}-remote-bufftest.patch
+
+ # Fix bug #178126: subtle subtree pruning issue / other small issues
+ epatch "${FILESDIR}"/${P}-prune.patch
+
+ # Fix bug #184560: fails to back up targets with spaces in their names in some modes
+ epatch "${FILESDIR}"/${P}-spaces-in-filenames.patch
+
+ # Fix bug #190357: fails on very large files with afio back end
+ epatch "${FILESDIR}"/${P}-afio-large-files.patch
+
+ # Fix bug #235416: prevent normal status message during conf file read from going to stderr
+ epatch "${FILESDIR}"/${P}-quieten.patch
+
+ # Fix bug #331673: perl 5.12 deprecation warnings.
+ epatch "${FILESDIR}"/${P}-perl-5.12-deprecation-warning.patch
+
+ sed -i \
+ -e '/^\$type = /s:afio:tar:' \
+ -e "/^\$buffer = /s:'buffer':'false':" \
+ flexbackup.conf \
+ || die "Failed to set modified configuration defaults."
+
+ MY_PV=$(replace_all_version_separators '_')
+ sed -i \
+ -e "/^[[:blank:]]*my \$ver = /s:${MY_PV}:&-${PR}:" \
+ flexbackup \
+ || die "Failed to apply ebuild revision to internal version string."
+}
+
+src_install() {
+ dodir /etc /usr/bin /usr/share/man/man{1,5}
+ emake install \
+ PREFIX="${D}"/usr \
+ CONFFILE="${D}"/etc/flexbackup.conf \
+ || die "emake install failed"
+
+ dodoc CHANGES CREDITS README TODO
+ dohtml faq.html
+}
+
+pkg_postinst() {
+ elog "Please edit your /etc/flexbackup.conf file to suit your"
+ elog "needs. If you are using devfs, the tape device should"
+ elog "be set to /dev/tapes/tape0/mtn. If you need to use any"
+ elog "archiver other than tar, please emerge it separately."
+}