summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/obnam/obnam-1.1.ebuild')
-rw-r--r--app-backup/obnam/obnam-1.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-backup/obnam/obnam-1.1.ebuild b/app-backup/obnam/obnam-1.1.ebuild
new file mode 100644
index 000000000000..3aa8d8a88442
--- /dev/null
+++ b/app-backup/obnam/obnam-1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/obnam/obnam-1.1.ebuild,v 1.1 2012/07/09 00:11:45 mschiff Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6:2.7"
+PYTHON_MODNAME="${PN}lib"
+MY_P="${PN}_${PV}.orig"
+
+inherit distutils python
+
+DESCRIPTION="A backup program that supports encryption and deduplication"
+HOMEPAGE="http://liw.fi/obnam/"
+SRC_URI="http://code.liw.fi/debian/pool/main/o/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/cliapp-1.20120630
+ dev-python/larch
+ dev-python/paramiko
+ dev-python/tracing
+ >=dev-python/ttystatus-0.19
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ distutils_src_install
+ rm "${D}"/usr/bin/obnam-{benchmark,viewprof}
+ rm "${D}"/usr/share/man/man1/obnam-benchmark*
+}