summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/zip/zip-2.31.ebuild')
-rw-r--r--app-arch/zip/zip-2.31.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/app-arch/zip/zip-2.31.ebuild b/app-arch/zip/zip-2.31.ebuild
deleted file mode 100644
index 3585a0eae15c..000000000000
--- a/app-arch/zip/zip-2.31.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zip/zip-2.31.ebuild,v 1.11 2007/02/28 21:53:56 genstef Exp $
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="Info ZIP (encryption support)"
-HOMEPAGE="ftp://ftp.freesoftware.com/pub/infozip/Zip.html"
-SRC_URI="ftp://ftp.info-zip.org/pub/infozip/src/zip${PV//.}.tar.gz
- crypt? ( ftp://ftp.icce.rug.nl/infozip/src/zcrypt29.zip )"
-
-LICENSE="Info-ZIP"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="crypt"
-
-DEPEND="crypt? ( app-arch/unzip )"
-
-src_unpack() {
- unpack ${A}
- use crypt && mv -f crypt.[ch] "${S}"
- cd "${S}"
- epatch "${FILESDIR}"/zip-2.3-unix_configure-pic.patch
- cd unix
- sed -i -e "s:-O2:${CFLAGS}:" Makefile
-}
-
-src_compile() {
- emake \
- -f unix/Makefile \
- CC="$(tc-getCC)" \
- CPP="$(tc-getCC) -E" \
- generic || die
-}
-
-src_install() {
- dobin zip zipcloak zipnote zipsplit || die
- doman man/zip.1
- dodoc BUGS CHANGES MANUAL README TODO WHATSNEW WHERE
-}