summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unrar/unrar-4.0.7.ebuild')
-rw-r--r--app-arch/unrar/unrar-4.0.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/unrar/unrar-4.0.7.ebuild b/app-arch/unrar/unrar-4.0.7.ebuild
new file mode 100644
index 000000000000..78b577942a1e
--- /dev/null
+++ b/app-arch/unrar/unrar-4.0.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/unrar-4.0.7.ebuild,v 1.1 2011/03/09 03:45:25 vapier Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+MY_PN=${PN}src
+DESCRIPTION="Uncompress rar files"
+HOMEPAGE="http://www.rarlab.com/rar_add.htm"
+SRC_URI="http://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="unRAR"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!<=app-arch/unrar-gpl-0.0.1_p20080417"
+
+S=${WORKDIR}/unrar
+
+src_compile() {
+ append-lfs-flags #356155
+ emake \
+ -f makefile.unix \
+ CXXFLAGS="${CXXFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ STRIP="true" || die "emake failed"
+}
+
+src_install() {
+ dobin unrar || die
+ dodoc readme.txt
+}