summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/rpm/rpm-4.0.4-r2.ebuild')
-rw-r--r--app-arch/rpm/rpm-4.0.4-r2.ebuild51
1 files changed, 23 insertions, 28 deletions
diff --git a/app-arch/rpm/rpm-4.0.4-r2.ebuild b/app-arch/rpm/rpm-4.0.4-r2.ebuild
index 4b4db12a2fb3..1639af2646a6 100644
--- a/app-arch/rpm/rpm-4.0.4-r2.ebuild
+++ b/app-arch/rpm/rpm-4.0.4-r2.ebuild
@@ -1,15 +1,17 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.0.4-r2.ebuild,v 1.7 2002/07/17 20:44:57 drobbins Exp $
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.0.4-r2.ebuild,v 1.8 2002/07/24 01:41:48 seemant Exp $
# note to self: check for java deps
S=${WORKDIR}/${P}
DESCRIPTION="Red Hat Package Management Utils"
SRC_URI="ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/${P}.tar.gz"
-SLOT="0"
HOMEPAGE="http://www.rpm.org/"
-LICENSE="GPL|LGPL"
+
+SLOT="0"
+LICENSE="GPL-2 | LGPL-2"
+KEYWORDS="x86 ppc"
RDEPEND="=sys-libs/db-3.2*
>=sys-libs/zlib-1.1.3
@@ -17,45 +19,38 @@ RDEPEND="=sys-libs/db-3.2*
>=dev-libs/popt-1.6.3"
DEPEND="$RDEPEND nls? ( sys-devel/gettext )"
-KEYWORDS="x86 ppc"
src_unpack() {
- unpack ${A}
- cd ${S}
- patch -p1 < ${FILESDIR}/${P}-system-popt.diff
- rm -rf ${S}/popt
- # Suppress pointer warnings
- cp configure configure.orig
- sed -e "s:-Wpointer-arith::" configure.orig > configure
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${P}-system-popt.diff || die
+ rm -rf ${S}/popt
+ # Suppress pointer warnings
+ cp configure configure.orig
+ sed -e "s:-Wpointer-arith::" configure.orig > configure
}
src_compile() {
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
- try ./configure --prefix=/usr --mandir=/usr/share/man ${myconf}
- try make
+ local myconf
+ use nls || myconf="--disable-nls"
+ econf ${myconf} || die
+ make || die
}
src_install() {
- try make DESTDIR=${D} install
- mv ${D}/bin/rpm ${D}/usr/bin
- rm -rf ${D}/bin
+ make DESTDIR=${D} install || die
+ mv ${D}/bin/rpm ${D}/usr/bin
+ rm -rf ${D}/bin
- dodoc CHANGES COPYING CREDITS GROUPS README* RPM* TODO
+ dodoc CHANGES COPYING CREDITS GROUPS README* RPM* TODO
}
pkg_postinst() {
- ${ROOT}/usr/bin/rpm --initdb --root=${ROOT}
+ ${ROOT}/usr/bin/rpm --initdb --root=${ROOT}
}
-
-
-