summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/systemimager-client-bin/Changelog8
-rw-r--r--app-admin/systemimager-client-bin/Manifest2
-rw-r--r--app-admin/systemimager-client-bin/metadata.xml16
-rw-r--r--app-admin/systemimager-client-bin/systemimager-client-bin-3.0.1.ebuild44
4 files changed, 70 insertions, 0 deletions
diff --git a/app-admin/systemimager-client-bin/Changelog b/app-admin/systemimager-client-bin/Changelog
new file mode 100644
index 000000000000..8b7da36eeb23
--- /dev/null
+++ b/app-admin/systemimager-client-bin/Changelog
@@ -0,0 +1,8 @@
+# ChangeLog for app-admin/systemimager-client-bin
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/systemimager-client-bin/Changelog,v 1.1 2003/10/17 12:17:13 bass Exp $
+
+*app-admin/systemimager-client-bin-3.0.1 (17 Oct 2003)
+
+ 17 Oct 2003; José Alberto Suárez López systemimager-client-bin-3.0.1.ebuild:
+ First release
diff --git a/app-admin/systemimager-client-bin/Manifest b/app-admin/systemimager-client-bin/Manifest
new file mode 100644
index 000000000000..380c2267c1ca
--- /dev/null
+++ b/app-admin/systemimager-client-bin/Manifest
@@ -0,0 +1,2 @@
+MD5 238050ca75507a0a9ef850883c4c4f3e systemimager-server-bin-3.0.1.ebuild 931
+MD5 854bb2976a7826f27dc76c0119e142e3 files/digest-systemimager-server-bin-3.0.1 83
diff --git a/app-admin/systemimager-client-bin/metadata.xml b/app-admin/systemimager-client-bin/metadata.xml
new file mode 100644
index 000000000000..72555d99e5fa
--- /dev/null
+++ b/app-admin/systemimager-client-bin/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bass@gentoo.org</email>
+ <name>José Alberto Suárez López</name>
+</maintainer>
+<longdescription>
+SystemImager makes it easy to do automated installs (clones), software distribution, content or data distribution, configuration changes, and operating system updates to your network of Linux machines. You can even update from one Linux release version to another!
+
+It can also be used to ensure safe production deployments. By saving your current production image before updating to your new production image, you have a highly reliable contingency mechanism. If the new production enviroment is found to be flawed, simply roll-back to the last production image with a simple update command!
+
+Some typical environments include: Internet server farms, database server farms, high performance clusters, computer labs, and corporate desktop environments.
+</longdescription>
+</pkgmetadata>
diff --git a/app-admin/systemimager-client-bin/systemimager-client-bin-3.0.1.ebuild b/app-admin/systemimager-client-bin/systemimager-client-bin-3.0.1.ebuild
new file mode 100644
index 000000000000..b87f8b224a59
--- /dev/null
+++ b/app-admin/systemimager-client-bin/systemimager-client-bin-3.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/systemimager-client-bin/systemimager-client-bin-3.0.1.ebuild,v 1.1 2003/10/17 12:17:13 bass Exp $
+
+MY_P="systemimager-client-3.0.1-4.noarch"
+
+S=${WORKDIR}
+DESCRIPTION="System imager client. Software that automates Linux installs, software distribution, and production deployment."
+HOMEPAGE="http://www.systemimager.org/"
+SRC_URI="mirror://sourceforge/systemimager/${MY_P}.rpm"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="app-arch/rpm2targz
+ app-admin/systemimager-common-bin"
+RDEPEND="${DEPEND}
+ dev-perl/AppConfig
+ app-admin/systemconfigurator"
+
+src_unpack() {
+ rpm2targz ${DISTDIR}/${MY_P}.rpm
+ tar zxf ${WORKDIR}/${MY_P}.tar.gz
+}
+
+src_compile() {
+ einfo "nothing to compile; binary package."
+}
+
+src_install() {
+
+#stuff in /usr
+ dosbin usr/sbin/{prepareclient,updateclient}
+ doman usr/share/man/man8/*.gz
+ dodoc usr/share/doc/systemimager-client-3.0.1/*
+
+#stuff in etc
+ mkdir -p ${D}/etc/system/imager
+ insinto /etc/systemimager
+ doins etc/systemimager/{client.conf,updateclient.local.exclude}
+
+}
+