summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sysstat/sysstat-8.0.0.ebuild')
-rw-r--r--app-admin/sysstat/sysstat-8.0.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/sysstat/sysstat-8.0.0.ebuild b/app-admin/sysstat/sysstat-8.0.0.ebuild
new file mode 100644
index 000000000000..f6d04e609984
--- /dev/null
+++ b/app-admin/sysstat/sysstat-8.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/sysstat-8.0.0.ebuild,v 1.1 2007/09/08 11:00:27 jer Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="System performance tools for Linux"
+HOMEPAGE="http://perso.wanadoo.fr/sebastien.godard/"
+SRC_URI="http://perso.orange.fr/sebastien.godard/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch ${FILESDIR}/${PN}-7.1.4-strip.patch || die "${P}-strip.patch failed"
+}
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake LFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ keepdir /var/log/sa
+
+ emake DESTDIR=${D} DOC_DIR=/usr/share/doc/${PF} \
+ install || die "make install failed"
+
+ newdoc sysstat.crond.sample crontab.example
+ newinitd "${FILESDIR}"/sysstat.init.d sysstat
+}