summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/radmind')
-rw-r--r--app-admin/radmind/ChangeLog7
-rw-r--r--app-admin/radmind/radmind-1.13.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-admin/radmind/ChangeLog b/app-admin/radmind/ChangeLog
index 2ec6de98de71..8d3a6bb9f4db 100644
--- a/app-admin/radmind/ChangeLog
+++ b/app-admin/radmind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/radmind
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/radmind/ChangeLog,v 1.11 2010/06/02 21:36:38 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/radmind/ChangeLog,v 1.12 2010/06/03 08:23:42 patrick Exp $
+
+*radmind-1.13.0 (03 Jun 2010)
+
+ 03 Jun 2010; Patrick Lauer <patrick@gentoo.org> +radmind-1.13.0.ebuild:
+ Bump
02 Jun 2010; Patrick Lauer <patrick@gentoo.org> radmind-1.7.1-r1.ebuild:
Adding ~amd64 keyword
diff --git a/app-admin/radmind/radmind-1.13.0.ebuild b/app-admin/radmind/radmind-1.13.0.ebuild
new file mode 100644
index 000000000000..f15cb9de9476
--- /dev/null
+++ b/app-admin/radmind/radmind-1.13.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/radmind/radmind-1.13.0.ebuild,v 1.1 2010/06/03 08:23:42 patrick Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A suite of Unix command-line tools and a server designed to remotely administer the file systems of multiple Unix machines."
+HOMEPAGE="http://rsug.itd.umich.edu/software/radmind/"
+SRC_URI="mirror://sourceforge/radmind/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.0-gentoo.patch
+ # remove dnssd as it doesn't compile
+ epatch "${FILESDIR}"/${PN}-1.7.1-dnssd.patch
+}
+
+src_configure() {
+ econf $(use_with ssl) || die "econf failed"
+}
+
+src_compile() {
+ # bug #239862
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README VERSION COPYRIGHT
+}