summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pwgen/pwgen-2.01.ebuild')
-rw-r--r--app-admin/pwgen/pwgen-2.01.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/app-admin/pwgen/pwgen-2.01.ebuild b/app-admin/pwgen/pwgen-2.01.ebuild
index 3d4b94440614..693a4f1f767c 100644
--- a/app-admin/pwgen/pwgen-2.01.ebuild
+++ b/app-admin/pwgen/pwgen-2.01.ebuild
@@ -1,24 +1,20 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/pwgen/pwgen-2.01.ebuild,v 1.20 2004/06/24 21:35:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pwgen/pwgen-2.01.ebuild,v 1.21 2004/06/25 20:38:14 vapier Exp $
DESCRIPTION="Password Generator"
-SRC_URI="mirror://sourceforge/pwgen/${P}.tar.gz"
HOMEPAGE="http://sourceforge.net/projects/pwgen/"
+SRC_URI="mirror://sourceforge/pwgen/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc ~alpha hppa"
IUSE="livecd"
-KEYWORDS="x86 ppc sparc hppa ~alpha"
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
- # Fix the Makefile
- cp Makefile.in Makefile.in.new
- sed -e 's:$(prefix)/man/man1:$(mandir)/man1:g' \
- Makefile.in.new > Makefile.in
-
+ sed -i -e 's:$(prefix)/man/man1:$(mandir)/man1:g' Makefile.in
econf --sysconfdir=/etc/pwgen || die "econf failed"
emake || die
}