summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/eselect-python')
-rw-r--r--app-admin/eselect-python/eselect-python-20090606.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-admin/eselect-python/eselect-python-20090606.ebuild b/app-admin/eselect-python/eselect-python-20090606.ebuild
index a0682b4bfef9..cc25573790f0 100644
--- a/app-admin/eselect-python/eselect-python-20090606.ebuild
+++ b/app-admin/eselect-python/eselect-python-20090606.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20090606.ebuild,v 1.7 2009/07/11 20:40:16 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20090606.ebuild,v 1.8 2009/08/25 17:31:16 arfrever Exp $
DESCRIPTION="Manages multiple Python versions"
HOMEPAGE="http://www.gentoo.org"
@@ -13,6 +13,12 @@ IUSE=""
RDEPEND=">=app-admin/eselect-1.0.2"
+pkg_setup() {
+ if has_version ">=app-admin/eselect-python-20090804"; then
+ die "Downgrade of app-admin/eselect-python is not supported"
+ fi
+}
+
src_install() {
insinto /usr/share/eselect/modules
newins "${WORKDIR}/python.eselect-${PVR}" python.eselect || die "newins python.eselect failed"