summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Math-Random-ISAAC-XS/ChangeLog8
-rw-r--r--dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0.ebuild25
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-perl/Math-Random-ISAAC-XS/ChangeLog b/dev-perl/Math-Random-ISAAC-XS/ChangeLog
index 703ca1151a46..06e81665bac2 100644
--- a/dev-perl/Math-Random-ISAAC-XS/ChangeLog
+++ b/dev-perl/Math-Random-ISAAC-XS/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Math-Random-ISAAC-XS
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Math-Random-ISAAC-XS/ChangeLog,v 1.8 2011/08/27 20:11:32 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Math-Random-ISAAC-XS/ChangeLog,v 1.9 2011/08/30 10:27:00 tove Exp $
+
+*Math-Random-ISAAC-XS-1.4.0 (30 Aug 2011)
+
+ 30 Aug 2011; Torsten Veller <tove@gentoo.org>
+ +Math-Random-ISAAC-XS-1.4.0.ebuild:
+ Change version scheme
27 Aug 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
Math-Random-ISAAC-XS-1.4.ebuild:
diff --git a/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0.ebuild b/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0.ebuild
new file mode 100644
index 000000000000..39eae193383c
--- /dev/null
+++ b/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Math-Random-ISAAC-XS/Math-Random-ISAAC-XS-1.4.0.ebuild,v 1.1 2011/08/30 10:27:00 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=JAWNSY
+MODULE_VERSION=1.004
+inherit perl-module
+
+DESCRIPTION="C implementation of the ISAAC PRNG algorithm"
+
+LICENSE="|| ( public-domain Artistic Artistic-2 GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/Math-Random-ISAAC"
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build
+ test? (
+ dev-perl/Test-NoWarnings
+ )"
+
+SRC_TEST="do"