summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/rdiscount/ChangeLog9
-rw-r--r--dev-ruby/rdiscount/rdiscount-1.6.8.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-ruby/rdiscount/ChangeLog b/dev-ruby/rdiscount/ChangeLog
index 639d3e01a7f7..51eff0986658 100644
--- a/dev-ruby/rdiscount/ChangeLog
+++ b/dev-ruby/rdiscount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rdiscount
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/ChangeLog,v 1.1 2010/09/14 18:58:10 graaff Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/ChangeLog,v 1.2 2011/01/28 08:10:52 graaff Exp $
+
+*rdiscount-1.6.8 (28 Jan 2011)
+
+ 28 Jan 2011; Hans de Graaff <graaff@gentoo.org> +rdiscount-1.6.8.ebuild:
+ Version bump.
*rdiscount-1.6.5 (14 Sep 2010)
diff --git a/dev-ruby/rdiscount/rdiscount-1.6.8.ebuild b/dev-ruby/rdiscount/rdiscount-1.6.8.ebuild
new file mode 100644
index 000000000000..46d91cbf6c66
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-1.6.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/rdiscount-1.6.8.ebuild,v 1.1 2011/01/28 08:10:52 graaff Exp $
+
+EAPI=2
+
+# Has a native extension without jruby support.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="http://github.com/rtomayko/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "doc? ( app-text/ronn )"
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext || die
+ cp ext/*$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}