summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-extra/nautilus-sendto/ChangeLog9
-rw-r--r--gnome-extra/nautilus-sendto/files/digest-nautilus-sendto-0.103
-rw-r--r--gnome-extra/nautilus-sendto/files/nautilus-sendto-0.10-configure-options.patch173
-rw-r--r--gnome-extra/nautilus-sendto/nautilus-sendto-0.10.ebuild82
4 files changed, 266 insertions, 1 deletions
diff --git a/gnome-extra/nautilus-sendto/ChangeLog b/gnome-extra/nautilus-sendto/ChangeLog
index f34853f60860..c334f8e2e9b8 100644
--- a/gnome-extra/nautilus-sendto/ChangeLog
+++ b/gnome-extra/nautilus-sendto/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/nautilus-sendto
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/ChangeLog,v 1.10 2007/03/22 17:42:34 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/ChangeLog,v 1.11 2007/03/22 20:29:06 compnerd Exp $
+
+*nautilus-sendto-0.10 (22 Mar 2007)
+
+ 22 Mar 2007; <compnerd@gentoo.org>
+ +files/nautilus-sendto-0.10-configure-options.patch,
+ +nautilus-sendto-0.10.ebuild:
+ Version bump from upstream
22 Mar 2007; <compnerd@gentoo.org> nautilus-sendto-0.8-r1.ebuild:
Keyword ~amd64
diff --git a/gnome-extra/nautilus-sendto/files/digest-nautilus-sendto-0.10 b/gnome-extra/nautilus-sendto/files/digest-nautilus-sendto-0.10
new file mode 100644
index 000000000000..1609ea144dd1
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/files/digest-nautilus-sendto-0.10
@@ -0,0 +1,3 @@
+MD5 cc47d4364d71d6f35776c5634e2f1ed1 nautilus-sendto-0.10.tar.bz2 322104
+RMD160 a3a75070b7d08e61a3e84920e288ee013de275a9 nautilus-sendto-0.10.tar.bz2 322104
+SHA256 f5d3a654070464929c751775c767cf39ce27f8f37a7d9ef5f336598631d3ea8d nautilus-sendto-0.10.tar.bz2 322104
diff --git a/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.10-configure-options.patch b/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.10-configure-options.patch
new file mode 100644
index 000000000000..866da5b645f0
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/files/nautilus-sendto-0.10-configure-options.patch
@@ -0,0 +1,173 @@
+--- configure.in.orig 2007-03-22 14:50:03.000000000 -0500
++++ configure.in 2007-03-22 15:15:03.000000000 -0500
+@@ -58,60 +58,57 @@
+ AC_SUBST(NAUTILUS_EXT_SENDTO_CFLAGS)
+ AC_SUBST(NAUTILUS_EXT_SENDTO_LIBS)
+
+-dnl Libebook support
++dnl Evolution (libebook) support
+ dnl ---------------------------------
+
+-PKG_CHECK_MODULES(NST_EBOOK, libebook-1.2 >= $EBOOK_REQUIRED,
+- [
+- AC_SUBST(NST_EBOOK_CFLAGS)
+- AC_SUBST(NST_EBOOK_LIBS)
+- echo "Using libebook-1.2 !"
+- enable_evolution=yes
+- ],
+- [
+- echo "Building without evolution"
+- enable_evolution=no
+- ]
+-)
++AC_ARG_ENABLE([evolution],
++ AC_HELP_STRING([--enable-evolution], [enable support for evolution]),,
++ [enable_evolution=no])
++
++if test x$enable_evolution = xyes ; then
++ PKG_CHECK_MODULES(NST_EBOOK, [libebook-1.2 >= $EBOOK_REQUIRED])
++
++ AC_SUBST(NST_EBOOK_CFLAGS)
++ AC_SUBST(NST_EBOOK_LIBS)
++fi
+
+ AM_CONDITIONAL(HAVE_EVOLUTION, test "x$enable_evolution" = "xyes")
+
+-dnl Gaim support if it's installed
++dnl Gaim support
+ dnl ---------------------------------
+
++AC_ARG_ENABLE([gaim],
++ AC_HELP_STRING([--enable-gaim], [enable support for gaim]),,
++ [enable_gaim=no])
+
+-PKG_CHECK_MODULES(GAIM, gaim >= $GAIM_REQUIRED,
+- [
+- AC_SUBST(GAIM_CFLAGS)
+- AC_SUBST(GAIM_LIBS)
+- GAIM_LIBDIR=`pkg-config --variable=libdir gaim`
+- GAIM_DATADIR=`pkg-config --variable=datadir gaim`
+- AC_SUBST(GAIM_LIBDIR)
+- AC_SUBST(GAIM_DATADIR)
+- enable_gaim=yes
+- ],
+- [
+- echo "Building without gaim"
+- enable_gaim=no
+- ]
+-)
++if test x$enable_gaim = xyes ; then
++ PKG_CHECK_MODULES(GAIM, [gaim >= $GAIM_REQUIRED])
++
++ AC_SUBST(GAIM_CFLAGS)
++ AC_SUBST(GAIM_LIBS)
++
++ GAIM_LIBDIR=`pkg-config --variable=libdir gaim`
++ GAIM_DATADIR=`pkg-config --variable=datadir gaim`
++
++ AC_SUBST(GAIM_LIBDIR)
++ AC_SUBST(GAIM_DATADIR)
++fi
+
+ AM_CONDITIONAL(HAVE_GAIM, test "x$enable_gaim" = "xyes")
+
+-dnl Bluetooth support if it's installed
++dnl Bluetooth support
+ dnl -----------------------------------
+
+-PKG_CHECK_MODULES(BLUETOOTH, dbus-glib-1 >= $DBUS_REQUIRED,
+- [
+- AC_SUBST(BLUETOOTH_CFLAGS)
+- AC_SUBST(BLUETOOTH_LIBS)
+- enable_bluetooth=yes
+- ],
+- [
+- echo "Building without Bluetooth"
+- enable_bluetooth=no
+- ]
+-)
++AC_ARG_ENABLE([bluetooth],
++ AC_HELP_STRING([--enable-bluetooth],[enable support for bluetooth]),,
++ [enable_bluetooth=no])
++
++if test x$enable_bluetooth = xyes ; then
++ PKG_CHECK_MODULES(BLUETOOTH, [gnome-bluetooth >= $BLUETOOTH_REQUIRED dbus-glib-1 >= $DBUS_REQUIRED])
++
++ AC_SUBST(BLUETOOTH_CFLAGS)
++ AC_SUBST(BLUETOOTH_LIBS)
++fi
+
+ AM_CONDITIONAL(HAVE_BLUETOOTH, test "x$enable_bluetooth" = "xyes")
+
+@@ -123,7 +120,9 @@
+ dnl Balsa support
+ dnl -------------------------------------------------
+
+-enable_balsa=no
++AC_ARG_ENABLE([balsa],
++ AC_HELP_STRING([--enable-balsa],[enable support for balsa]),,
++ [enable_balsa=no])
+ AM_CONDITIONAL(HAVE_BALSA, test "x$enable_balsa" = "xyes")
+ dnl -------------------------------------------------
+
+@@ -131,7 +130,9 @@
+ dnl Sylpheed support
+ dnl -------------------------------------------------
+
+-enable_sylpheed=yes
++AC_ARG_ENABLE([sylpheed],
++ AC_HELP_STRING([--enable-sylpheed],[enable support for sylpheed]),,
++ [enable_sylpheed=no])
+ AM_CONDITIONAL(HAVE_SYLPHEED, test "x$enable_sylpheed" = "xyes")
+ dnl -------------------------------------------------
+
+@@ -139,7 +140,9 @@
+ dnl Thunderbird support
+ dnl -------------------------------------------------
+
+-enable_thunderbird=no
++AC_ARG_ENABLE([thunderbird],
++ AC_HELP_STRING([--enable-thunderbird],[enable support for thunderbird]),,
++ [enable_thunderbird=no])
+ AM_CONDITIONAL(HAVE_THUNDERBIRD, test "x$enable_thunderbird" = "xyes")
+ dnl -------------------------------------------------
+
+@@ -152,24 +155,20 @@
+
+ GAJIM_SHARE_DIR="$GAJIM_PATH"/share/gajim
+
+-PKG_CHECK_MODULES(DBUS, dbus-1 >= $DBUS_REQUIRED dbus-glib-1 >= $DBUS_REQUIRED,
+- [
+- AC_SUBST(DBUS_CFLAGS)
+- AC_SUBST(DBUS_LIBS)
+- if test -f "$GAJIM_SHARE_DIR"/data/pixmaps/gajim.png ;
+- then
+- enable_gajim=yes
+- AC_DEFINE_UNQUOTED(GAJIM_SHARE_DIR, "$GAJIM_SHARE_DIR", [path to gajim share dir])
+- else
+- echo "Building without Gajim support"
+- enable_gajim=no
+- fi
+- ],
+- [
+- echo "Building without Gajim support"
+- enable_gajim=no
+- ]
+-)
++AC_ARG_ENABLE([gajim],
++ AC_HELP_STRING([--enable-gajim],[enable support for gajim]),,
++ [enable_gajim=no])
++
++if test x$enable_gajim = xyes ; then
++ if test -f "$GAJIM_SHARE_DIR"/data/pixmaps/gajim.png ; then
++ enable_gajim=yes
++ AC_DEFINE_UNQUOTED(GAJIM_SHARE_DIR, "$GAJIM_SHARE_DIR", [path to gajim share dir])
++
++ PKG_CHECK_MODULES(DBUS, [dbus-1 >= $DBUS_REQUIRED dbus-glib-1 >= $DBUS_REQUIRED])
++ else
++ enable_gajim=no
++ fi
++fi
+
+ AM_CONDITIONAL(HAVE_GAJIM, test "x$enable_gajim" = "xyes")
+
diff --git a/gnome-extra/nautilus-sendto/nautilus-sendto-0.10.ebuild b/gnome-extra/nautilus-sendto/nautilus-sendto-0.10.ebuild
new file mode 100644
index 000000000000..cbf598ef53fa
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/nautilus-sendto-0.10.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/nautilus-sendto-0.10.ebuild,v 1.1 2007/03/22 20:29:06 compnerd Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="A nautilus extension for sending files to locations"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="bluetooth eds gaim gajim sylpheed thunderbird"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.6
+ >=gnome-base/libglade-2.5.1
+ >=gnome-base/libbonobo-2.13.0
+ >=gnome-base/libbonoboui-2.13.0
+ >=gnome-base/libgnome-2.13.0
+ >=gnome-base/libgnomeui-2.13.0
+ >=gnome-base/nautilus-2.13.3
+ >=gnome-base/gconf-2.13.0
+ || (
+ >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.60 )
+ )
+ bluetooth? ( >=net-wireless/gnome-bluetooth-0.6 )
+ eds? ( >=gnome-extra/evolution-data-server-1.5.3 )
+ gaim? ( >=net-im/gaim-1.5.0 )
+ gajim? ( net-im/gajim )
+ sylpheed? ( || (
+ mail-client/sylpheed
+ mail-client/claws-mail
+ mail-client/sylpheed-claws
+ )
+ )
+ thunderbird? ( mail-client/mozilla-thunderbird )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} \
+ $(use_enable bluetooth) \
+ $(use_enable eds evolution) \
+ $(use_enable gaim) \
+ $(use_enable gajim) \
+ $(use_enable sylpheed) \
+ $(use_enable thunderbird)"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Convert autodetection into hard options
+ epatch ${FILESDIR}/${PN}-0.10-configure-options.patch
+
+ # Add support for gaim 2.0
+ if has_version '=net-im/gaim-2*' ; then
+ epatch ${FILESDIR}/${PN}-0.8-gaim-2.0-plugin.patch
+ fi
+
+ # Fix thunderbird support
+ epatch ${FILESDIR}/${PN}-0.8-thunderbird-binaries.patch
+
+ # Oh the joys of autotools
+ eautoreconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if use gaim ; then
+ elog "To enable SendTo support in GAIM, you must enable the plugin in GAIM"
+ elog "Check Tools -> Preferences -> Plugins in the GAIM menu."
+ fi
+}