summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/opera/ChangeLog8
-rw-r--r--www-client/opera/files/digest-opera-9.00_pre212
-rw-r--r--www-client/opera/files/opera-9.00_pre2-install.patch12
-rw-r--r--www-client/opera/opera-9.00_pre2.ebuild144
4 files changed, 175 insertions, 1 deletions
diff --git a/www-client/opera/ChangeLog b/www-client/opera/ChangeLog
index 5a8a0ed243f1..eee81c9dd40c 100644
--- a/www-client/opera/ChangeLog
+++ b/www-client/opera/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/opera
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera/ChangeLog,v 1.43 2006/05/30 11:20:22 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/ChangeLog,v 1.44 2006/05/30 11:52:07 axxo Exp $
+
+*opera-9.00_pre2 (30 May 2006)
+
+ 30 May 2006; Thomas Matthijs <axxo@gentoo.org>
+ +files/opera-9.00_pre2-install.patch, +opera-9.00_pre2.ebuild:
+ opera 9 beta ebuild from 122036
30 May 2006; Thomas Matthijs <axxo@gentoo.org>
+files/opera-8.54-install.patch, opera-8.54.ebuild:
diff --git a/www-client/opera/files/digest-opera-9.00_pre2 b/www-client/opera/files/digest-opera-9.00_pre2
new file mode 100644
index 000000000000..058a12f6cda4
--- /dev/null
+++ b/www-client/opera/files/digest-opera-9.00_pre2
@@ -0,0 +1,12 @@
+MD5 9b1750cacca27541cfc83400ee0cbfda opera-9.0-20060518.1-static-qt.i386-en-284.tar.bz2 6639458
+RMD160 f7e98bda5549db7841407ae33b23eed0719f822a opera-9.0-20060518.1-static-qt.i386-en-284.tar.bz2 6639458
+SHA256 94f067f766b06d1454b7abba63562a6a19f252c66ab221bf03af1f68b20e5754 opera-9.0-20060518.1-static-qt.i386-en-284.tar.bz2 6639458
+MD5 928d594cdec0118843a0466f7c75251c opera-9.0-20060518.1-static-qt.ppc-en-284.tar.bz2 6674777
+RMD160 3a91b95cb4f81688c7cef6c93cccb50b06f51865 opera-9.0-20060518.1-static-qt.ppc-en-284.tar.bz2 6674777
+SHA256 561380909d79d64b2fde18e7c4588efe69f2c40defe95169ab2151ad0361b2cc opera-9.0-20060518.1-static-qt.ppc-en-284.tar.bz2 6674777
+MD5 201c1927677939ab596f8c940f9fd059 opera-9.0-20060518.1-static-qt.sparc-en-284.tar.bz2 6566633
+RMD160 5ef2040ee30a455c8b9b05bc9b28bb35f2764ff8 opera-9.0-20060518.1-static-qt.sparc-en-284.tar.bz2 6566633
+SHA256 d8479ea2b6785196f3492008218b12b9d76e5c407d6ab876e2a393137a917bbc opera-9.0-20060518.1-static-qt.sparc-en-284.tar.bz2 6566633
+MD5 4ea4938d39ae8c29c44208b246501cf6 opera-9.0-20060518.5-shared-qt.i386-en-284.tar.bz2 4816367
+RMD160 e4607530604e889d1f7728e72b2efdf8cfd566ee opera-9.0-20060518.5-shared-qt.i386-en-284.tar.bz2 4816367
+SHA256 53b7ea48575732efc4451414c2c0865cea4849e6f2615c30e44380b6b69923ac opera-9.0-20060518.5-shared-qt.i386-en-284.tar.bz2 4816367
diff --git a/www-client/opera/files/opera-9.00_pre2-install.patch b/www-client/opera/files/opera-9.00_pre2-install.patch
new file mode 100644
index 000000000000..007974e8d0a2
--- /dev/null
+++ b/www-client/opera/files/opera-9.00_pre2-install.patch
@@ -0,0 +1,12 @@
+--- install.sh.orig 2006-05-30 13:11:54.000000000 +0200
++++ install.sh 2006-05-30 13:12:28.000000000 +0200
+@@ -1835,6 +1835,9 @@
+
+ xdg()
+ { # http://standards.freedesktop.org
++
++ return; # Handled by ebuild.
++
+ UDD=''
+ for BIN_DIR in `pathdirs`; do
+ test -x ${BIN_DIR}/update-desktop-database || continue
diff --git a/www-client/opera/opera-9.00_pre2.ebuild b/www-client/opera/opera-9.00_pre2.ebuild
new file mode 100644
index 000000000000..37bdc497e39f
--- /dev/null
+++ b/www-client/opera/opera-9.00_pre2.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-9.00_pre2.ebuild,v 1.1 2006/05/30 11:52:07 axxo Exp $
+
+inherit eutils gnome2
+
+IUSE="qt-static spell gnome"
+
+OPERAVER="9.0-20060518"
+OPERAFTPDIR="900/beta2/en"
+OPERASUFF="en-284"
+
+S=${WORKDIR}/${A/.tar.bz2/}
+
+DESCRIPTION="Opera web browser."
+HOMEPAGE="http://www.opera.com"
+
+# that's an ugly workaround for the broken src_uri syntax
+OPERA_URI="mirror://opera/linux/${OPERAFTPDIR}/"
+SRC_URI="
+ x86? ( qt-static? ( ${OPERA_URI}i386/static/${PN}-${OPERAVER}.1-static-qt.i386-${OPERASUFF}.tar.bz2 ) )
+ x86? ( !qt-static? ( ${OPERA_URI}i386/shared/${PN}-${OPERAVER}.5-shared-qt.i386-${OPERASUFF}.tar.bz2 ) )
+ amd64? ( qt-static? ( ${OPERA_URI}i386/static/${PN}-${OPERAVER}.1-static-qt.i386-${OPERASUFF}.tar.bz2 ) )
+ amd64? ( !qt-static? ( ${OPERA_URI}i386/shared/${PN}-${OPERAVER}.5-shared-qt.i386-${OPERASUFF}.tar.bz2 ) )
+ sparc? ( ${OPERA_URI}sparc/static/${PN}-${OPERAVER}.1-static-qt.sparc-${OPERASUFF}.tar.bz2 )
+ ppc? ( ${OPERA_URI}ppc/static/${PN}-${OPERAVER}.1-static-qt.ppc-${OPERASUFF}.tar.bz2 )"
+
+# Dependencies may be augmented later (see below).
+DEPEND=">=sys-apps/sed-4
+ amd64? ( sys-apps/setarch )"
+
+RDEPEND="|| ( ( x11-libs/libXrandr
+ x11-libs/libXp
+ x11-libs/libXmu
+ x11-libs/libXi
+ x11-libs/libXft
+ x11-libs/libXext
+ x11-libs/libXcursor
+ x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libICE
+ )
+ virtual/x11
+ )
+ >=media-libs/fontconfig-2.1.94-r1
+ amd64? ( qt-static? ( app-emulation/emul-linux-x86-xlibs )
+ !qt-static? ( app-emulation/emul-linux-x86-qtlibs ) )
+ !amd64? ( media-libs/libexif
+ spell? ( app-text/aspell )
+ x86? ( !qt-static? ( =x11-libs/qt-3* ) )
+ media-libs/jpeg )"
+
+SLOT="0"
+LICENSE="OPERA-9.0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+src_unpack() {
+ unpack ${A}
+ echo ${S}
+ cd ${S}
+ epatch "${FILESDIR}/${P}-install.patch"
+ sed -i -e "s:config_dir=\"/etc\":config_dir=\"${D}/etc/\":g" \
+ -e "s:/usr/share/applnk:${D}/usr/share/applnk:g" \
+ -e "s:/usr/share/pixmaps:${D}/usr/share/pixmaps:g" \
+ -e "s:/usr/share/icons:${D}/usr/share/icons:g" \
+ -e "s:/etc/X11:${D}/etc/X11:g" \
+ -e "s:/usr/share/gnome:${D}/usr/share/gnome:g" \
+ -e "s:/opt/gnome/share:${D}/opt/gnome/share:g" \
+ -e 's:#\(OPERA_FORCE_JAVA_ENABLED=\):\1:' \
+ -e 's:#\(export LD_PRELOAD OPERA_FORCE_JAVA_ENABLED\):\1:' \
+ -e 's:read str_answer:return 0:' \
+ -e "s:/opt/kde:${D}/usr/kde:" \
+ -e "s:\(str_localdirplugin=\).*$:\1/opt/opera/lib/opera/plugins:" \
+ install.sh || die
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ # Prepare installation directories for Opera's installer script.
+ dodir /etc
+
+ # Opera's native installer.
+ if [ ${ARCH} = "amd64" ]; then
+ linux32 ./install.sh --prefix="${D}"/opt/opera || die
+ else
+ ./install.sh --prefix="${D}"/opt/opera || die
+ fi
+
+ # java workaround
+ sed -i -e 's:LD_PRELOAD="${OPERA_JAVA_DIR}/libawt.so":LD_PRELOAD="$LD_PRELOAD"\:"${OPERA_JAVA_DIR}/libawt.so":' ${D}/opt/opera/bin/opera
+
+ dosed /opt/opera/bin/opera
+ dosed /opt/opera/share/opera/java/opera.policy
+
+ # Install the icons
+ insinto /usr/share/pixmaps
+ doins images/opera.xpm
+ for res in 16x16 22x22 32x32 48x48 ; do
+ insinto /usr/share/icons/hicolor/${res}/apps/
+ newins images/opera_${res}.png opera.png
+ done
+
+ # Install the menu entry
+ insinto /usr/share/applications
+ doins ${FILESDIR}/opera.desktop
+
+ # Install a symlink /usr/bin/opera
+ dodir /usr/bin
+ dosym /opt/opera/bin/opera /usr/bin/opera
+
+ # fix plugin path
+ echo "Plugin Path=/opt/opera/lib/opera/plugins" >> ${D}/etc/opera6rc
+
+ # enable spellcheck
+ if use spell; then
+ if use qt-static; then
+ DIR=$OPERAVER.1
+ else
+ use sparc && DIR=$OPERAVER.2 || DIR=$OPERAVER.5
+ fi
+ echo "Spell Check Engine=/opt/opera/lib/opera/${DIR}/spellcheck.so" >> ${D}/opt/opera/share/opera/ini/spellcheck.ini
+ fi
+
+ dodir /etc/revdep-rebuild
+ echo 'SEARCH_DIRS_MASK="/opt/opera/lib/opera/plugins"' > ${D}/etc/revdep-rebuild/90opera
+}
+
+pkg_postinst() {
+ use gnome && gnome2_pkg_postinst
+
+ einfo "For localized language files take a look at:"
+ einfo "http://www.opera.com/download/languagefiles/index.dml?platform=linux"
+ einfo
+ einfo "To change the spellcheck language edit /opt/opera/share/opera/ini/spellcheck.ini"
+ einfo "and emerge app-text/aspell-language."
+}
+
+
+pkg_postrm() {
+ use gnome && gnome2_pkg_postrm
+}