summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libmicrohttpd/ChangeLog8
-rw-r--r--net-libs/libmicrohttpd/files/libmicrohttpd-0.9.26-fix-doc-build.patch23
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.26.ebuild55
3 files changed, 85 insertions, 1 deletions
diff --git a/net-libs/libmicrohttpd/ChangeLog b/net-libs/libmicrohttpd/ChangeLog
index ce6abd22cf07..e8adee97d5ce 100644
--- a/net-libs/libmicrohttpd/ChangeLog
+++ b/net-libs/libmicrohttpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libmicrohttpd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.29 2013/02/06 01:20:08 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.30 2013/03/30 21:11:24 blueness Exp $
+
+*libmicrohttpd-0.9.26 (30 Mar 2013)
+
+ 30 Mar 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/libmicrohttpd-0.9.26-fix-doc-build.patch, +libmicrohttpd-0.9.26.ebuild:
+ Version bump
*libmicrohttpd-0.9.25 (06 Feb 2013)
diff --git a/net-libs/libmicrohttpd/files/libmicrohttpd-0.9.26-fix-doc-build.patch b/net-libs/libmicrohttpd/files/libmicrohttpd-0.9.26-fix-doc-build.patch
new file mode 100644
index 000000000000..9e60f2724f30
--- /dev/null
+++ b/net-libs/libmicrohttpd/files/libmicrohttpd-0.9.26-fix-doc-build.patch
@@ -0,0 +1,23 @@
+diff -Naur libmicrohttpd-0.9.26.orig/doc/examples/Makefile.am libmicrohttpd-0.9.26/doc/examples/Makefile.am
+--- libmicrohttpd-0.9.26.orig/doc/examples/Makefile.am 2013-03-29 12:21:07.000000000 -0400
++++ libmicrohttpd-0.9.26/doc/examples/Makefile.am 2013-03-30 17:04:34.000000000 -0400
+@@ -18,15 +18,16 @@
+ basicauthentication \
+ hellobrowser \
+ logging \
+- responseheaders \
+- sessions
++ responseheaders
+
+ if ENABLE_HTTPS
+ noinst_PROGRAMS += \
+ tlsauthentication
+ endif
+ if HAVE_POSTPROCESSOR
+-noinst_PROGRAMS += simplepost largepost
++noinst_PROGRAMS += \
++ simplepost largepost \
++ sessions
+ endif
+
+ if HAVE_W32
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.26.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.26.ebuild
new file mode 100644
index 000000000000..e6147705a91e
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.26.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/libmicrohttpd-0.9.26.ebuild,v 1.1 2013/03/30 21:11:24 blueness Exp $
+
+EAPI="5"
+
+inherit eutils autotools
+
+MY_P="${P/_/}"
+
+DESCRIPTION="A small C library that makes it easy to run an HTTP server as part of another application."
+HOMEPAGE="http://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+IUSE="messages ssl static-libs test"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt
+ net-libs/gnutls
+ )"
+
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( >=net-misc/curl-7.25.0-r1[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-doc-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable messages postprocessor) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}