summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/xindice/ChangeLog10
-rw-r--r--dev-db/xindice/files/21xindice1
-rw-r--r--dev-db/xindice/files/digest-xindice-1.04
-rw-r--r--dev-db/xindice/files/xindice23
-rw-r--r--dev-db/xindice/files/xindice-1.0.patch28
-rw-r--r--dev-db/xindice/xindice-1.0.ebuild62
6 files changed, 126 insertions, 2 deletions
diff --git a/dev-db/xindice/ChangeLog b/dev-db/xindice/ChangeLog
new file mode 100644
index 000000000000..601bdb74a8f2
--- /dev/null
+++ b/dev-db/xindice/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-db/xindice
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/xindice/ChangeLog,v 1.1 2003/04/11 20:10:21 phosphan Exp $
+
+*xindice-1.0 (11 Apr 2003)
+
+ 11 Apr 2003; Patrick Kursawe <phosphan@gentoo.org> xindice-1.0.ebuild,
+ files/21xindice, files/xindice-1.0.patch, ChangeLog, files/xindice :
+ Initial import. Ebuild submitted by Matthieu Sozeau <mattam@netcourrier.com>
+ and modified by myself.
diff --git a/dev-db/xindice/files/21xindice b/dev-db/xindice/files/21xindice
new file mode 100644
index 000000000000..af062f72f9e1
--- /dev/null
+++ b/dev-db/xindice/files/21xindice
@@ -0,0 +1 @@
+XINDICE_HOME=/opt/xindice
diff --git a/dev-db/xindice/files/digest-xindice-1.0 b/dev-db/xindice/files/digest-xindice-1.0
index 358fce584c70..928a119929fc 100644
--- a/dev-db/xindice/files/digest-xindice-1.0
+++ b/dev-db/xindice/files/digest-xindice-1.0
@@ -1,5 +1,5 @@
-MD5 40d7ad6d12e193b661c2241c9faf82a7 /files/xindice 493
+MD5 e60da088b700fb70b44c177f41325953 /files/xindice 586
MD5 c87c4724c3cbf94d7c0379589a13ad2b /files/21xindice 26
MD5 c2e834a3314f4a4d91fbb3b1df7d7e47 /files/xindice-1.0.patch 725
-MD5 3d2929ad36839d3de0803fde56968acf /xindice-1.0.ebuild 1578
+MD5 adb46b55e2bc4515eab01c4a6bed4df6 /xindice-1.0.ebuild 1676
MD5 895bf529f483be5885cf4c963b4111a8 xml-xindice-1.0.tar.gz 5304315
diff --git a/dev-db/xindice/files/xindice b/dev-db/xindice/files/xindice
new file mode 100644
index 000000000000..b7392ab22d48
--- /dev/null
+++ b/dev-db/xindice/files/xindice
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/xindice/files/xindice,v 1.1 2003/04/11 20:10:21 phosphan Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting xindice..."
+ start-stop-daemon --pidfile /var/run/xindice/xindice.pid\
+ --start --background --user xindice --chuid xindice\
+ --exec /opt/xindice/start
+ eend $?
+}
+
+
+stop() {
+ ebegin "Stopping xindice..."
+ start-stop-daemon --pidfile /var/run/xindice/xindice.pid --stop --retry 10
+ eend $?
+}
diff --git a/dev-db/xindice/files/xindice-1.0.patch b/dev-db/xindice/files/xindice-1.0.patch
new file mode 100644
index 000000000000..aaae16545888
--- /dev/null
+++ b/dev-db/xindice/files/xindice-1.0.patch
@@ -0,0 +1,28 @@
+--- start 2003-04-07 15:44:25.000000000 +0200
++++ start.new 2003-04-07 15:53:39.000000000 +0200
+@@ -11,8 +11,8 @@
+ echo "-----------"
+ echo "XINDICE_HOME = " $XINDICE_HOME
+
+-if test -f $XINDICE_HOME/config/xindice.pid; then
+- echo "A Xindice instance is already running with PID" `cat $XINDICE_HOME/config/xindice.pid`
++if test -f /var/run/xindice/xindice.pid; then
++ echo "A Xindice instance is already running with PID" `cat /var/run/xindice/xindice.pid`
+ exit
+ fi
+
+@@ -42,7 +42,7 @@
+
+ cd $XINDICE_HOME
+
+-echo $$ > $XINDICE_HOME/config/xindice.pid
++echo $$ > /var/run/xindice/xindice.pid
+
+ RESTART=1
+
+@@ -73,4 +73,4 @@
+ done
+
+ trap 1 2 15
+-rm $XINDICE_HOME/config/xindice.pid
++rm /var/run/xindice/xindice.pid
diff --git a/dev-db/xindice/xindice-1.0.ebuild b/dev-db/xindice/xindice-1.0.ebuild
new file mode 100644
index 000000000000..488672941fe3
--- /dev/null
+++ b/dev-db/xindice/xindice-1.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/xindice/xindice-1.0.ebuild,v 1.1 2003/04/11 20:10:21 phosphan Exp $
+
+DESCRIPTION="A native java XML database"
+HOMEPAGE="http://xml.apache.org/xindice"
+SRC_URI="http://xml.apache.org/xindice/dist/xml-xindice-${PV}.tar.gz"
+LICENSE="Apache-1.1"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND=">=sun-jdk-1.3"
+
+S="${WORKDIR}/xml-${P}"
+
+inherit eutils
+
+pkg_preinst() {
+ enewgroup xindice || die "Adding group xindice failed"
+ enewuser xindice -1 /bin/sh /var/run/xindice xindice || die "Adding user xindice failed"
+ ewarn "This has only been tested with Sun's JDK!"
+ ewarn "Good luck if you use another VM"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}.patch
+}
+
+src_compile() {
+ export XINDICE_HOME=${S}
+ bin/ant
+ use doc && bin/ant docs
+}
+
+src_install() {
+ export TARGET=/opt/xindice
+ keepdir /var/run/xindice
+ chown xindice.xindice ${D}/var/run/xindice
+ dodir ${TARGET}
+ dodir ${TARGET}/java
+ cp -Rvdp bin config icons docs logs idl ${D}${TARGET}
+ cd java
+ cp -Rvdp lib tests examples ${D}${TARGET}/java
+ cd ..
+ dodoc docs/LICENSE docs/README docs/FAQ docs/TODO docs/VERSIONS docs/AUTHORS
+ dohtml docs/AdministratorsGuide.html docs/DevelopersGuide.html docs/UsersGuide.html docs/ToolsReference.html docs/feather.gif docs/index.html docs/xindice.jpg
+ dodir /etc/env.d
+ insinto /etc/env.d
+ doins ${FILESDIR}/21xindice
+ dodir /etc/init.d
+ insinto /etc/init.d
+ insopts -m0755
+ doins ${FILESDIR}/xindice
+ insinto ${TARGET}
+ doins start
+ keepdir /opt/xindice/db
+ chown -R xindice.xindice ${D}/opt/xindice
+}