summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-base/libghttp/ChangeLog7
-rw-r--r--gnome-base/libghttp/Manifest6
-rw-r--r--gnome-base/libghttp/files/digest-libghttp-1.0.9-r4 (renamed from gnome-base/libghttp/files/digest-libghttp-1.0.9-r1)0
-rw-r--r--gnome-base/libghttp/files/libghttp-1.0.9-fixlocale.patch42
-rw-r--r--gnome-base/libghttp/libghttp-1.0.9-r1.ebuild36
-rw-r--r--gnome-base/libghttp/libghttp-1.0.9-r4.ebuild45
6 files changed, 95 insertions, 41 deletions
diff --git a/gnome-base/libghttp/ChangeLog b/gnome-base/libghttp/ChangeLog
index 3def14ae182b..7b759003e5f2 100644
--- a/gnome-base/libghttp/ChangeLog
+++ b/gnome-base/libghttp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/libghttp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/ChangeLog,v 1.14 2003/10/28 00:59:32 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/ChangeLog,v 1.15 2003/12/07 16:28:54 foser Exp $
+
+*libghttp-1.0.9-r4 (06 Dec 2003)
+
+ 06 Dec 2003; foser <foser@gentoo.org> libghttp-1.0.9-r4.ebuild :
+ Added patch to fix locale related problem, described in bug #33386
27 Oct 2003; Brad House <brad_mssw@gentoo.org> libghttp-1.0.9-r3.ebuild:
add amd64 flag
diff --git a/gnome-base/libghttp/Manifest b/gnome-base/libghttp/Manifest
index ba9002b83893..43d1da3c6a99 100644
--- a/gnome-base/libghttp/Manifest
+++ b/gnome-base/libghttp/Manifest
@@ -1,10 +1,8 @@
MD5 12d260487ed68ffbb4229f4d7528aee7 libghttp-1.0.9-r2.ebuild 873
-MD5 ce2f02062b2fed466954f9b33c25fdb1 libghttp-1.0.9-r4.ebuild 858
-MD5 0d41f561e7b7b1e40d64d6dd5444e9d5 libghttp-1.0.9-r1.ebuild 857
-MD5 61d184067bc9f440e69259555cf46642 ChangeLog 2034
+MD5 825d066e10e04d3f87a291be1c3f4b98 libghttp-1.0.9-r4.ebuild 856
+MD5 da5c2212896226c739e3af37be445af0 ChangeLog 2201
MD5 8bef2ccbaee30c7cbf56d3d7ec93ad8f libghttp-1.0.9-r3.ebuild 730
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
-MD5 a8c7fbe13dede783a2937bb45ed65735 files/digest-libghttp-1.0.9-r1 66
MD5 a8c7fbe13dede783a2937bb45ed65735 files/digest-libghttp-1.0.9-r2 66
MD5 a8c7fbe13dede783a2937bb45ed65735 files/digest-libghttp-1.0.9-r3 66
MD5 a8c7fbe13dede783a2937bb45ed65735 files/digest-libghttp-1.0.9-r4 66
diff --git a/gnome-base/libghttp/files/digest-libghttp-1.0.9-r1 b/gnome-base/libghttp/files/digest-libghttp-1.0.9-r4
index 5977c599aa4d..5977c599aa4d 100644
--- a/gnome-base/libghttp/files/digest-libghttp-1.0.9-r1
+++ b/gnome-base/libghttp/files/digest-libghttp-1.0.9-r4
diff --git a/gnome-base/libghttp/files/libghttp-1.0.9-fixlocale.patch b/gnome-base/libghttp/files/libghttp-1.0.9-fixlocale.patch
new file mode 100644
index 000000000000..595b431711da
--- /dev/null
+++ b/gnome-base/libghttp/files/libghttp-1.0.9-fixlocale.patch
@@ -0,0 +1,42 @@
+Index: gnome-http/http_req.c
+diff -u gnome-http/http_req.c:1.24 gnome-http/http_req.c:1.25
+--- gnome-http/http_req.c:1.24 Sat Dec 2 13:45:35 2000
++++ gnome-http/http_req.c Sat May 12 16:35:46 2001
+@@ -108,6 +108,7 @@
+ int l_headers_len = 0;
+ int l_rv = 0;
+ char *l_content = NULL;
++ int l_ver_major, l_ver_minor;
+
+ /* see if we need to jump into the function somewhere */
+ if (a_conn->sync == HTTP_TRANS_ASYNC)
+@@ -125,21 +126,25 @@
+ memset(l_request, 0, 30 + strlen(a_req->resource) + (a_conn->proxy_host ?
+ (strlen(a_req->host) + 20) : 0));
+ /* copy it into the buffer */
++ l_ver_major = (int)a_req->http_ver;
++ l_ver_minor = ((int)(a_req->http_ver*10.0)) % 10;
+ if (a_conn->proxy_host)
+ {
+ l_request_len = sprintf(l_request,
+- "%s %s HTTP/%01.1f\r\n",
++ "%s %s HTTP/%d.%d\r\n",
+ http_req_type_char[a_req->type],
+ a_req->full_uri,
+- a_req->http_ver);
++ l_ver_major,
++ l_ver_minor);
+ }
+ else
+ {
+ l_request_len = sprintf(l_request,
+- "%s %s HTTP/%01.1f\r\n",
++ "%s %s HTTP/%d.%d\r\n",
+ http_req_type_char[a_req->type],
+ a_req->resource,
+- a_req->http_ver);
++ l_ver_major,
++ l_ver_minor);
+ }
+ /* set the request in the connection buffer */
+ http_trans_append_data_to_buf(a_conn, l_request, l_request_len);
diff --git a/gnome-base/libghttp/libghttp-1.0.9-r1.ebuild b/gnome-base/libghttp/libghttp-1.0.9-r1.ebuild
deleted file mode 100644
index d9411ebe7c4e..000000000000
--- a/gnome-base/libghttp/libghttp-1.0.9-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/libghttp-1.0.9-r1.ebuild,v 1.10 2003/09/06 23:51:37 msterret Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="libghttp"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
-
-HOMEPAGE="http://www.gnome.org/"
-LICENSE="LGPL-2.1"
-KEYWORDS="x86 sparc "
-SLOT="0"
-
-DEPEND="virtual/glibc"
-
-src_compile() {
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var/lib
- assert
-
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- install || die
-
- dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
-
- docinto html
- dodoc doc/ghttp.html
-}
diff --git a/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild b/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild
new file mode 100644
index 000000000000..008f58175c00
--- /dev/null
+++ b/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libghttp/libghttp-1.0.9-r4.ebuild,v 1.1 2003/12/07 16:28:54 foser Exp $
+
+GNOME_TARBALL_SUFFIX="gz"
+inherit libtool gnome.org
+
+DESCRIPTION="GNOME http client library"
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64"
+
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # fixes http locale related bug (#33386)
+ epatch ${FILESDIR}/${P}-fixlocale.patch
+
+}
+
+src_compile() {
+
+ elibtoolize
+
+ econf || die
+ emake || die
+
+}
+
+src_install() {
+ einstall || die
+
+ # headers needed for Intermezzo (bug 11501)
+ insinto /usr/include/ghttp-1.0/
+ doins http*.h
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dohtml doc/*.html
+}