summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-antivirus/clamav/ChangeLog5
-rwxr-xr-xapp-antivirus/clamav/files/clamd.initd-r57
2 files changed, 9 insertions, 3 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index d094d72e7249..0fdc3ebb6b36 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-antivirus/clamav
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.454 2013/04/02 10:55:04 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.455 2013/04/16 05:52:39 eras Exp $
+
+ 16 Apr 2013; Eray Aslan <eras@gentoo.org> files/clamd.initd-r5:
+ Check pid file directory before starting freshclam - bug #333783
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> clamav-0.97.7.ebuild:
Stable for sparc, wrt bug #462278
diff --git a/app-antivirus/clamav/files/clamd.initd-r5 b/app-antivirus/clamav/files/clamd.initd-r5
index 52edcf0dfc7b..fbe2432b053d 100755
--- a/app-antivirus/clamav/files/clamd.initd-r5
+++ b/app-antivirus/clamav/files/clamd.initd-r5
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/files/clamd.initd-r5,v 1.1 2013/04/01 12:51:53 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/files/clamd.initd-r5,v 1.2 2013/04/16 05:52:39 eras Exp $
daemon_clamd="/usr/sbin/clamd"
daemon_freshclam="/usr/bin/freshclam"
@@ -48,6 +48,9 @@ start() {
fi
if [ "${START_FRESHCLAM}" = "yes" ]; then
+ checkpath --quiet --mode 755 \
+ --owner "${clamd_user}":"${clamd_user}" \
+ --directory `dirname ${clamd_socket}`
ebegin "Starting freshclam"
start-stop-daemon --start --quiet \
--nicelevel ${FRESHCLAM_NICELEVEL:-0} \
@@ -93,7 +96,7 @@ stop() {
}
logfix() {
- clamd_socket=$(get_config clamd LocalSocket /var/run/clamav/clamd.sock)
+ clamd_socket=$(get_config clamd LocalSocket /run/clamav/clamd.sock)
clamd_user=$(get_config clamd User clamav)
freshclam_user=$(get_config freshclam DatabaseOwner clamav)