summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/iptraf-ng/ChangeLog9
-rw-r--r--net-analyzer/iptraf-ng/files/iptraf-ng-1.1.3.1-kernel-v3.5-kill-off-token-ring-support.patch128
-rw-r--r--net-analyzer/iptraf-ng/iptraf-ng-1.1.3.1-r1.ebuild49
3 files changed, 185 insertions, 1 deletions
diff --git a/net-analyzer/iptraf-ng/ChangeLog b/net-analyzer/iptraf-ng/ChangeLog
index 7f7a47d4668d..f4b006b1e4b6 100644
--- a/net-analyzer/iptraf-ng/ChangeLog
+++ b/net-analyzer/iptraf-ng/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/iptraf-ng
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf-ng/ChangeLog,v 1.39 2012/08/04 10:26:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf-ng/ChangeLog,v 1.40 2012/08/06 14:36:35 ssuominen Exp $
+
+*iptraf-ng-1.1.3.1-r1 (06 Aug 2012)
+
+ 06 Aug 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +iptraf-ng-1.1.3.1-r1.ebuild,
+ +files/iptraf-ng-1.1.3.1-kernel-v3.5-kill-off-token-ring-support.patch:
+ Fix building with linux-headers >= 3.5 wrt #427902 by Justin Lecher
04 Aug 2012; Jeroen Roovers <jer@gentoo.org> iptraf-ng-1.1.3.1.ebuild:
Force verbose build output (bug #429784).
diff --git a/net-analyzer/iptraf-ng/files/iptraf-ng-1.1.3.1-kernel-v3.5-kill-off-token-ring-support.patch b/net-analyzer/iptraf-ng/files/iptraf-ng-1.1.3.1-kernel-v3.5-kill-off-token-ring-support.patch
new file mode 100644
index 000000000000..e5c04cd891f1
--- /dev/null
+++ b/net-analyzer/iptraf-ng/files/iptraf-ng-1.1.3.1-kernel-v3.5-kill-off-token-ring-support.patch
@@ -0,0 +1,128 @@
+From 72512af1a3f1d55fff73cdfe7b63d9cfe8cc37ab Mon Sep 17 00:00:00 2001
+Message-Id: <72512af1a3f1d55fff73cdfe7b63d9cfe8cc37ab.1337783673.git.npajkovs@redhat.com>
+From: Nikola Pajkovsky <npajkovs@redhat.com>
+Date: Wed, 23 May 2012 16:32:27 +0200
+Subject: [PATCH] token-ring: kernel v3.5 kill off token-ring support
+
+Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>
+---
+ src/hostmon.c | 10 ----------
+ src/iptraf-ng-compat.h | 1 -
+ src/othptab.c | 6 ------
+ src/packet.c | 27 ---------------------------
+ src/tcptable.c | 4 ----
+ 5 files changed, 48 deletions(-)
+
+diff --git a/src/hostmon.c b/src/hostmon.c
+index 40a2b95..72b91f8 100644
+--- a/src/hostmon.c
++++ b/src/hostmon.c
+@@ -1004,16 +1004,6 @@ void hostmon(const struct OPTIONS *options, time_t facilitytime, char *ifptr,
+ FDDI_K_ALEN);
+ list = flist;
+ break; }
+- case ARPHRD_IEEE802:
+- case ARPHRD_IEEE802_TR: {
+- struct trh_hdr *hdr_trh =
+- (struct trh_hdr *)pkt.pkt_buf;
+- memcpy(scratch_saddr, hdr_trh->saddr,
+- TR_ALEN);
+- memcpy(scratch_daddr, hdr_trh->daddr,
+- TR_ALEN);
+- list = flist;
+- break; }
+ default:
+ /* unknown link protocol */
+ continue;
+diff --git a/src/iptraf-ng-compat.h b/src/iptraf-ng-compat.h
+index d5aee4a..2d9da96 100644
+--- a/src/iptraf-ng-compat.h
++++ b/src/iptraf-ng-compat.h
+@@ -39,7 +39,6 @@
+ #include <linux/if_ether.h>
+ #include <linux/if_packet.h>
+ #include <linux/if_fddi.h>
+-#include <linux/if_tr.h>
+ #include <linux/types.h>
+ #include <linux/isdn.h>
+
+diff --git a/src/othptab.c b/src/othptab.c
+index d12cdfd..1181eb1 100644
+--- a/src/othptab.c
++++ b/src/othptab.c
+@@ -193,12 +193,6 @@ struct othptabent *add_othp_entry(struct othptable *table, struct pkt_hdr *pkt,
+ saddr), new_entry->smacaddr);
+ convmacaddr((char *) (((struct fddihdr *) packet)->
+ daddr), new_entry->dmacaddr);
+- } else if ((pkt->pkt_hatype == ARPHRD_IEEE802)
+- || (pkt->pkt_hatype == ARPHRD_IEEE802_TR)) {
+- convmacaddr((char *) (((struct trh_hdr *) packet)->
+- saddr), new_entry->smacaddr);
+- convmacaddr((char *) (((struct trh_hdr *) packet)->
+- daddr), new_entry->dmacaddr);
+ }
+ }
+
+diff --git a/src/packet.c b/src/packet.c
+index a43a27a..f3e4304 100644
+--- a/src/packet.c
++++ b/src/packet.c
+@@ -51,24 +51,6 @@ static int in_cksum(u_short * addr, int len)
+ return (u_short) (~sum);
+ }
+
+-static unsigned int get_tr_ip_offset(char *pkt)
+-{
+- struct trh_hdr *trh;
+- unsigned int riflen = 0;
+-
+- trh = (struct trh_hdr *) pkt;
+-
+- /*
+- * Check if this packet has TR routing information and get
+- * its length.
+- */
+- if (trh->saddr[0] & TR_RII)
+- riflen = (ntohs(trh->rcf) & TR_RCF_LEN_MASK) >> 8;
+-
+- return sizeof(struct trh_hdr) - TR_MAXRIFLEN + riflen +
+- sizeof(struct trllc);
+-}
+-
+ static int packet_adjust(struct pkt_hdr *pkt)
+ {
+ int retval = 0;
+@@ -109,15 +91,6 @@ static int packet_adjust(struct pkt_hdr *pkt)
+ pkt->pkt_payload += sizeof(struct fddihdr);
+ pkt->pkt_len -= sizeof(struct fddihdr);
+ break;
+- case ARPHRD_IEEE802_TR:
+- case ARPHRD_IEEE802:
+- pkt->pkt_payload = pkt->pkt_buf;
+- /* Token Ring patch supplied by Tomas Dvorak */
+- /* Get the start of the IP packet from the Token Ring frame. */
+- unsigned int dataoffset = get_tr_ip_offset(pkt->pkt_payload);
+- pkt->pkt_payload += dataoffset;
+- pkt->pkt_len -= dataoffset;
+- break;
+ default:
+ /* return a NULL packet to signal an unrecognized link */
+ /* protocol to the caller. Hopefully, this switch statement */
+diff --git a/src/tcptable.c b/src/tcptable.c
+index 56c4780..b0e5ccc 100644
+--- a/src/tcptable.c
++++ b/src/tcptable.c
+@@ -620,10 +620,6 @@ void updateentry(struct tcptable *table, struct tcptableent *tableentry,
+ } else if (linkproto == ARPHRD_FDDI) {
+ convmacaddr((char *) (((struct fddihdr *) packet)->
+ saddr), newmacaddr);
+- } else if ((linkproto == ARPHRD_IEEE802)
+- || (linkproto == ARPHRD_IEEE802_TR)) {
+- convmacaddr((char *) (((struct trh_hdr *) packet)->
+- saddr), newmacaddr);
+ }
+
+ if (tableentry->smacaddr[0] != '\0') {
+--
+1.7.10
+
diff --git a/net-analyzer/iptraf-ng/iptraf-ng-1.1.3.1-r1.ebuild b/net-analyzer/iptraf-ng/iptraf-ng-1.1.3.1-r1.ebuild
new file mode 100644
index 000000000000..873a8fc4454c
--- /dev/null
+++ b/net-analyzer/iptraf-ng/iptraf-ng-1.1.3.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iptraf-ng/iptraf-ng-1.1.3.1-r1.ebuild,v 1.1 2012/08/06 14:36:35 ssuominen Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A console-based network monitoring utility"
+HOMEPAGE="http://fedorahosted.org/iptraf-ng/"
+SRC_URI="http://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 doc? ( FDL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc"
+
+RESTRICT="test"
+
+RDEPEND=">=sys-libs/ncurses-5.7-r7"
+DEPEND="${RDEPEND}
+ !net-analyzer/iptraf"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-kernel-v3.5-kill-off-token-ring-support.patch
+
+ sed -i \
+ -e '/^CC =/d' \
+ -e '/^CFLAGS =/s:-g -O2::' \
+ -e '/^LDFLAGS =/d' \
+ -e 's|$(QUIET_[[:alpha:]]*)||g' \
+ Makefile || die
+}
+
+src_configure() { :; }
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dosbin {iptraf,rvnamed}-ng
+
+ doman src/*.8
+ dodoc AUTHORS CHANGES FAQ README* RELEASE-NOTES
+ use doc && dohtml -a gif,html,png -r Documentation/*
+
+ keepdir /var/{lib,log,lock}/iptraf-ng #376157
+}