summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/paw/ChangeLog7
-rw-r--r--sci-physics/paw/files/paw-2.14.04-glibc-2.10.patch11
-rw-r--r--sci-physics/paw/files/paw-2.14.04-missing-headers.patch11
-rw-r--r--sci-physics/paw/paw-2.14.04-r2.ebuild9
4 files changed, 33 insertions, 5 deletions
diff --git a/sci-physics/paw/ChangeLog b/sci-physics/paw/ChangeLog
index a5df422b730c..bfa5f8e27de7 100644
--- a/sci-physics/paw/ChangeLog
+++ b/sci-physics/paw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/paw
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/ChangeLog,v 1.13 2009/05/05 19:48:23 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/ChangeLog,v 1.14 2009/09/11 02:19:50 bicatali Exp $
+
+ 11 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ paw-2.14.04-r2.ebuild, +files/paw-2.14.04-glibc-2.10.patch,
+ +files/paw-2.14.04-missing-headers.patch:
+ Fixed glibc bug #275020, thanks Andrew Savchenko, and add missing header
05 May 2009; Christian Faulhammer <fauli@gentoo.org>
paw-2.14.04-r2.ebuild:
diff --git a/sci-physics/paw/files/paw-2.14.04-glibc-2.10.patch b/sci-physics/paw/files/paw-2.14.04-glibc-2.10.patch
new file mode 100644
index 000000000000..7cfa5aa03d12
--- /dev/null
+++ b/sci-physics/paw/files/paw-2.14.04-glibc-2.10.patch
@@ -0,0 +1,11 @@
+--- src/pawlib/paw/cpaw/bugrep.c.orig 2009-07-13 00:38:38.000000000 +0400
++++ src/pawlib/paw/cpaw/bugrep.c 2009-07-13 08:47:54.934308924 +0400
+@@ -20,6 +20,8 @@
+ * Paw
+ *
+ */
++#define _POSIX_SOURCE
++
+ #include "paw/pilot.h"
+ #if defined(CERNLIB_BUGREPORT)
+ /*CMZ : 2.07/19 21/11/95 18.17.13 by Unknown*/
diff --git a/sci-physics/paw/files/paw-2.14.04-missing-headers.patch b/sci-physics/paw/files/paw-2.14.04-missing-headers.patch
new file mode 100644
index 000000000000..5a1f76ed1542
--- /dev/null
+++ b/sci-physics/paw/files/paw-2.14.04-missing-headers.patch
@@ -0,0 +1,11 @@
+--- src/pawlib/comis/deccc/cs_hlshl.c.orig 2009-09-10 01:14:51.000000000 +0100
++++ src/pawlib/comis/deccc/cs_hlshl.c 2009-09-10 01:16:19.000000000 +0100
+@@ -61,7 +61,7 @@
+ #endif
+
+ #include <sys/time.h>
+-
++#include <stdlib.h>
+ #include <signal.h>
+ #include <string.h>
+
diff --git a/sci-physics/paw/paw-2.14.04-r2.ebuild b/sci-physics/paw/paw-2.14.04-r2.ebuild
index 626ba3e306cc..76bfd957d07e 100644
--- a/sci-physics/paw/paw-2.14.04-r2.ebuild
+++ b/sci-physics/paw/paw-2.14.04-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/paw-2.14.04-r2.ebuild,v 1.11 2009/05/05 19:48:23 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/paw-2.14.04-r2.ebuild,v 1.12 2009/09/11 02:19:51 bicatali Exp $
EAPI=2
inherit eutils toolchain-funcs
@@ -18,7 +18,7 @@ SRC_URI="mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
KEYWORDS="amd64 ~hppa sparc x86"
SLOT="0"
-IUSE=""
+IUSE="static"
RDEPEND="sci-physics/cernlib
x11-libs/libXaw
@@ -35,7 +35,7 @@ S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
src_prepare() {
cd "${WORKDIR}"
- epatch "${WORKDIR}/${DEB_P}-${DEB_PR}.diff"
+ epatch "${WORKDIR}"/${DEB_P}-${DEB_PR}.diff
cd "${S}"
cp debian/add-ons/Makefile .
export DEB_BUILD_OPTIONS="$(tc-getFC) nostrip nocheck"
@@ -50,7 +50,8 @@ src_prepare() {
einfo "Applying Debian patches"
emake -j1 patch || die "applying patch failed"
-
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ epatch "${FILESDIR}"/${P}-missing-headers.patch
# since we depend on cfortran, do not use the one from cernlib
rm -f src/include/cfortran/cfortran.h
}