summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/xbattle/ChangeLog9
-rw-r--r--games-strategy/xbattle/Manifest4
-rw-r--r--games-strategy/xbattle/files/digest-xbattle-5.4.11
-rw-r--r--games-strategy/xbattle/metadata.xml27
-rw-r--r--games-strategy/xbattle/xbattle-5.4.1.ebuild50
5 files changed, 90 insertions, 1 deletions
diff --git a/games-strategy/xbattle/ChangeLog b/games-strategy/xbattle/ChangeLog
new file mode 100644
index 000000000000..f3c530004a02
--- /dev/null
+++ b/games-strategy/xbattle/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for games-strategy/xbattle
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xbattle/ChangeLog,v 1.1 2003/09/26 04:55:49 msterret Exp $
+
+*xbattle-5.4.1 (25 Sep 2003)
+
+ 25 Sep 2003; Michael Sterrett <msterret@gentoo.org> xbattle-5.4.1.ebuild:
+ initial commit; ebuild based on the one submitted by Marc Bevand via bug 29224
+
diff --git a/games-strategy/xbattle/Manifest b/games-strategy/xbattle/Manifest
index 3442cc774be8..c0a3f1419f96 100644
--- a/games-strategy/xbattle/Manifest
+++ b/games-strategy/xbattle/Manifest
@@ -1,2 +1,4 @@
-MD5 4a8e9628bbb1dc48306038c613fc59d6 xbattle-5.4.1.ebuild 928
+MD5 88a6fcb91ea02b46e9eea855cdc4dc7b xbattle-5.4.1.ebuild 1490
+MD5 4f41da1fe9b44886d234d05804d203c7 metadata.xml 1359
+MD5 af12f38be7ce3e34fc2a517541affa8c ChangeLog 416
MD5 9430b48ce6fae1abaa361a27350a99e0 files/digest-xbattle-5.4.1 65
diff --git a/games-strategy/xbattle/files/digest-xbattle-5.4.1 b/games-strategy/xbattle/files/digest-xbattle-5.4.1
new file mode 100644
index 000000000000..61f6a4148760
--- /dev/null
+++ b/games-strategy/xbattle/files/digest-xbattle-5.4.1
@@ -0,0 +1 @@
+MD5 9eb96c644807156a060f753b4d06df92 xbattle-5.4.1.tar.gz 128982
diff --git a/games-strategy/xbattle/metadata.xml b/games-strategy/xbattle/metadata.xml
new file mode 100644
index 000000000000..7e72e513cfe1
--- /dev/null
+++ b/games-strategy/xbattle/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>msterret@gentoo.org</email>
+<name>Michael Sterrett</name>
+</maintainer>
+<longdescription>
+From the HOMEPAGE:
+XBattle is a concurrent multi-player arcade/strategy game that captures
+the dynamics of a wide range of military situations through numerous
+options. The game board is a matrix of game cells which can be occupied
+by troops of various colors, with troop strength indicated by the size of
+colored markers within a cell. Troops are commanded by clicking the mouse
+near the edge of an occupied cell in the direction that movement is to take
+place. XBattle is concurrent, so that commands are given continuously by
+all players without waiting for turns. A command will be acknowledged by
+the appearance of a command vector, and thereafter, in each update cycle,
+a certain proportion of the troops will move from the source cell to the
+destination cell. In this way, troops can be slowly redistributed via
+supply lines which steadily deliver troops to their endpoints. Troops
+of different colors engage in battle whenever they come to occupy the
+same cell. A wide variety of options are available for configuring troop
+movement, distribution, and production.
+</longdescription>
+</pkgmetadata>
diff --git a/games-strategy/xbattle/xbattle-5.4.1.ebuild b/games-strategy/xbattle/xbattle-5.4.1.ebuild
new file mode 100644
index 000000000000..606348d0cc70
--- /dev/null
+++ b/games-strategy/xbattle/xbattle-5.4.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xbattle/xbattle-5.4.1.ebuild,v 1.1 2003/09/26 04:55:49 msterret Exp $
+
+inherit games
+
+DESCRIPTION="A multi-player game of strategy and coordination"
+HOMEPAGE="http://cns-web.bu.edu/pub/xpip/html/xbattle.html"
+SRC_URI="ftp://cns-ftp.bu.edu/pub/xbattle/${P}.tar.gz"
+
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64"
+LICENSE="xbattle"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/x11"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:/export/home/lesher/:${GAMES_DATADIR}/${PN}/:" Imakefile || \
+ die "sed Imakefile failed"
+}
+
+src_compile() {
+ xmkmf || die "xmkmf failed"
+ emake CDEBUGFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dogamesbin xbattle || die "dogamesbin failed"
+ newgamesbin tutorial1 xbattle-tutorial1 || die "newgamesbin failed"
+ newgamesbin tutorial2 xbattle-tutorial2 || die "newgamesbin failed"
+ dodir ${GAMES_DATADIR}/${PN} || die "dodir failed"
+ cp -r xbas/ xbos/ xbts/ ${D}${GAMES_DATADIR}/${PN}/ || die "cp failed"
+ newman xbattle.man xbattle.6 || die "newman failed"
+ dodoc README xbattle.dot || die "dodoc failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo 'You may be interested by these tutorials:'
+ einfo ' xbattle-tutorial1'
+ einfo ' xbattle-tutorial2'
+}