summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tcltk/expect/ChangeLog6
-rw-r--r--dev-tcltk/expect/expect-5.37.1-r2.ebuild101
-rw-r--r--dev-tcltk/expect/expect-5.40.0-r1.ebuild83
-rw-r--r--dev-tcltk/expect/expect-5.40.0.ebuild65
-rw-r--r--dev-tcltk/expect/expect-5.42.1.ebuild98
-rw-r--r--dev-tcltk/expect/files/digest-expect-5.37.1-r23
-rw-r--r--dev-tcltk/expect/files/digest-expect-5.40.03
-rw-r--r--dev-tcltk/expect/files/digest-expect-5.40.0-r13
-rw-r--r--dev-tcltk/expect/files/digest-expect-5.42.13
9 files changed, 5 insertions, 360 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 1f50bcc16441..4b223ddf8f3f 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/expect
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.44 2007/04/07 14:45:30 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.45 2007/04/07 14:48:02 jokey Exp $
+
+ 07 Apr 2007; Markus Ullmann <jokey@gentoo.org> -expect-5.37.1-r2.ebuild,
+ -expect-5.40.0.ebuild, -expect-5.40.0-r1.ebuild, -expect-5.42.1.ebuild:
+ Do a little cleanup while at it
07 Apr 2007; Markus Ullmann <jokey@gentoo.org> expect-5.42.1-r1.ebuild,
expect-5.43.0.ebuild:
diff --git a/dev-tcltk/expect/expect-5.37.1-r2.ebuild b/dev-tcltk/expect/expect-5.37.1-r2.ebuild
deleted file mode 100644
index 3905c08f9217..000000000000
--- a/dev-tcltk/expect/expect-5.37.1-r2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.37.1-r2.ebuild,v 1.11 2007/01/05 07:46:35 flameeyes Exp $
-
-
-#remove the trailing ".0" from the tarball version
-NON_MICRO_V=${P%.[0-9]}
-S=${WORKDIR}/${NON_MICRO_V}
-
-DESCRIPTION="tool for automating interactive applications"
-HOMEPAGE="http://expect.nist.gov/"
-SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 ppc sparc alpha mips hppa amd64 ia64 s390 arm"
-IUSE="X doc"
-
-DEPEND=">=dev-lang/tcl-8.2
- X? ( >=dev-lang/tk-8.2 )"
-
-src_unpack() {
- unpack ${A}
- sed -i 's#/usr/local/bin#/usr/bin#' ${S}/expect.man
- sed -i 's#/usr/local/bin#/usr/bin#' ${S}/expectk.man
- #stops any example scripts being installed by default
- sed -i 's/^SCRIPTS =/G_SCRIPTS =/' ${S}/Makefile.in
- sed -i 's/^SCRIPTS_MANPAGES =/G_SCRIPTS_MANPAGES =/' ${S}/Makefile.in
-
- cat >${WORKDIR}/sed.examples.gentoo <<HERE
-1s;#!\\.\\.;#!/usr/bin;
-1s;#!/depot/path;#!/usr/bin;
-HERE
-
- cat >${WORKDIR}/Makefile.examples.gentoo <<HERE
-include Makefile
-
-gentoo_examples:
- for i in \$(G_SCRIPTS) ; do \\
- if [ -f \$(srcdir)/example/\$\$i ] ; then \\
- \$(INSTALL_PROGRAM) \$(srcdir)/example/\$\$i \\
- ${D}/usr/share/doc/${PF}/examples/\$\$i ; \\
- sed -i -f ${WORKDIR}/sed.examples.gentoo \\
- ${D}/usr/share/doc/${PF}/examples/\$\$i ; \\
- fi ; \\
- done
-
- for i in \$(G_SCRIPTS_MANPAGES) ; do \\
- if [ -f \$(srcdir)/example/\$\$i.man ] ; then \\
- \$(INSTALL_DATA) \$(srcdir)/example/\$\$i.man \\
- ${D}/usr/share/doc/${PF}/examples/\$\$i.1 ; \\
- gzip ${D}/usr/share/doc/${PF}/examples/\$\$i.1 ; \\
- fi ; \\
- done
-
-HERE
-}
-
-src_compile() {
- local myconf
- local tclv
- local tkv
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- #tkv isn't really needed, included for symmetry and the future
- tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
-
- #configure needs to find the files tclConfig.sh and tclInt.h
- myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl$tclv/include/generic"
-
- if use X; then
- #--with-x is enabled by default
- #configure needs to find the file tkConfig.sh and tk.h
- #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=/usr/lib"
- else
- #configure knows that tk depends on X so just disable X
- myconf="$myconf --without-x"
- fi
-
- econf $myconf --enable-shared || die
- emake || die
-}
-
-src_install () {
- make install INSTALL_ROOT=${D} || die
-
- dodoc ChangeLog FAQ HISTORY NEWS README
-
- local static_lib="lib${NON_MICRO_V/-/}.a"
- rm ${D}/usr/lib/${NON_MICRO_V/-/}/${static_lib}
-
- #install examples if 'doc' is set
- if use doc; then
- docinto examples
- dodoc example/README
- make -f ${WORKDIR}/Makefile.examples.gentoo gentoo_examples
- fi
-}
diff --git a/dev-tcltk/expect/expect-5.40.0-r1.ebuild b/dev-tcltk/expect/expect-5.40.0-r1.ebuild
deleted file mode 100644
index 8d537d4285f7..000000000000
--- a/dev-tcltk/expect/expect-5.40.0-r1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.40.0-r1.ebuild,v 1.8 2007/01/05 07:46:35 flameeyes Exp $
-
-
-DESCRIPTION="tool for automating interactive applications"
-HOMEPAGE="http://expect.nist.gov/"
-SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="X doc"
-
-DEPEND=">=dev-lang/tcl-8.2
- X? ( >=dev-lang/tk-8.2 )"
-
-NON_MICRO_V=${P%.[0-9]}
-S=${WORKDIR}/${NON_MICRO_V}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -i 's#/usr/local/bin#/usr/bin#' expect.man
- sed -i 's#/usr/local/bin#/usr/bin#' expectk.man
- #stops any example scripts being installed by default
- sed -i \
- -e '/^install:/s/install-libraries //' \
- -e 's/^SCRIPTS_MANPAGES = /_&/' Makefile.in
-}
-
-src_compile() {
- local myconf
- local tclv
- local tkv
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- #tkv isn't really needed, included for symmetry and the future
- #tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
-
- #configure needs to find the files tclConfig.sh and tclInt.h
- myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl${tclv}/include/generic"
-
- if use X; then
- #--with-x is enabled by default
- #configure needs to find the file tkConfig.sh and tk.h
- #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=/usr/lib"
- else
- #configure knows that tk depends on X so just disable X
- myconf="$myconf --without-x"
- fi
-
- econf $myconf --enable-shared || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- make install INSTALL_ROOT=${D} || die "make install failed"
-
- dodoc ChangeLog FAQ HISTORY NEWS README
-
- local static_lib="lib${NON_MICRO_V/-/}.a"
- rm ${D}/usr/lib/${NON_MICRO_V/-/}/${static_lib}
-
- #install examples if 'doc' is set
- if use doc; then
- docinto examples
- local scripts=$(make -qp | \
- sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
- exeinto /usr/share/doc/${PF}/examples
- doexe ${scripts}
- local scripts_manpages=$(make -qp | \
- sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
- for m in ${scripts_manpages}; do
- dodoc example/${m}.man
- done
- dodoc example/README
- fi
-
-}
diff --git a/dev-tcltk/expect/expect-5.40.0.ebuild b/dev-tcltk/expect/expect-5.40.0.ebuild
deleted file mode 100644
index 7e8731aff00e..000000000000
--- a/dev-tcltk/expect/expect-5.40.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.40.0.ebuild,v 1.8 2007/01/05 07:46:35 flameeyes Exp $
-
-
-DESCRIPTION="tool for automating interactive applications"
-HOMEPAGE="http://expect.nist.gov/"
-SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips hppa amd64 ppc64 sh"
-IUSE="X doc"
-
-DEPEND=">=dev-lang/tcl-8.2
- X? ( >=dev-lang/tk-8.2 )"
-
-S=${WORKDIR}/${P%.0}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
-src_compile() {
- local myconf
- local tclv
- local tkv
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- #tkv isn't really needed, included for symmetry and the future
- tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
-
- #configure needs to find the files tclConfig.sh and tclInt.h
- myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl$tclv/include/generic"
-
- if use X; then
- #--with-x is enabled by default
- #configure needs to find the file tkConfig.sh and tk.h
- #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=/usr/lib"
- else
- #configure knows that tk depends on X so just disable X
- myconf="$myconf --without-x"
- fi
-
- econf $myconf --enable-shared || die
- emake || die
-}
-
-src_install () {
- einstall || die
-
- #docs
- dodoc Changelog FAQ HISTORY NEWS README
-
- #install examples if 'doc' is set
- if use doc; then
- cd ${S}
- dodir /usr/share/doc/${PF}/examples/
- cp example/* ${D}/usr/share/doc/${PF}/examples/
- fi
-}
diff --git a/dev-tcltk/expect/expect-5.42.1.ebuild b/dev-tcltk/expect/expect-5.42.1.ebuild
deleted file mode 100644
index 26a05b4d4b26..000000000000
--- a/dev-tcltk/expect/expect-5.42.1.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.42.1.ebuild,v 1.10 2007/01/05 07:46:35 flameeyes Exp $
-
-inherit eutils
-
-DESCRIPTION="tool for automating interactive applications"
-HOMEPAGE="http://expect.nist.gov/"
-SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ~ppc ~ppc64 s390 sh sparc x86"
-IUSE="X doc"
-
-# We need dejagnu for src_test, but dejagnu needs expect
-# to compile/run, so we cant add dejagnu to DEPEND :/
-RDEPEND=">=dev-lang/tcl-8.2
- X? ( >=dev-lang/tk-8.2 )"
-DEPEND="${RDEPEND}
- =sys-devel/autoconf-2.1*"
-
-NON_MICRO_V=${P%.[0-9]}
-S=${WORKDIR}/${NON_MICRO_V}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-multilib.patch
- sed -i 's#/usr/local/bin#/usr/bin#' expect.man
- sed -i 's#/usr/local/bin#/usr/bin#' expectk.man
- #stops any example scripts being installed by default
- sed -i \
- -e '/^install:/s/install-libraries //' \
- -e 's/^SCRIPTS_MANPAGES = /_&/' \
- Makefile.in
- WANT_AUTOCONF=2.1 autoconf
-}
-
-src_compile() {
- local myconf
- local tclv
- local tkv
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- #tkv isn't really needed, included for symmetry and the future
- #tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
-
- #configure needs to find the files tclConfig.sh and tclInt.h
- myconf="--with-tcl=/usr/$(get_libdir) --with-tclinclude=/usr/$(get_libdir)/tcl${tclv}/include/generic"
-
- if use X ; then
- #--with-x is enabled by default
- #configure needs to find the file tkConfig.sh and tk.h
- #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=/usr/$(get_libdir)"
- else
- #configure knows that tk depends on X so just disable X
- myconf="$myconf --without-x"
- fi
-
- econf $myconf --enable-shared || die "econf failed"
- emake || die "emake failed"
-}
-
-src_test() {
- # we need dejagnu to do tests ... but dejagnu needs
- # expect ... so don't do tests unless we have dejagnu
- type -p runtest || return 0
- make check || die "make check failed"
-}
-
-src_install() {
- dodir /usr/$(get_libdir)
- make install INSTALL_ROOT=${D} || die "make install failed"
-
- dodoc ChangeLog FAQ HISTORY NEWS README
-
- local static_lib="lib${NON_MICRO_V/-/}.a"
- rm ${D}/usr/$(get_libdir)/${NON_MICRO_V/-/}/${static_lib}
-
- #install examples if 'doc' is set
- if use doc ; then
- docinto examples
- local scripts=$(make -qp | \
- sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
- exeinto /usr/share/doc/${PF}/examples
- doexe ${scripts}
- local scripts_manpages=$(make -qp | \
- sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
- for m in ${scripts_manpages}; do
- dodoc example/${m}.man
- done
- dodoc example/README
- fi
-}
diff --git a/dev-tcltk/expect/files/digest-expect-5.37.1-r2 b/dev-tcltk/expect/files/digest-expect-5.37.1-r2
deleted file mode 100644
index 2005b690ee61..000000000000
--- a/dev-tcltk/expect/files/digest-expect-5.37.1-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d570837b6dc6311036d7bdeab19f0e03 expect-5.37.1.tar.gz 517284
-RMD160 9f29d8944014857d2bf6a667272f3670ac86ef0e expect-5.37.1.tar.gz 517284
-SHA256 e5778be726a4b719ae9e0a4c035fc1dc959b52d864cc5ff67d581215466eae37 expect-5.37.1.tar.gz 517284
diff --git a/dev-tcltk/expect/files/digest-expect-5.40.0 b/dev-tcltk/expect/files/digest-expect-5.40.0
deleted file mode 100644
index a20376971e05..000000000000
--- a/dev-tcltk/expect/files/digest-expect-5.40.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 6ae1b87c9af993a69b901b6e52962c18 expect-5.40.0.tar.gz 521414
-RMD160 a38505bef2f8f299ea9914bb035bd3534bb0ec9c expect-5.40.0.tar.gz 521414
-SHA256 f337c13c7a18d8900fd23eacee406354f45cf8fc4141e9039f65bd92bca379be expect-5.40.0.tar.gz 521414
diff --git a/dev-tcltk/expect/files/digest-expect-5.40.0-r1 b/dev-tcltk/expect/files/digest-expect-5.40.0-r1
deleted file mode 100644
index a20376971e05..000000000000
--- a/dev-tcltk/expect/files/digest-expect-5.40.0-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 6ae1b87c9af993a69b901b6e52962c18 expect-5.40.0.tar.gz 521414
-RMD160 a38505bef2f8f299ea9914bb035bd3534bb0ec9c expect-5.40.0.tar.gz 521414
-SHA256 f337c13c7a18d8900fd23eacee406354f45cf8fc4141e9039f65bd92bca379be expect-5.40.0.tar.gz 521414
diff --git a/dev-tcltk/expect/files/digest-expect-5.42.1 b/dev-tcltk/expect/files/digest-expect-5.42.1
deleted file mode 100644
index 795e5611d9f7..000000000000
--- a/dev-tcltk/expect/files/digest-expect-5.42.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 fea346fac6aaf74b0851f2441f478571 expect-5.42.1.tar.gz 524882
-RMD160 d354d5d3ffa941d89e668fb4ad1ccbb59be4f341 expect-5.42.1.tar.gz 524882
-SHA256 a2b64dbca4dc127dfcb6d7e16dd3c08ef8bba2056104ce89819d3e6f0e1df430 expect-5.42.1.tar.gz 524882