summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/virtinst/ChangeLog7
-rw-r--r--app-emulation/virtinst/virtinst-0.600.0.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/app-emulation/virtinst/ChangeLog b/app-emulation/virtinst/ChangeLog
index ae1b07f40b2a..ef779ac3202d 100644
--- a/app-emulation/virtinst/ChangeLog
+++ b/app-emulation/virtinst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/virtinst
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.29 2011/07/28 19:17:18 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.30 2011/07/28 19:18:39 cardoe Exp $
+
+*virtinst-0.600.0 (28 Jul 2011)
+
+ 28 Jul 2011; Doug Goldstein <cardoe@gentoo.org> +virtinst-0.600.0.ebuild:
+ Version bump.
28 Jul 2011; Doug Goldstein <cardoe@gentoo.org> -virtinst-0.500.4.ebuild,
-virtinst-0.500.5.ebuild:
diff --git a/app-emulation/virtinst/virtinst-0.600.0.ebuild b/app-emulation/virtinst/virtinst-0.600.0.ebuild
new file mode 100644
index 000000000000..be87ed00952f
--- /dev/null
+++ b/app-emulation/virtinst/virtinst-0.600.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.600.0.ebuild,v 1.1 2011/07/28 19:18:39 cardoe Exp $
+
+#BACKPORTS=1
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils ${HG_ECLASS}
+
+SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Python modules for starting virtualized guest installations"
+HOMEPAGE="http://virt-manager.et.redhat.com/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+RDEPEND=">=app-emulation/libvirt-0.7.0[python]
+ dev-python/urlgrabber
+ dev-libs/libxml2[python]"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="virtconv virtinst"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ distutils_src_prepare
+}