summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/mosh/ChangeLog6
-rw-r--r--net-misc/mosh/mosh-1.2.2.ebuild69
-rw-r--r--net-misc/mosh/mosh-1.2.3.95_rc1.ebuild61
-rw-r--r--net-misc/mosh/mosh-1.2.3.ebuild69
4 files changed, 5 insertions, 200 deletions
diff --git a/net-misc/mosh/ChangeLog b/net-misc/mosh/ChangeLog
index dfb6f140fdca..5a7bc554de23 100644
--- a/net-misc/mosh/ChangeLog
+++ b/net-misc/mosh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/mosh
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/ChangeLog,v 1.42 2013/05/20 12:42:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/ChangeLog,v 1.43 2013/06/11 09:40:21 xmw Exp $
+
+ 11 Jun 2013; Michael Weber <xmw@gentoo.org> -mosh-1.2.2.ebuild,
+ -mosh-1.2.3.95_rc1.ebuild, -mosh-1.2.3.ebuild:
+ drop old versions.
20 May 2013; Agostino Sarubbo <ago@gentoo.org> mosh-1.2.4.ebuild:
Stable for ppc, wrt bug #470562
diff --git a/net-misc/mosh/mosh-1.2.2.ebuild b/net-misc/mosh/mosh-1.2.2.ebuild
deleted file mode 100644
index 7c0b40c5f7ba..000000000000
--- a/net-misc/mosh/mosh-1.2.2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-1.2.2.ebuild,v 1.6 2012/10/30 00:28:06 xmw Exp $
-
-EAPI=4
-
-inherit autotools vcs-snapshot
-
-DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
-HOMEPAGE="http://mosh.mit.edu"
-SRC_URI="https://github.com/keithw/${PN}/tarball/${P} -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~mips ppc x86"
-IUSE="bash-completion +client examples +mosh-hardening +server ufw +utempter"
-REQUIRED_USE="|| ( client server )
- examples? ( client )"
-
-RDEPEND="dev-libs/protobuf
- sys-libs/ncurses:5
- virtual/ssh
- client? ( dev-lang/perl
- dev-perl/IO-Tty )
- utempter? ( sys-libs/libutempter )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable test tests) \
- $(use_enable bash-completion completion) \
- $(use_enable client) \
- $(use_enable server) \
- $(use_enable examples) \
- $(use_enable ufw) \
- $(use_enable mosh-hardening hardening) \
- $(use_with utempter)
-}
-
-src_compile() {
- emake V=1
-}
-
-src_test() {
- einfo "running test encrypt-decrypt"
- ./src/tests/encrypt-decrypt -q || die
- einfo "running test ocb-aes"
- ./src/tests/ocb-aes -q || die
-}
-
-src_install() {
- default
-
- for myprog in $(find src/examples -type f -perm /0111) ; do
- newbin ${myprog} ${PN}-$(basename ${myprog})
- elog "${myprog} installed as ${PN}-$(basename ${myprog})"
- done
-
- if use bash-completion ; then
- insinto /usr/share/bash-completion
- doins "${D}"/etc/bash_completion.d/mosh
- rm -rf "${D}"/etc/bash_completion.d
- fi
-}
diff --git a/net-misc/mosh/mosh-1.2.3.95_rc1.ebuild b/net-misc/mosh/mosh-1.2.3.95_rc1.ebuild
deleted file mode 100644
index 4758e09215c8..000000000000
--- a/net-misc/mosh/mosh-1.2.3.95_rc1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-1.2.3.95_rc1.ebuild,v 1.1 2013/03/13 18:42:35 xmw Exp $
-
-EAPI=4
-
-inherit autotools vcs-snapshot
-
-DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
-HOMEPAGE="http://mosh.mit.edu"
-SRC_URI="http://mosh.mit.edu/${P/_rc/rc}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~mips ~ppc ~x86 ~arm-linux ~x86-linux"
-IUSE="bash-completion +client examples +mosh-hardening +server ufw +utempter"
-REQUIRED_USE="|| ( client server )
- examples? ( client )"
-
-RDEPEND="dev-libs/protobuf
- sys-libs/ncurses:5
- virtual/ssh
- client? ( dev-lang/perl
- dev-perl/IO-Tty )
- utempter? ( sys-libs/libutempter )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable bash-completion completion) \
- $(use_enable client) \
- $(use_enable server) \
- $(use_enable examples) \
- $(use_enable ufw) \
- $(use_enable mosh-hardening hardening) \
- $(use_with utempter)
-}
-
-src_compile() {
- emake V=1
-}
-
-src_install() {
- default
-
- for myprog in $(find src/examples -type f -perm /0111) ; do
- newbin ${myprog} ${PN}-$(basename ${myprog})
- elog "${myprog} installed as ${PN}-$(basename ${myprog})"
- done
-
- if use bash-completion ; then
- insinto /usr/share/bash-completion
- doins "${ED}"/etc/bash_completion.d/mosh
- rm -rf "${ED}"/etc/bash_completion.d
- fi
-}
diff --git a/net-misc/mosh/mosh-1.2.3.ebuild b/net-misc/mosh/mosh-1.2.3.ebuild
deleted file mode 100644
index 60160356649f..000000000000
--- a/net-misc/mosh/mosh-1.2.3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mosh/mosh-1.2.3.ebuild,v 1.6 2013/02/19 03:42:49 zmedico Exp $
-
-EAPI=4
-
-inherit autotools vcs-snapshot
-
-DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
-HOMEPAGE="http://mosh.mit.edu"
-SRC_URI="https://github.com/keithw/${PN}/tarball/${P} -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~mips ppc x86 ~arm-linux ~x86-linux"
-IUSE="bash-completion +client examples +mosh-hardening +server ufw +utempter"
-REQUIRED_USE="|| ( client server )
- examples? ( client )"
-
-RDEPEND="dev-libs/protobuf
- sys-libs/ncurses:5
- virtual/ssh
- client? ( dev-lang/perl
- dev-perl/IO-Tty )
- utempter? ( sys-libs/libutempter )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable test tests) \
- $(use_enable bash-completion completion) \
- $(use_enable client) \
- $(use_enable server) \
- $(use_enable examples) \
- $(use_enable ufw) \
- $(use_enable mosh-hardening hardening) \
- $(use_with utempter)
-}
-
-src_compile() {
- emake V=1
-}
-
-src_test() {
- einfo "running test encrypt-decrypt"
- ./src/tests/encrypt-decrypt -q || die
- einfo "running test ocb-aes"
- ./src/tests/ocb-aes -q || die
-}
-
-src_install() {
- default
-
- for myprog in $(find src/examples -type f -perm /0111) ; do
- newbin ${myprog} ${PN}-$(basename ${myprog})
- elog "${myprog} installed as ${PN}-$(basename ${myprog})"
- done
-
- if use bash-completion ; then
- insinto /usr/share/bash-completion
- doins "${ED}"/etc/bash_completion.d/mosh
- rm -rf "${ED}"/etc/bash_completion.d
- fi
-}