summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/automatictexplugin/ChangeLog7
-rw-r--r--app-vim/automatictexplugin/automatictexplugin-10.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/app-vim/automatictexplugin/ChangeLog b/app-vim/automatictexplugin/ChangeLog
index f37cbd055d25..d6dae5054c77 100644
--- a/app-vim/automatictexplugin/ChangeLog
+++ b/app-vim/automatictexplugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/automatictexplugin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.8 2011/07/22 18:39:40 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.9 2011/08/10 21:02:13 radhermit Exp $
+
+*automatictexplugin-10 (10 Aug 2011)
+
+ 10 Aug 2011; Tim Harder <radhermit@gentoo.org> +automatictexplugin-10.ebuild:
+ Version bump
*automatictexplugin-9.7.4 (22 Jul 2011)
diff --git a/app-vim/automatictexplugin/automatictexplugin-10.ebuild b/app-vim/automatictexplugin/automatictexplugin-10.ebuild
new file mode 100644
index 000000000000..68f3d2d2f977
--- /dev/null
+++ b/app-vim/automatictexplugin/automatictexplugin-10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/automatictexplugin-10.ebuild,v 1.1 2011/08/10 21:02:15 radhermit Exp $
+
+EAPI="4"
+VIM_PLUGIN_VIM_VERSION="7.3"
+
+inherit vim-plugin
+
+MY_P="AutomaticTexPlugin_${PV}"
+DESCRIPTION="vim plugin: a comprehensive plugin for editing LaTeX files"
+HOMEPAGE="http://atp-vim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atp-vim/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+VIM_PLUGIN_HELPFILES="automatic-tex-plugin.txt"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ !app-vim/vim-latex
+ app-vim/align
+ app-text/wdiff
+ >=dev-lang/python-2.7
+ dev-python/psutil
+ dev-tex/latexmk
+ dev-tex/detex
+ virtual/tex-base"