summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-mud/gnome-mud/ChangeLog10
-rw-r--r--games-mud/gnome-mud/gnome-mud-0.11.1.ebuild60
2 files changed, 68 insertions, 2 deletions
diff --git a/games-mud/gnome-mud/ChangeLog b/games-mud/gnome-mud/ChangeLog
index 729bc375c85e..64a4bb049bb8 100644
--- a/games-mud/gnome-mud/ChangeLog
+++ b/games-mud/gnome-mud/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-mud/gnome-mud
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/gnome-mud/ChangeLog,v 1.22 2008/07/26 01:27:53 mr_bones_ Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/gnome-mud/ChangeLog,v 1.23 2009/02/17 16:53:59 mr_bones_ Exp $
+
+*gnome-mud-0.11.1 (17 Feb 2009)
+
+ 17 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +gnome-mud-0.11.1.ebuild:
+ version bump
*gnome-mud-0.11 (26 Jul 2008)
diff --git a/games-mud/gnome-mud/gnome-mud-0.11.1.ebuild b/games-mud/gnome-mud/gnome-mud-0.11.1.ebuild
new file mode 100644
index 000000000000..e3f5801fbe18
--- /dev/null
+++ b/games-mud/gnome-mud/gnome-mud-0.11.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/gnome-mud/gnome-mud-0.11.1.ebuild,v 1.1 2009/02/17 16:53:59 mr_bones_ Exp $
+
+EAPI=1
+inherit gnome2 games
+
+DESCRIPTION="GNOME MUD client"
+HOMEPAGE="http://live.gnome.org/GnomeMud"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gstreamer"
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/libglade-2.0.1:2.0
+ >=x11-libs/vte-0.11
+ gstreamer? ( media-libs/gstreamer )
+ dev-perl/XML-Parser
+ dev-libs/libpcre
+ net-libs/gnet:2
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.23
+ >=sys-devel/gettext-0.11.5
+ app-text/scrollkeeper"
+
+src_compile() {
+ gnome2_src_compile \
+ --bindir="${GAMES_BINDIR}" \
+ $(use_enable gstreamer)
+}
+
+src_install() {
+ DOCS="AUTHORS BUGS ChangeLog NEWS PLUGIN.API README ROADMAP" \
+ gnome2_src_install
+
+ # plugin directory
+ keepdir /usr/share/gnome-mud || die "keepdir failed"
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ games_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ games_pkg_postinst
+ echo
+ elog "For proper plugin operation, please create ~/.gnome-mud/plugins/"
+ elog "if that directory doesn't already exist."
+ elog "The command to do that is:"
+ elog " mkdir -p ~/.gnome-mud/plugins/"
+ echo
+}