summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/blas-goto/ChangeLog12
-rw-r--r--sci-libs/blas-goto/Manifest20
-rw-r--r--sci-libs/blas-goto/blas-goto-1.08.ebuild129
-rw-r--r--sci-libs/blas-goto/files/digest-blas-goto-1.083
-rw-r--r--sci-libs/blas-goto/files/eselect-goto3
-rw-r--r--sci-libs/blas-goto/metadata.xml5
6 files changed, 172 insertions, 0 deletions
diff --git a/sci-libs/blas-goto/ChangeLog b/sci-libs/blas-goto/ChangeLog
new file mode 100644
index 000000000000..31e62452a7e6
--- /dev/null
+++ b/sci-libs/blas-goto/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sci-libs/blas-goto
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/ChangeLog,v 1.1 2006/10/21 06:15:34 dberkholz Exp $
+
+*blas-goto-1.08 (21 Oct 2006)
+
+ 21 Oct 2006; Donnie Berkholz <dberkholz@gentoo.org>; +files/eselect-goto,
+ +metadata.xml, +blas-goto-1.08.ebuild:
+ New package: The fastest implementations of the Basic Linear Algebra
+ Subroutines. However, they won't work for all systems because they're
+ manually tuned.
+
diff --git a/sci-libs/blas-goto/Manifest b/sci-libs/blas-goto/Manifest
new file mode 100644
index 000000000000..af83e708b715
--- /dev/null
+++ b/sci-libs/blas-goto/Manifest
@@ -0,0 +1,20 @@
+AUX eselect-goto 140 RMD160 795f24085adeccd8f736ce205bed1ae1937f7329 SHA1 aaae84c45c26d372f34e4ddf053a7cb2d6bbfaea SHA256 0ce922ff68673c3a3c18b5299d57455404bbd044481997d57b4819160c43f70c
+MD5 90d71f801fc1cb8670ec358cb4191f59 files/eselect-goto 140
+RMD160 795f24085adeccd8f736ce205bed1ae1937f7329 files/eselect-goto 140
+SHA256 0ce922ff68673c3a3c18b5299d57455404bbd044481997d57b4819160c43f70c files/eselect-goto 140
+DIST GotoBLAS-1.08.tar.gz 1555562 RMD160 5918b34e7a3417e54130c1b9182b3ca033ed80e5 SHA1 6b2c8b69daca1c8dd399cdb321c2b311d1b637f0 SHA256 367dc91fc8784a91e9941548209ade93a4216aed656adb2e54f2ac25ce44152a
+EBUILD blas-goto-1.08.ebuild 3291 RMD160 9d3f7599531866a398c504ae50788a58f7575acb SHA1 29b1cb5a99176d1eb770da434e74886496cddec1 SHA256 4669deaf88476b9c93ce750b74d0e669b207647eb484d1deedeb76ac2065235d
+MD5 1c080e4a12729d9d4135df27cc2f2cb6 blas-goto-1.08.ebuild 3291
+RMD160 9d3f7599531866a398c504ae50788a58f7575acb blas-goto-1.08.ebuild 3291
+SHA256 4669deaf88476b9c93ce750b74d0e669b207647eb484d1deedeb76ac2065235d blas-goto-1.08.ebuild 3291
+MISC ChangeLog 429 RMD160 aab2428339a6b9bd1055a695ca2ec9f58107a2ae SHA1 bd15424ce31f1e243dc855d70e6d9a7ef7020789 SHA256 5ed6c97f79a1724876a7374a003171f7f66e094b86681e720a73ca15df3d48ac
+MD5 f73648b6a1288b4b131a638a7ab5d889 ChangeLog 429
+RMD160 aab2428339a6b9bd1055a695ca2ec9f58107a2ae ChangeLog 429
+SHA256 5ed6c97f79a1724876a7374a003171f7f66e094b86681e720a73ca15df3d48ac ChangeLog 429
+MISC metadata.xml 156 RMD160 dc078172bfebcb25d69bdf8731714f9cce9d3e36 SHA1 da2b240a255820145b7c83a5c48e45b96b7e9ee6 SHA256 5d22100902db7507a5b5493dd4a66cdb08025faf80a2c0b75e6392315c47f900
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+RMD160 dc078172bfebcb25d69bdf8731714f9cce9d3e36 metadata.xml 156
+SHA256 5d22100902db7507a5b5493dd4a66cdb08025faf80a2c0b75e6392315c47f900 metadata.xml 156
+MD5 32863035b05ef25ea3891b5909d3d004 files/digest-blas-goto-1.08 244
+RMD160 5d8fba1fe5876f06e2ba5951d3ad664d14865024 files/digest-blas-goto-1.08 244
+SHA256 dd249f79b68f1e510fb6b183a69c26b05aed8218904040c09518aec8aba19ce3 files/digest-blas-goto-1.08 244
diff --git a/sci-libs/blas-goto/blas-goto-1.08.ebuild b/sci-libs/blas-goto/blas-goto-1.08.ebuild
new file mode 100644
index 000000000000..f53217e72e21
--- /dev/null
+++ b/sci-libs/blas-goto/blas-goto-1.08.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.08.ebuild,v 1.1 2006/10/21 06:15:34 dberkholz Exp $
+
+inherit eutils fortran toolchain-funcs
+
+MY_PN="GotoBLAS"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="The fastest implementations of the Basic Linear Algebra Subroutines"
+HOMEPAGE="http://www.tacc.utexas.edu/resources/software/software.php"
+SRC_URI="http://www.tacc.utexas.edu/resources/software/login/gotoblas/${MY_P}.tar.gz"
+LICENSE="tacc"
+SLOT="0"
+# See http://www.tacc.utexas.edu/resources/software/gotoblasfaq.php
+# for supported architectures
+KEYWORDS="~x86"
+IUSE="threads"
+RESTRICT="mirror"
+RDEPEND="app-admin/eselect-blas"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_PN}"
+FORTRAN="g77 gfortran" # ifc g95 pgf77 pathf90 f90 f77
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Set up C compiler
+ if [[ $(tc-getCC) = *gcc ]]; then
+ C_COMPILER="GNU"
+ elif [[ $(tc-getCC) = icc ]]; then
+ C_COMPILER="INTEL"
+ else
+ die "tc-getCC() returned an invalid C compiler; valid are gcc or icc."
+ fi
+
+ # Set up Fortran compiler
+ if [[ ${FORTRANC} = g77 ]]; then
+ F_COMPILER="G77"
+ elif [[ ${FORTRANC} = gfortran ]]; then
+ F_COMPILER="GFORTRAN"
+ # Otherwise, we get undefined reference to _gfortran_runtime_error
+ FORTRAN_LIB="-lgfortran"
+# elif [[ ${FORTRANC} = ifc ]]; then
+# F_COMPILER="INTEL"
+# elif [[ ${FORTRANC} = g95 ]]; then
+# F_COMPILER="G95"
+# elif [[ ${FORTRANC} = pgf77 ]]; then
+# F_COMPILER="PGI"
+# elif [[ ${FORTRANC} = pathf90 ]]; then
+# F_COMPILER="PATHSCALE"
+# elif [[ ${FORTRANC} = f90 ]] || [[ ${FORTRANC} = f77 ]]; then
+# F_COMPILER="SUN"
+# elif [[ ${FORTRANC} = xlf ]]; then
+# F_COMPILER="IBM"
+ else
+ die "fortran.eclass returned an invalid Fortran compiler \'${FORTRANC}\'; valid are ${FORTRAN}."
+ fi
+
+ # Fix shared lib build
+ sed -i \
+ -e "s:\(&& echo OK\):${FORTRAN_LIB} \1:g" \
+ "${S}"/exports/Makefile
+
+ # Set up compilers
+ sed -i \
+ -e "s:^\(C_COMPILER =\) GNU:\1 ${C_COMPILER}:g" \
+ -e "s:^# \(F_COMPILER =\) G77:\1 ${F_COMPILER}:g" \
+ -e "s:^# \(SMP = 1\):\1:g" \
+ "${S}"/Makefile.rule
+
+ # Threaded?
+ if use threads; then
+ sed -i \
+ -e "s:^# \(SMP = 1\):\1:g" \
+ "${S}"/Makefile.rule
+ fi
+
+ # If you need a 64-bit binary
+ # If you need a 64-bit integer interface, also do this for "INTERFACE64 = 1"
+ if use amd64; then
+ sed -i \
+ -e "s:^# \(BINARY64 = 1\):\1:g" \
+ "${S}"/Makefile.rule
+ fi
+
+ # Respect CFLAGS/FFLAGS
+ sed -i \
+ -e "/^COMMON_OPT += -O2$/d" \
+ "${S}"/Makefile.rule
+ sed -i \
+ -e "s:^\(CCOMMON_OPT +=\)$:\1 ${CFLAGS}:g" \
+ -e "s:^\(FCOMMON_OPT +=\)$:\1 ${FFLAGS:- -O2}:g" \
+ "${S}"/Makefile.rule
+}
+
+src_compile() {
+ # Make static library
+ emake || die "emake failed"
+
+ # Make shared library
+ cd exports
+ emake so -j1 || die "emake failed"
+}
+
+src_install() {
+ local MAIN_DIR="/usr/$(get_libdir)/blas"
+ local DIR="${MAIN_DIR}/goto"
+
+ # dolib.so doesn't support our alternate locations
+ exeinto ${DIR}
+ doexe libgoto_*.so
+ dosym libgoto_*.so ${DIR}/libgoto.so
+ dosym libgoto_*.so ${DIR}/libgoto.so.0
+ dosym libgoto_*.so ${DIR}/libgoto.so.0.0.0
+
+ # dolib.a doesn't support our alternate locations
+ insinto ${DIR}
+ doins libgoto_*.a
+ dosym libgoto_*.a ${DIR}/libgoto.a
+
+ eselect blas add $(get_libdir) "${FILESDIR}"/eselect-goto goto
+}
+
+pkg_postinst() {
+ if [[ -z $(eselect blas show) ]]; then
+ eselect blas set goto
+ fi
+}
diff --git a/sci-libs/blas-goto/files/digest-blas-goto-1.08 b/sci-libs/blas-goto/files/digest-blas-goto-1.08
new file mode 100644
index 000000000000..6e7e4e10239f
--- /dev/null
+++ b/sci-libs/blas-goto/files/digest-blas-goto-1.08
@@ -0,0 +1,3 @@
+MD5 23fb69d69322bee8dd6e85eaefbdbe7a GotoBLAS-1.08.tar.gz 1555562
+RMD160 5918b34e7a3417e54130c1b9182b3ca033ed80e5 GotoBLAS-1.08.tar.gz 1555562
+SHA256 367dc91fc8784a91e9941548209ade93a4216aed656adb2e54f2ac25ce44152a GotoBLAS-1.08.tar.gz 1555562
diff --git a/sci-libs/blas-goto/files/eselect-goto b/sci-libs/blas-goto/files/eselect-goto
new file mode 100644
index 000000000000..ad8fde5a7eca
--- /dev/null
+++ b/sci-libs/blas-goto/files/eselect-goto
@@ -0,0 +1,3 @@
+blas/goto/libgoto.so /usr/@LIBDIR@/libblas.so
+blas/goto/libgoto.so.0 /usr/@LIBDIR@/libblas.so.0
+blas/goto/libgoto.a /usr/@LIBDIR@/libblas.a
diff --git a/sci-libs/blas-goto/metadata.xml b/sci-libs/blas-goto/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/sci-libs/blas-goto/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>