summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-freebsd/freebsd-contrib/ChangeLog8
-rw-r--r--sys-freebsd/freebsd-contrib/freebsd-contrib-9.0_rc3.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-contrib/ChangeLog b/sys-freebsd/freebsd-contrib/ChangeLog
index c655f13fa424..5d7c42b312d8 100644
--- a/sys-freebsd/freebsd-contrib/ChangeLog
+++ b/sys-freebsd/freebsd-contrib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-contrib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.30 2011/12/07 17:06:03 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.31 2011/12/09 13:19:26 aballier Exp $
+
+*freebsd-contrib-9.0_rc3 (09 Dec 2011)
+
+ 09 Dec 2011; Alexis Ballier <aballier@gentoo.org>
+ +freebsd-contrib-9.0_rc3.ebuild:
+ bump to 9.0_rc3
*freebsd-contrib-9.0_rc2 (07 Dec 2011)
diff --git a/sys-freebsd/freebsd-contrib/freebsd-contrib-9.0_rc3.ebuild b/sys-freebsd/freebsd-contrib/freebsd-contrib-9.0_rc3.ebuild
new file mode 100644
index 000000000000..18d13488b730
--- /dev/null
+++ b/sys-freebsd/freebsd-contrib/freebsd-contrib-9.0_rc3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/freebsd-contrib-9.0_rc3.ebuild,v 1.1 2011/12/09 13:19:26 aballier Exp $
+
+inherit bsdmk freebsd flag-o-matic
+
+DESCRIPTION="Contributed sources for FreeBSD."
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+LICENSE="BSD GPL-2 as-is"
+
+IUSE=""
+
+SRC_URI="mirror://gentoo/${GNU}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-sources-${RV}*
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+S="${WORKDIR}/gnu"
+
+src_unpack() {
+ echo ">>> Unpacking needed parts of ${GNU}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${GNU}.tar.bz2" gnu/lib/libodialog gnu/usr.bin/sort gnu/usr.bin/patch
+ echo ">>> Unpacking needed parts of ${CONTRIB}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${CONTRIB}.tar.bz2" contrib/gnu-sort
+
+ freebsd_do_patches
+ freebsd_rename_libraries
+}
+
+src_compile() {
+ cd "${S}/lib/libodialog"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/sort"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/patch"
+ freebsd_src_compile
+}
+
+src_install() {
+ use profile || mymakeopts="${mymakeopts} NO_PROFILE= "
+ mymakeopts="${mymakeopts} NO_MANCOMPRESS= NO_INFOCOMPRESS= "
+
+ cd "${S}/lib/libodialog"
+ mkinstall || die "libodialog install failed"
+
+ cd "${S}/usr.bin/sort"
+ mkinstall BINDIR="/bin/" || die "sort install failed"
+
+ cd "${S}/usr.bin/patch"
+ mkinstall BINDIR="/usr/bin/" || die "patch install failed"
+}