summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/termcolor/ChangeLog6
-rw-r--r--dev-ruby/termcolor/termcolor-1.2.0.ebuild10
2 files changed, 13 insertions, 3 deletions
diff --git a/dev-ruby/termcolor/ChangeLog b/dev-ruby/termcolor/ChangeLog
index 1f8724b78f85..5a7e94e4bdc1 100644
--- a/dev-ruby/termcolor/ChangeLog
+++ b/dev-ruby/termcolor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/termcolor
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/ChangeLog,v 1.1 2011/11/13 08:21:27 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/ChangeLog,v 1.2 2011/11/20 09:30:50 graaff Exp $
+
+ 20 Nov 2011; Hans de Graaff <graaff@gentoo.org> termcolor-1.2.0.ebuild:
+ Fix building with USE=doc, fix rspec dependency to right slot. Fix running
+ specs on ruby19.
*termcolor-1.2.0 (13 Nov 2011)
diff --git a/dev-ruby/termcolor/termcolor-1.2.0.ebuild b/dev-ruby/termcolor/termcolor-1.2.0.ebuild
index b6a2d7f41c79..36fc5a9d97d8 100644
--- a/dev-ruby/termcolor/termcolor-1.2.0.ebuild
+++ b/dev-ruby/termcolor/termcolor-1.2.0.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/termcolor-1.2.0.ebuild,v 1.1 2011/11/13 08:21:27 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/termcolor-1.2.0.ebuild,v 1.2 2011/11/20 09:30:50 graaff Exp $
EAPI="2"
#*** Using highline effectively in JRuby requires manually installing the ffi-ncurses gem.
USE_RUBY="ruby18 ruby19 ree18"
RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
inherit ruby-fakegem
@@ -19,5 +21,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-ruby_add_bdepend dev-ruby/rspec
+ruby_add_bdepend "dev-ruby/rspec:0"
ruby_add_rdepend ">=dev-ruby/highline-1.5.0"
+
+each_ruby_test() {
+ ${RUBY} -S spec spec || die
+}