summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/gle/ChangeLog6
-rw-r--r--media-libs/gle/files/configure-LANG.patch41
-rw-r--r--media-libs/gle/gle-3.0.1-r2.ebuild6
3 files changed, 51 insertions, 2 deletions
diff --git a/media-libs/gle/ChangeLog b/media-libs/gle/ChangeLog
index dda6940aeeb4..a77b214914e6 100644
--- a/media-libs/gle/ChangeLog
+++ b/media-libs/gle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/gle
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/ChangeLog,v 1.17 2006/04/18 14:42:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/ChangeLog,v 1.18 2006/05/18 13:46:05 truedfx Exp $
+
+ 18 May 2006; Harald van Dijk <truedfx@gentoo.org>
+ +files/configure-LANG.patch, gle-3.0.1-r2.ebuild:
+ Fix compilation with et_EE locale (#133625)
18 Apr 2006; Diego Pettenò <flameeyes@gentoo.org> gle-3.0.1-r2.ebuild:
Replace malloc.h inclusions with stdlib.h inclusions to build on FreeBSD and
diff --git a/media-libs/gle/files/configure-LANG.patch b/media-libs/gle/files/configure-LANG.patch
new file mode 100644
index 000000000000..3ef76ef911c0
--- /dev/null
+++ b/media-libs/gle/files/configure-LANG.patch
@@ -0,0 +1,41 @@
+The LANG vars aren't reset early enough so when sed tries to use [a-zA-Z] in
+option parsing, it may break.
+
+http://bugs.gentoo.org/103483
+
+--- configure
++++ configure
+@@ -54,6 +54,16 @@
+ infodir='${prefix}/info'
+ mandir='${prefix}/man'
+
++# NLS nuisances.
++# Only set these to C if already set. These must not be set unconditionally
++# because not all systems understand e.g. LANG=C (notably SCO).
++# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
++# Non-C LC_CTYPE values break the ctype check.
++if test "${LANG+set}" = set; then LANG=C; export LANG; fi
++if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
++if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
++if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
++
+ # Initialize some other variables.
+ subdirs=
+ MFLAGS= MAKEFLAGS=
+@@ -452,16 +463,6 @@
+ esac
+ done
+
+-# NLS nuisances.
+-# Only set these to C if already set. These must not be set unconditionally
+-# because not all systems understand e.g. LANG=C (notably SCO).
+-# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
+-# Non-C LC_CTYPE values break the ctype check.
+-if test "${LANG+set}" = set; then LANG=C; export LANG; fi
+-if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
+-if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
+-if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
+-
+ # confdefs.h avoids OS command line length limits that DEFS can exceed.
+ rm -rf conftest* confdefs.h
+ # AIX cpp loses on an empty file, so make sure it contains at least a newline.
diff --git a/media-libs/gle/gle-3.0.1-r2.ebuild b/media-libs/gle/gle-3.0.1-r2.ebuild
index ad19caaafb97..31f150c57580 100644
--- a/media-libs/gle/gle-3.0.1-r2.ebuild
+++ b/media-libs/gle/gle-3.0.1-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/gle-3.0.1-r2.ebuild,v 1.29 2006/04/18 14:42:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/gle-3.0.1-r2.ebuild,v 1.30 2006/05/18 13:46:05 truedfx Exp $
+
+inherit eutils
DESCRIPTION="GL extrusion library"
HOMEPAGE="http://www.linas.org/gle"
@@ -19,6 +21,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/configure-LANG.patch
+
# Replace inclusion of malloc.h with stdlib.h as needed by Mac OS X and
# FreeBSD.
sed -i -e 's:malloc.h:stdlib.h:g' ${S}/src/*