summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/sitecopy/ChangeLog13
-rw-r--r--net-misc/sitecopy/files/digest-sitecopy-0.11.41
-rw-r--r--net-misc/sitecopy/sitecopy-0.11.4.ebuild33
3 files changed, 42 insertions, 5 deletions
diff --git a/net-misc/sitecopy/ChangeLog b/net-misc/sitecopy/ChangeLog
index f8ffafb8314b..c746a7a970a9 100644
--- a/net-misc/sitecopy/ChangeLog
+++ b/net-misc/sitecopy/ChangeLog
@@ -1,13 +1,14 @@
# ChangeLog for net-misc/sitecopy
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/ChangeLog,v 1.6 2002/12/13 11:00:14 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/ChangeLog,v 1.7 2002/12/15 07:41:19 blizzy Exp $
+
+*sitecopy-0.11.4 (15 Dec 2002)
+
+ 15 Dec 2002; Maik Schreiber <blizzy@gentoo.org> : New version.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
-*sitecopy-0.10.12-r1 (1 Feb 2002)
- 29 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
- Cleanup / HOMEPAGE fix (#9933)
+ 29 Oct 2002; Mike Frysinger <vapier@gentoo.org> : Cleanup / HOMEPAGE fix (#9933)
30 Aug 2002; Sascha Schwabbauer <cybersystem@gentoo.org> sitecopy-0.10.12-r1.ebuild :
Added ppc to keywords.
@@ -15,6 +16,8 @@
09 Jul 2002; phoen][x <phoenix@gentoo.org> sitecopy-0.10.12-r1.ebuild :
Added KEYWORDS, LICENSE, SLOT.
+*sitecopy-0.10.12-r1 (01 Feb 2002)
+
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
diff --git a/net-misc/sitecopy/files/digest-sitecopy-0.11.4 b/net-misc/sitecopy/files/digest-sitecopy-0.11.4
new file mode 100644
index 000000000000..2ea8d65a6a82
--- /dev/null
+++ b/net-misc/sitecopy/files/digest-sitecopy-0.11.4
@@ -0,0 +1 @@
+MD5 2c46e70f64825903119154f24963f209 sitecopy-0.11.4.tar.gz 737326
diff --git a/net-misc/sitecopy/sitecopy-0.11.4.ebuild b/net-misc/sitecopy/sitecopy-0.11.4.ebuild
new file mode 100644
index 000000000000..ee84fc9cab4b
--- /dev/null
+++ b/net-misc/sitecopy/sitecopy-0.11.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/sitecopy-0.11.4.ebuild,v 1.1 2002/12/15 07:41:19 blizzy Exp $
+
+DESCRIPTION="sitecopy is for easily maintaining remote web sites"
+SRC_URI="http://www.lyra.org/sitecopy/${P}.tar.gz"
+HOMEPAGE="http://www.lyra.org/sitecopy/"
+KEYWORDS="~x86 ~ppc ~sparc"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="ssl"
+
+DEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ >=dev-libs/libxml-1.8.15
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+ local myconf="--with-libxml1"
+
+ if [ `use ssl` ] ; then
+ myconf="${myconf} --with-ssl=/usr"
+ else
+ myconf="${myconf} --without-ssl"
+ fi
+ econf ${myconf}
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall || die "install problem"
+}