summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/readline/files/readline-6.0-rlfe-build.patch21
-rw-r--r--sys-libs/readline/readline-6.0_p4.ebuild108
2 files changed, 0 insertions, 129 deletions
diff --git a/sys-libs/readline/files/readline-6.0-rlfe-build.patch b/sys-libs/readline/files/readline-6.0-rlfe-build.patch
deleted file mode 100644
index cc4ca97ee849..000000000000
--- a/sys-libs/readline/files/readline-6.0-rlfe-build.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/examples/rlfe/Makefile.in
-+++ b/examples/rlfe/Makefile.in
-@@ -55,7 +55,7 @@ rlfe-$(VERSION).tar.gz:
- tar czf $@ $(CFILES) $(HFILES) $(EXTRA_DIST)
-
- .c.o:
-- $(CC) -c -I. -I$(srcdir) $(M_CFLAGS) $(DEFS) $(OPTIONS) $(CFLAGS) $<
-+ $(CC) -c -I. -I$(srcdir) $(CPPFLAGS) $(M_CFLAGS) $(DEFS) $(OPTIONS) $(CFLAGS) $<
-
- install_bin: .version screen
- -if [ -f $(DESTDIR)$(bindir)/$(SCREEN) ] && [ ! -f $(DESTDIR)$(bindir)/$(SCREEN).old ]; \
-@@ -170,6 +170,9 @@ depend.in: $(CFILES) term.h
- for i in $(CFILES); do echo $$i; $(CPP_DEPEND) $$i >> tmp_make; done
- mv tmp_make Makefile.in
-
-+Makefile: $(srcdir)/Makefile.in
-+ ./config.status
-+
- ###############################################################################
-
- ### Dependencies:
diff --git a/sys-libs/readline/readline-6.0_p4.ebuild b/sys-libs/readline/readline-6.0_p4.ebuild
deleted file mode 100644
index c32b811230a3..000000000000
--- a/sys-libs/readline/readline-6.0_p4.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.0_p4.ebuild,v 1.12 2010/03/12 18:14:16 ssuominen Exp $
-
-inherit autotools eutils multilib toolchain-funcs flag-o-matic
-
-# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-6.0-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-[[ ${PV} != *_p* ]] && PLEVEL=0
-patches() {
- [[ ${PLEVEL} -eq 0 ]] && return 1
- local opt=$1
- eval set -- {1..${PLEVEL}}
- set -- $(printf "${PN}${MY_PV/\.}-%03d " "$@")
- if [[ ${opt} == -s ]] ; then
- echo "${@/#/${DISTDIR}/}"
- else
- local u
- for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${PN} ; do
- printf "${u}/${PN}-${MY_PV}-patches/%s " "$@"
- done
- fi
-}
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz $(patches)"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-# We must be certain that we have a bash that is linked
-# to its internal readline, else we may get problems.
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
- >=app-shells/bash-2.05b-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
-
- cd "${S}"
- [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
- epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
- epatch "${FILESDIR}"/${PN}-6.0-rlfe-build.patch #151174
- epatch "${FILESDIR}"/${PN}-5.2-no-ignore-shlib-errors.patch #216952
-
- # force ncurses linking #71420
- sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-
- # fix building under Gentoo/FreeBSD; upstream FreeBSD deprecated
- # objformat for years, so we don't want to rely on that.
- sed -i -e '/objformat/s:if .*; then:if true; then:' support/shobj-conf || die
-
- # the bundled rlfe had its configure.in updated, but no one actually
- # ran autoconf to have the configure file updated
- ln -s ../.. examples/rlfe/readline # for headers
- cd examples/rlfe
- eautoconf
-}
-
-src_compile() {
- append-cppflags -D_GNU_SOURCE
-
- econf --with-curses || die
- emake || die
-
- if ! tc-is-cross-compiler ; then
- # code is full of AC_TRY_RUN()
- cd examples/rlfe
- append-ldflags -L.
- local l
- for l in readline history ; do
- ln -s ../../shlib/lib${l}$(get_libname)* lib${l}$(get_libname)
- ln -sf ../../lib${l}.a lib${l}.a
- done
- econf || die
- emake || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- gen_usr_ldscript -a readline history #4411
-
- if ! tc-is-cross-compiler; then
- dobin examples/rlfe/rlfe || die
- fi
-
- dodoc CHANGELOG CHANGES README USAGE NEWS
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/lib{history,readline}.so.{4,5} #29865
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.{4,5}
-}