summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-action/bzflag/ChangeLog7
-rw-r--r--games-action/bzflag/bzflag-2.0.12.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/games-action/bzflag/ChangeLog b/games-action/bzflag/ChangeLog
index ce0660746090..e5abb2ee956c 100644
--- a/games-action/bzflag/ChangeLog
+++ b/games-action/bzflag/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/bzflag
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.35 2008/06/14 15:12:56 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.36 2008/06/25 19:44:49 tupone Exp $
+
+*bzflag-2.0.12 (25 Jun 2008)
+
+ 25 Jun 2008; Tupone Alfredo <tupone@gentoo.org> +bzflag-2.0.12.ebuild:
+ Version bump to 2.0.12 Fixes bug #217874 by rinus
14 Jun 2008; Santiago M. Mola <coldwind@gentoo.org>
+files/bzflag-2.0.10-gcc4.3.patch, bzflag-2.0.10.ebuild:
diff --git a/games-action/bzflag/bzflag-2.0.12.ebuild b/games-action/bzflag/bzflag-2.0.12.ebuild
new file mode 100644
index 000000000000..af379b8c0278
--- /dev/null
+++ b/games-action/bzflag/bzflag-2.0.12.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.0.12.ebuild,v 1.1 2008/06/25 19:44:49 tupone Exp $
+
+inherit eutils flag-o-matic games
+
+DESCRIPTION="3D tank combat simulator game"
+HOMEPAGE="http://www.bzflag.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated sdl"
+
+UIDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/glew
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm"
+
+DEPEND=">=net-misc/curl-7.15.0
+ sys-libs/ncurses
+ net-dns/c-ares
+ sdl? ( ${UIDEPEND} )
+ !sdl? ( !dedicated? ( ${UIDEPEND} ) )"
+
+pkg_setup() {
+ # Only do the libsdl checks for !dedicated - bug #107792
+ use dedicated || GAMES_USE_SDL="nojoystick"
+ if ! built_with_use net-misc/curl ares; then
+ ewarn "net-misc/curl is not buily with c-ares support"
+ ewarn "To avoid undesired glitch during play consider"
+ ewarn "emerging net-misc/curl with USE=\"ares\"."
+ fi
+ games_pkg_setup
+}
+
+src_compile() {
+ local myconf
+
+ if use dedicated && ! use sdl ; then
+ ewarn
+ ewarn "You are building a server-only copy of BZFlag"
+ ewarn
+ myconf="--disable-client --without-SDL"
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ --without-regex \
+ ${myconf} \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS TODO ChangeLog BUGS PORTING DEVINFO NEWS README* RELNOTES
+
+ if use sdl || ! use dedicated ; then
+ doicon "data/bzflag-48x48.png"
+ make_desktop_entry ${PN} "BZFlag" ${PN}-48x48
+ fi
+
+ prepgamesdirs
+}