summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/mercurial/ChangeLog8
-rw-r--r--dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild16
-rw-r--r--dev-vcs/mercurial/mercurial-9999.ebuild19
3 files changed, 17 insertions, 26 deletions
diff --git a/dev-vcs/mercurial/ChangeLog b/dev-vcs/mercurial/ChangeLog
index 8849b4fa082d..1e306b383af1 100644
--- a/dev-vcs/mercurial/ChangeLog
+++ b/dev-vcs/mercurial/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/mercurial
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.98 2012/12/31 08:20:42 djc Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.99 2013/01/02 08:32:19 djc Exp $
+
+ 02 Jan 2013; Dirkjan Ochtman <djc@gentoo.org> mercurial-2.4.1-r2.ebuild,
+ mercurial-9999.ebuild:
+ Fix up docs brokenness (bug 449434).
31 Dec 2012; Dirkjan Ochtman <djc@gentoo.org> -mercurial-2.3.2.ebuild,
-mercurial-2.4-r1.ebuild:
diff --git a/dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild b/dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild
index 3f6d2d788811..1bb9ce7382fe 100644
--- a/dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild
+++ b/dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild,v 1.3 2012/12/31 08:16:12 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild,v 1.4 2013/01/02 08:32:19 djc Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -17,7 +17,7 @@ SRC_URI="http://mercurial.selenic.com/release/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bugzilla doc emacs gpg test tk zsh-completion"
+IUSE="bugzilla emacs gpg test tk zsh-completion"
RDEPEND="bugzilla? ( dev-python/mysql-python )
gpg? ( app-crypt/gnupg )
@@ -26,9 +26,7 @@ RDEPEND="bugzilla? ( dev-python/mysql-python )
app-misc/ca-certificates"
DEPEND="emacs? ( virtual/emacs )
test? ( app-arch/unzip
- dev-python/pygments )
- doc? ( app-text/asciidoc
- dev-python/docutils )"
+ dev-python/pygments )"
PYTHON_CFLAGS=(
"2.* + -fno-strict-aliasing"
@@ -47,16 +45,10 @@ src_prepare() {
src_compile() {
distutils_src_compile
-
- if use doc; then
- make doc || die
- fi
-
if use emacs; then
cd "${S}"/contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
fi
-
rm -rf contrib/{win32,macosx} || die
}
diff --git a/dev-vcs/mercurial/mercurial-9999.ebuild b/dev-vcs/mercurial/mercurial-9999.ebuild
index 0258a76cf8e2..adde60064d2c 100644
--- a/dev-vcs/mercurial/mercurial-9999.ebuild
+++ b/dev-vcs/mercurial/mercurial-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-9999.ebuild,v 1.16 2012/12/31 08:16:12 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-9999.ebuild,v 1.17 2013/01/02 08:32:19 djc Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -17,7 +17,7 @@ EHG_REPO_URI="http://selenic.com/repo/hg"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="bugzilla doc emacs gpg test tk zsh-completion"
+IUSE="bugzilla emacs gpg test tk zsh-completion"
RDEPEND="bugzilla? ( dev-python/mysql-python )
gpg? ( app-crypt/gnupg )
@@ -27,8 +27,8 @@ RDEPEND="bugzilla? ( dev-python/mysql-python )
DEPEND="emacs? ( virtual/emacs )
test? ( app-arch/unzip
dev-python/pygments )
- doc? ( app-text/asciidoc
- dev-python/docutils )"
+ app-text/asciidoc
+ dev-python/docutils"
PYTHON_CFLAGS=(
"2.* + -fno-strict-aliasing"
@@ -47,16 +47,11 @@ src_prepare() {
src_compile() {
distutils_src_compile
-
- if use doc; then
- make doc || die
- fi
-
+ make doc || die
if use emacs; then
cd "${S}"/contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
fi
-
rm -rf contrib/{win32,macosx} || die
}
@@ -72,7 +67,7 @@ src_install() {
fi
rm -f doc/*.?.txt || die
- dodoc CONTRIBUTORS PKG-INFO README doc/*.txt || die
+ dodoc CONTRIBUTORS README doc/*.txt || die
cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
dobin hgeditor || die