summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/mysql/ChangeLog5
-rw-r--r--dev-db/mysql/mysql-5.0.54.ebuild8
2 files changed, 11 insertions, 2 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 456c750b8fc0..adcdab99f44a 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.438 2008/01/25 08:55:32 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.439 2008/01/25 22:54:55 robbat2 Exp $
+
+ 25 Jan 2008; Robin H. Johnson <robbat2@gentoo.org> mysql-5.0.54.ebuild:
+ Disable the subselect testcase on x86.
25 Jan 2008; Robin H. Johnson <robbat2@gentoo.org> mysql-5.0.54.ebuild:
Bump the mysql-extras.
diff --git a/dev-db/mysql/mysql-5.0.54.ebuild b/dev-db/mysql/mysql-5.0.54.ebuild
index 1cd9b7db897f..5c52804218db 100644
--- a/dev-db/mysql/mysql-5.0.54.ebuild
+++ b/dev-db/mysql/mysql-5.0.54.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.54.ebuild,v 1.2 2008/01/25 08:55:32 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.54.ebuild,v 1.3 2008/01/25 22:54:55 robbat2 Exp $
MY_EXTRAS_VER="20080124"
SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
@@ -48,6 +48,12 @@ src_test() {
"read_only" \
"Broken in 5.0.54, output in wrong order"
+ [ "${PV}" == "5.0.54" ] && \
+ [ "${ARCH/x86}" != "${ARCH}" ] && \
+ mysql_disable_test \
+ "subselect" \
+ "Testcase needs tuning on x86 for oom condition"
+
# We run the test protocols seperately
make -j1 test-ns force=--force
retstatus1=$?