summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/gtk2hs/ChangeLog7
-rw-r--r--dev-haskell/gtk2hs/files/gtk2hs-0.9.10-cflags.patch22
-rw-r--r--dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild17
3 files changed, 41 insertions, 5 deletions
diff --git a/dev-haskell/gtk2hs/ChangeLog b/dev-haskell/gtk2hs/ChangeLog
index c0c8ca592939..6af1db1e56b3 100644
--- a/dev-haskell/gtk2hs/ChangeLog
+++ b/dev-haskell/gtk2hs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/gtk2hs
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/ChangeLog,v 1.21 2006/02/10 12:32:41 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/ChangeLog,v 1.22 2006/02/14 12:34:00 dcoutts Exp $
+
+ 14 Feb 2006; <duncan@gentoo.org> +files/gtk2hs-0.9.10-cflags.patch,
+ gtk2hs-0.9.10.ebuild:
+ Added a patch to fix the use of CFLAGS which was causing problems on sparc.
+ Marked ~sparc.
10 Feb 2006; <duncan@gentoo.org> -gtk2hs-0.9.6-r1.ebuild,
-gtk2hs-0.9.8.ebuild:
diff --git a/dev-haskell/gtk2hs/files/gtk2hs-0.9.10-cflags.patch b/dev-haskell/gtk2hs/files/gtk2hs-0.9.10-cflags.patch
new file mode 100644
index 000000000000..91356788108e
--- /dev/null
+++ b/dev-haskell/gtk2hs/files/gtk2hs-0.9.10-cflags.patch
@@ -0,0 +1,22 @@
+diff -urwpN gtk2hs-0.9.10.orig/mk/common.mk gtk2hs-0.9.10/mk/common.mk
+--- gtk2hs-0.9.10.orig/mk/common.mk 2006-02-13 16:31:33.184111717 +0000
++++ gtk2hs-0.9.10/mk/common.mk 2006-02-13 17:26:41.972180579 +0000
+@@ -79,6 +79,8 @@ noDeps := $(strip $(findstring clean,$
+ $(strip $(HC) -c $< -o $@ $(INCLUDES) \
+ $(AM_CPPFLAGS) $($(PKG)_CPPFLAGS) $(CPPFLAGS) \
+ $(addprefix -optc,$(AM_CFLAGS) $($(PKG)_CFLAGS) \
++ $(call getVar,$<,CFLAGS) $(CFLAGS)) \
++ $(addprefix -opta,$(AM_CFLAGS) $($(PKG)_CFLAGS) \
+ $(call getVar,$<,CFLAGS) $(CFLAGS)))
+
+ # The cheeky rule for .hi files says that .hi files can be created as
+@@ -106,7 +108,8 @@ noDeps := $(strip $(findstring clean,$
+ $(strip $(HSC2HS) $(HSCFLAGS) +RTS $(HSTOOLFLAGS) -RTS \
+ $(addprefix -L-optl,$(AM_LDFLAGS) $(LDFLAGS) $($(PKG)_LIBS)) \
+ $(addprefix -C, $(filter-out -I%,$(AM_CPPFLAGS) $(CPPFLAGS)) \
+- $(addprefix -optc,$(AM_CFLAGS) $(CFLAGS) $($(PKG)_CFLAGS)))\
++ $(addprefix -optc,$(AM_CFLAGS) $(CFLAGS) $($(PKG)_CFLAGS)) \
++ $(addprefix -opta,$(AM_CFLAGS) $(CFLAGS) $($(PKG)_CFLAGS))) \
+ $(filter -I%,$(AM_CPPFLAGS) $(CPPFLAGS)) $($(PKG)_CPPFLAGS)\
+ -C'-optc-include' -C'-optc$(CONFIG_HEADER)' \
+ --include $($(PKG)_HEADER) \
diff --git a/dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild b/dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild
index 442971189491..8552265dad0d 100644
--- a/dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild
+++ b/dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild,v 1.4 2005/12/14 15:40:42 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.9.10.ebuild,v 1.5 2006/02/14 12:34:00 dcoutts Exp $
-inherit base ghc-package multilib
+inherit base eutils ghc-package multilib autotools
DESCRIPTION="A GUI Library for Haskell based on Gtk+"
HOMEPAGE="http://haskell.org/gtk2hs/"
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/gtk2hs/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~ppc"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc"
#enable sparc when CFLAGS/-mcpu ebuild bug is fixed
IUSE="doc glade gnome mozilla firefox"
@@ -27,7 +27,16 @@ RDEPEND=">=virtual/ghc-5.04.3
DEPEND="${RDEPEND}
doc? ( >=dev-haskell/haddock-0.7 )"
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.9.10-cflags.patch"
+}
+
src_compile() {
+ # only needed because of the cflags patch above.
+ eautoreconf
+
econf \
--enable-packager-mode \
$(has_version '>=x11-libs/gtk+-2.8' && echo --enable-cairo) \