summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/sunflower/ChangeLog7
-rw-r--r--x11-misc/sunflower/sunflower-0.1_alpha53.ebuild84
-rw-r--r--x11-misc/sunflower/sunflower-0.1_alpha54.ebuild93
-rw-r--r--x11-misc/sunflower/sunflower-0.1_alpha55.ebuild93
-rw-r--r--x11-misc/sunflower/sunflower-0.1_alpha56.ebuild3
5 files changed, 8 insertions, 272 deletions
diff --git a/x11-misc/sunflower/ChangeLog b/x11-misc/sunflower/ChangeLog
index 3d689ce07d60..687dcd56e928 100644
--- a/x11-misc/sunflower/ChangeLog
+++ b/x11-misc/sunflower/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/sunflower
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sunflower/ChangeLog,v 1.8 2013/06/14 22:43:20 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sunflower/ChangeLog,v 1.9 2013/10/30 22:18:37 hasufell Exp $
+
+ 30 Oct 2013; Julian Ospald <hasufell@gentoo.org>
+ -sunflower-0.1_alpha53.ebuild, -sunflower-0.1_alpha54.ebuild,
+ -sunflower-0.1_alpha55.ebuild, sunflower-0.1_alpha56.ebuild:
+ add missing dep wrt #489424, remove old
*sunflower-0.1_alpha56 (14 Jun 2013)
diff --git a/x11-misc/sunflower/sunflower-0.1_alpha53.ebuild b/x11-misc/sunflower/sunflower-0.1_alpha53.ebuild
deleted file mode 100644
index 3735c5171bc3..000000000000
--- a/x11-misc/sunflower/sunflower-0.1_alpha53.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sunflower/sunflower-0.1_alpha53.ebuild,v 1.2 2013/05/29 13:38:21 hasufell Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-PLOCALES="bg cs de es hu pl ru uk_UA"
-inherit eutils fdo-mime gnome2-utils l10n python-r1
-
-MY_PV="${PV%_alpha*}a-${PV#*_alpha}"
-MY_PN="Sunflower"
-DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
-HOMEPAGE="http://code.google.com/p/sunflower-fm"
-SRC_URI="http://sunflower-fm.googlecode.com/files/${MY_PN}-${MY_PV}.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- >=dev-python/pygtk-2.15.0
- >=dev-python/notify-python-0.1
- virtual/python-argparse[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_PN}
-
-src_prepare() {
- find "${S}" -name "*.py[co]" -delete || die
- find "${S}"/translations -name "*.po" -delete || die
-
- sed -i \
- -e '/^application_file/s/os.path.dirname(sys.argv\[0\])/os.getcwd()/' \
- ${MY_PN}.py || die
-}
-
-src_install() {
- touch __init__.py || die
- installme() {
- # install modules
- python_moduleinto ${PN}
- python_domodule images application ${MY_PN}.py \
- AUTHORS CHANGES COPYING DEPENDS TODO __init__.py
-
- # generate and install startup scripts
- sed \
- -e "s#@SITEDIR@#$(python_get_sitedir)/${PN}#" \
- "${FILESDIR}"/${PN} > "${T}"/${PN} || die
- python_doscript "${T}"/${PN}
- }
-
- # install for all enabled implementations
- python_foreach_impl installme
-
- installlocale() { insinto /usr/share/locale ; doins -r "${S}"/translations/${1} ;}
- l10n_for_each_locale_do installlocale
-
- newicon -s 64 images/${PN}_64.png ${PN}.png
- doicon -s scalable images/${PN}.svg
- newmenu ${MY_PN}.desktop ${PN}.desktop
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-
- # TODO: better description
- elog "optional dependencies:"
- elog " dev-python/libgnome-python"
- elog " media-libs/mutagen"
- elog " x11-libs/vte:0[python] (terminal support)"
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/x11-misc/sunflower/sunflower-0.1_alpha54.ebuild b/x11-misc/sunflower/sunflower-0.1_alpha54.ebuild
deleted file mode 100644
index a690386566e8..000000000000
--- a/x11-misc/sunflower/sunflower-0.1_alpha54.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sunflower/sunflower-0.1_alpha54.ebuild,v 1.2 2013/05/29 13:38:21 hasufell Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-inherit eutils fdo-mime gnome2-utils python-r1
-
-MY_PV="${PV%_alpha*}a-${PV#*_alpha}"
-MY_PN="Sunflower"
-DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
-HOMEPAGE="http://code.google.com/p/sunflower-fm"
-SRC_URI="http://sunflower-fm.googlecode.com/files/${MY_PN}-${MY_PV}.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- >=dev-python/pygtk-2.15.0
- >=dev-python/notify-python-0.1
- virtual/python-argparse[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_PN}
-
-src_prepare() {
- find "${S}" -name "*.py[co]" -delete || die
- find "${S}"/translations -name "*.po" -delete || die
- rm "${S}"/translations/${PN}.pot || die
-
- sed -i \
- -e '/^application_file/s/os.path.dirname(sys.argv\[0\])/os.getcwd()/' \
- ${MY_PN}.py || die
-}
-
-src_install() {
- touch __init__.py || die
- installme() {
- # install modules
- python_moduleinto ${PN}
- python_domodule images application ${MY_PN}.py \
- AUTHORS CHANGES COPYING DEPENDS TODO __init__.py
-
- # generate and install startup scripts
- sed \
- -e "s#@SITEDIR@#$(python_get_sitedir)/${PN}#" \
- "${FILESDIR}"/${PN} > "${T}"/${PN} || die
- python_doscript "${T}"/${PN}
- }
-
- # install for all enabled implementations
- python_foreach_impl installme
-
- insinto /usr/share/locale
- # correct gettext behavior
- if [[ -n "${LINGUAS+x}" ]] ; then
- for i in $(cd "${S}"/translations ; echo *) ; do
- if has ${i} ${LINGUAS} ; then
- doins -r "${S}"/translations/${i}
- fi
- done
- else
- doins -r "${S}"/translations/*
- fi
-
- newicon -s 64 images/${PN}_64.png ${PN}.png
- doicon -s scalable images/${PN}.svg
- newmenu ${MY_PN}.desktop ${PN}.desktop
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-
- # TODO: better description
- elog "optional dependencies:"
- elog " dev-python/libgnome-python"
- elog " media-libs/mutagen"
- elog " x11-libs/vte:0[python] (terminal support)"
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/x11-misc/sunflower/sunflower-0.1_alpha55.ebuild b/x11-misc/sunflower/sunflower-0.1_alpha55.ebuild
deleted file mode 100644
index d7abc068d2df..000000000000
--- a/x11-misc/sunflower/sunflower-0.1_alpha55.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sunflower/sunflower-0.1_alpha55.ebuild,v 1.2 2013/05/29 13:38:21 hasufell Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-inherit eutils fdo-mime gnome2-utils python-r1
-
-MY_PV="${PV%_alpha*}a-${PV#*_alpha}"
-MY_PN="Sunflower"
-DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
-HOMEPAGE="http://code.google.com/p/sunflower-fm"
-SRC_URI="http://sunflower-fm.googlecode.com/files/${MY_PN}-${MY_PV}.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- >=dev-python/pygtk-2.15.0[${PYTHON_USEDEP}]
- >=dev-python/notify-python-0.1[${PYTHON_USEDEP}]
- virtual/python-argparse[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_PN}
-
-src_prepare() {
- find "${S}" -name "*.py[co]" -delete || die
- find "${S}"/translations -name "*.po" -delete || die
- rm "${S}"/translations/${PN}.pot || die
-
- sed -i \
- -e '/^application_file/s/os.path.dirname(sys.argv\[0\])/os.getcwd()/' \
- ${MY_PN}.py || die
-}
-
-src_install() {
- touch __init__.py || die
- installme() {
- # install modules
- python_moduleinto ${PN}
- python_domodule images application ${MY_PN}.py \
- AUTHORS CHANGES COPYING DEPENDS TODO __init__.py
-
- # generate and install startup scripts
- sed \
- -e "s#@SITEDIR@#$(python_get_sitedir)/${PN}#" \
- "${FILESDIR}"/${PN} > "${T}"/${PN} || die
- python_doscript "${T}"/${PN}
- }
-
- # install for all enabled implementations
- python_foreach_impl installme
-
- insinto /usr/share/locale
- # correct gettext behavior
- if [[ -n "${LINGUAS+x}" ]] ; then
- for i in $(cd "${S}"/translations ; echo *) ; do
- if has ${i} ${LINGUAS} ; then
- doins -r "${S}"/translations/${i}
- fi
- done
- else
- doins -r "${S}"/translations/*
- fi
-
- newicon -s 64 images/${PN}_64.png ${PN}.png
- doicon -s scalable images/${PN}.svg
- newmenu ${MY_PN}.desktop ${PN}.desktop
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-
- # TODO: better description
- elog "optional dependencies:"
- elog " dev-python/libgnome-python"
- elog " media-libs/mutagen"
- elog " x11-libs/vte:0[python] (terminal support)"
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}
diff --git a/x11-misc/sunflower/sunflower-0.1_alpha56.ebuild b/x11-misc/sunflower/sunflower-0.1_alpha56.ebuild
index 6656e58f8ec0..8b645f66ba0a 100644
--- a/x11-misc/sunflower/sunflower-0.1_alpha56.ebuild
+++ b/x11-misc/sunflower/sunflower-0.1_alpha56.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sunflower/sunflower-0.1_alpha56.ebuild,v 1.1 2013/06/14 22:43:20 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sunflower/sunflower-0.1_alpha56.ebuild,v 1.2 2013/10/30 22:18:37 hasufell Exp $
EAPI=5
@@ -23,6 +23,7 @@ DEPEND="${PYTHON_DEPS}"
RDEPEND="${DEPEND}
>=dev-python/pygtk-2.15.0[${PYTHON_USEDEP}]
>=dev-python/notify-python-0.1[${PYTHON_USEDEP}]
+ gnome-base/librsvg:2
virtual/python-argparse[${PYTHON_USEDEP}]"
S=${WORKDIR}/${MY_PN}