summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/bash-completion/ChangeLog8
-rw-r--r--app-shells/bash-completion/Manifest4
-rw-r--r--app-shells/bash-completion/bash-completion-20031125.ebuild55
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-200311251
4 files changed, 65 insertions, 3 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index a236cec79b05..370d4db0fa21 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.44 2003/11/12 12:50:17 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.45 2003/11/26 00:20:57 mholzer Exp $
+
+*bash-completion-20031125 (26 Nov 2003)
+
+ 26 Nov 2003; Martin Holzer <mholzer@gentoo.org>
+ bash-completion-20031125.ebuild:
+ Version bumped.
*bash-completion-20031112 (12 Nov 2003)
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index 82f61a9bbc2b..6e12f4b9e275 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -1,7 +1,7 @@
-MD5 6857c6fae80b28a125ae3cf18debfe85 bash-completion-20031125.ebuild 1468
+MD5 06e3b77d5f5a5d1d78c9d38d99968e0e bash-completion-20031125.ebuild 1468
MD5 6857c6fae80b28a125ae3cf18debfe85 bash-completion-20031112.ebuild 1468
MD5 d294ab161daf66abe94e479df8373993 bash-completion-20031022.ebuild 1460
-MD5 7984e366f55824c6bc58c46c724c47e5 ChangeLog 5800
+MD5 9046677160cb03f7ffcf527e7658a4e5 ChangeLog 5947
MD5 3c7995eee919c34f968dcde5d7b05ae0 files/digest-bash-completion-20031125 76
MD5 9b22241df7258cb9677cf9a1497e07c5 files/bash-completion 625
MD5 027671ae5e2c2687102df28add2005e4 files/digest-bash-completion-20031112 76
diff --git a/app-shells/bash-completion/bash-completion-20031125.ebuild b/app-shells/bash-completion/bash-completion-20031125.ebuild
new file mode 100644
index 000000000000..8861234e92da
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20031125.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20031125.ebuild,v 1.1 2003/11/26 00:20:57 mholzer Exp $
+
+S=${WORKDIR}/${PN/-/_}
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm ~amd64"
+
+DEPEND="app-arch/tar
+ app-arch/bzip2"
+
+RDEPEND=">=app-shells/bash-2.05a"
+
+src_install() {
+ insinto /etc
+ doins bash_completion
+
+ insinto /etc/bash_completion.d
+
+ doins contrib/unrar
+ doins contrib/harbour
+ doins contrib/isql
+ doins contrib/larch
+ doins contrib/lilypond
+ doins contrib/p4
+ doins contrib/ri
+
+ newins ${FILESDIR}/gentoo.completion gentoo
+
+ insinto /etc/profile.d
+ doins ${FILESDIR}/bash-completion
+
+ dodoc COPYING Changelog README
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
+ echo
+
+ if [ -f /etc/bash_completion.d/gentoo.completion ]
+ then
+ echo
+ ewarn "The file 'gentoo.completion' in '/etc/bash_completion.d/' has been"
+ ewarn "replaced with 'gentoo'. Remove gentoo.completion to avoid problems."
+ echo
+ fi
+}
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20031125 b/app-shells/bash-completion/files/digest-bash-completion-20031125
new file mode 100644
index 000000000000..09228e9de058
--- /dev/null
+++ b/app-shells/bash-completion/files/digest-bash-completion-20031125
@@ -0,0 +1 @@
+MD5 56a19bf89972f2d6e129933e7d76d626 bash-completion-20031125.tar.bz2 72975