summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/blitz/ChangeLog10
-rw-r--r--dev-libs/blitz/blitz-0.9-r1.ebuild5
-rw-r--r--dev-libs/blitz/blitz-0.9.ebuild10
-rw-r--r--dev-libs/blitz/files/blitz-0.9-gcc-4.3-missing-includes.patch20
4 files changed, 39 insertions, 6 deletions
diff --git a/dev-libs/blitz/ChangeLog b/dev-libs/blitz/ChangeLog
index bdbb9b7a66ee..5bbb3b066051 100644
--- a/dev-libs/blitz/ChangeLog
+++ b/dev-libs/blitz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/blitz
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/ChangeLog,v 1.28 2006/11/12 11:28:49 dragonheart Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/ChangeLog,v 1.29 2008/04/01 15:48:32 dragonheart Exp $
+
+ 01 Apr 2008; Daniel Black <dragonheart@gentoo.org>
+ +files/blitz-0.9-gcc-4.3-missing-includes.patch, blitz-0.9.ebuild,
+ blitz-0.9-r1.ebuild:
+ gcc-4.3 compatible patch poached from debian thanks to the watchful eye of
+ Jan - bug #214084 referes
12 Nov 2006; Daniel Black <dragonheart@gentoo.org> blitz-0.9.ebuild:
removed doc support - access violation - thanks Manuel Herzog bug 88042#c6
diff --git a/dev-libs/blitz/blitz-0.9-r1.ebuild b/dev-libs/blitz/blitz-0.9-r1.ebuild
index b4727c499801..143590c6ccf0 100644
--- a/dev-libs/blitz/blitz-0.9-r1.ebuild
+++ b/dev-libs/blitz/blitz-0.9-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9-r1.ebuild,v 1.1 2006/10/24 19:04:32 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9-r1.ebuild,v 1.2 2008/04/01 15:48:32 dragonheart Exp $
inherit eutils toolchain-funcs fortran
@@ -24,6 +24,7 @@ src_unpack() {
sed -i \
-e 's/blitz-uninstalled.pc//' \
Makefile.in || die "sed failed"
+ epatch "${FILESDIR}"/${P}-gcc-4.3-missing-includes.patch
}
src_compile() {
diff --git a/dev-libs/blitz/blitz-0.9.ebuild b/dev-libs/blitz/blitz-0.9.ebuild
index fa9e2800a984..5b38ad8f5760 100644
--- a/dev-libs/blitz/blitz-0.9.ebuild
+++ b/dev-libs/blitz/blitz-0.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9.ebuild,v 1.7 2006/11/12 11:28:49 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9.ebuild,v 1.8 2008/04/01 15:48:32 dragonheart Exp $
inherit eutils toolchain-funcs fortran
@@ -18,6 +18,12 @@ LICENSE="GPL-2"
FORTAN="g77"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc-4.3-missing-includes.patch
+}
+
src_compile() {
local myconf
# ICC: if we've got it, use it
diff --git a/dev-libs/blitz/files/blitz-0.9-gcc-4.3-missing-includes.patch b/dev-libs/blitz/files/blitz-0.9-gcc-4.3-missing-includes.patch
new file mode 100644
index 000000000000..64ca31c38a7a
--- /dev/null
+++ b/dev-libs/blitz/files/blitz-0.9-gcc-4.3-missing-includes.patch
@@ -0,0 +1,20 @@
+--- blitz-0.9.orig/blitz/funcs.h
++++ blitz-0.9/blitz/funcs.h
+@@ -30,6 +30,7 @@
+ #include <blitz/blitz.h>
+ #include <blitz/promote.h>
+ #include <blitz/prettyprint.h>
++#include <cstdlib>
+
+ BZ_NAMESPACE(blitz)
+
+--- blitz-0.9.orig/blitz/prettyprint.h
++++ blitz-0.9/blitz/prettyprint.h
+@@ -27,6 +27,7 @@
+
+ #ifndef BZ_PRETTYPRINT_H
+ #define BZ_PRETTYPRINT_H
++#include <cstdlib>
+
+ BZ_NAMESPACE(blitz)
+