summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/yarsrevenge/ChangeLog6
-rw-r--r--games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc43.patch10
-rw-r--r--games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild6
3 files changed, 19 insertions, 3 deletions
diff --git a/games-arcade/yarsrevenge/ChangeLog b/games-arcade/yarsrevenge/ChangeLog
index 336474e3d0e9..59a8d838e997 100644
--- a/games-arcade/yarsrevenge/ChangeLog
+++ b/games-arcade/yarsrevenge/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/yarsrevenge
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/ChangeLog,v 1.8 2008/03/25 13:18:27 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/ChangeLog,v 1.9 2008/04/30 22:56:34 nyhm Exp $
+
+ 30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/yarsrevenge-0.99-gcc43.patch, yarsrevenge-0.99.ebuild:
+ Fix building with gcc-4.3
25 Mar 2008; Santiago M. Mola <coldwind@gentoo.org>
yarsrevenge-0.99.ebuild:
diff --git a/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc43.patch b/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc43.patch
new file mode 100644
index 000000000000..fe32b6c74e6c
--- /dev/null
+++ b/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc43.patch
@@ -0,0 +1,10 @@
+--- yar/sgw.hxx
++++ yar/sgw.hxx
+@@ -24,6 +24,7 @@
+
+ #include <iostream>
+ #include <string>
++#include <cstdlib>
+
+ #define DEFAULT_SCX (1024) // Default Screen Size and Depth
+ #define DEFAULT_SCY (768)
diff --git a/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild b/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild
index 5138093caec5..21d5feaaea24 100644
--- a/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild
+++ b/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild,v 1.8 2008/03/25 13:18:27 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild,v 1.9 2008/04/30 22:56:34 nyhm Exp $
inherit eutils games
@@ -20,7 +20,9 @@ S=${WORKDIR}/yar-${PV}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PV}-math.patch
+ epatch \
+ "${FILESDIR}"/${PV}-math.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
}
src_install() {