summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-sci/gromacs/ChangeLog15
-rw-r--r--app-sci/gromacs/files/digest-gromacs-3.1.41
-rw-r--r--app-sci/gromacs/gromacs-3.1.4.ebuild35
3 files changed, 49 insertions, 2 deletions
diff --git a/app-sci/gromacs/ChangeLog b/app-sci/gromacs/ChangeLog
index 9267e67340f4..c179b1a08d80 100644
--- a/app-sci/gromacs/ChangeLog
+++ b/app-sci/gromacs/ChangeLog
@@ -1,9 +1,20 @@
# ChangeLog for app-sci/gromacs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# /space/gentoo/cvsroot/gentoo-x86/app-text/wv/ChangeLog,v 1.2 2002/04/27 23:08:36 bangert Exp
+# $Header $
+
+*gromacs-3.1.4 (08 Nov 2002)
+
+ 08 Nov 2002; George Shapovalov <george@gentoo.org> gromacs-3.1.4.ebuild, files/digest-gromacs-3.1.4 :
+
+ new version.
+ !!!IMPORTANT!!!
+ I changed --prefix to point to /usr for FHS compliance.
+ Now the binaries and the libs are getting installed into
+ /usr/i686-pc-linux-gnu/{bin,lib} correspondingly and the data into /usr/share/gromacs-${PV}
+ This seems to fit well in the existing direcory structure and does not conflict with gcc.
*gromacs-3.1.3 (27 Apr 2002)
- 27 Apr 2002; G.Shapovalov <georges@its.caltech.edu> all_files :
+ 27 Apr 2002; George Shapovalov <george@gentoo.org> all_files :
initial release.
diff --git a/app-sci/gromacs/files/digest-gromacs-3.1.4 b/app-sci/gromacs/files/digest-gromacs-3.1.4
new file mode 100644
index 000000000000..7f41e1fba1e3
--- /dev/null
+++ b/app-sci/gromacs/files/digest-gromacs-3.1.4
@@ -0,0 +1 @@
+MD5 835247417207a9852583a78f835a7da2 gromacs-3.1.4.tar.gz 2713384
diff --git a/app-sci/gromacs/gromacs-3.1.4.ebuild b/app-sci/gromacs/gromacs-3.1.4.ebuild
new file mode 100644
index 000000000000..4b0b6a3b225a
--- /dev/null
+++ b/app-sci/gromacs/gromacs-3.1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gromacs/gromacs-3.1.4.ebuild,v 1.1 2002/11/09 10:27:08 george Exp $
+
+IUSE=""
+
+DESCRIPTION="The ultimate Molecular Dynamics simulation package"
+SRC_URI="ftp://ftp.gromacs.org/pub/gromacs/${P}.tar.gz"
+HOMEPAGE="http://www.gromacs.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-libs/fftw-2.1.3
+ >=sys-devel/binutils-2.10.91.0.2"
+
+
+src_compile() {
+ econf \
+ --enable-fortran \
+ --datadir=/usr/share/${P} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ # Install documentation.
+ dodoc AUTHORS COPYING INSTALL README
+
+ #move html docs under /usr/share/doc
+ #and leave examples and templates under /usr/gromacs...
+ mv ${D}/usr/share/${P}/html ${D}/usr/share/doc/${PF}
+}