summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/ehcache/ChangeLog10
-rw-r--r--dev-java/ehcache/ehcache-1.1-r1.ebuild19
-rw-r--r--dev-java/ehcache/ehcache-1.2.4-r2.ebuild14
-rw-r--r--dev-java/ehcache/ehcache-1.2.4.ebuild18
4 files changed, 31 insertions, 30 deletions
diff --git a/dev-java/ehcache/ChangeLog b/dev-java/ehcache/ChangeLog
index 575cb70a465f..0c451e2aee4e 100644
--- a/dev-java/ehcache/ChangeLog
+++ b/dev-java/ehcache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ehcache
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ChangeLog,v 1.14 2010/05/21 17:58:46 ken69267 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ChangeLog,v 1.15 2013/11/30 08:19:52 tomwij Exp $
+
+ 30 Nov 2013; Tom Wijsman <TomWij@gentoo.org> ehcache-1.1-r1.ebuild,
+ ehcache-1.2.4-r2.ebuild, ehcache-1.2.4.ebuild:
+ Quoted multiple S variables. Removed redundant cd ${S} call from start of
+ src_install.
21 May 2010; Kenneth Prugh <ken69267@gentoo.org> ehcache-1.2.4-r2.ebuild:
amd64 stable, bug #292503
@@ -63,4 +68,3 @@
11 Mar 2005; Lim Swee Tat <st_lim@gentoo.org> +ehcache-1.1.ebuild:
Initial commit of ehcache. There is no src file nor a build.xml.
-
diff --git a/dev-java/ehcache/ehcache-1.1-r1.ebuild b/dev-java/ehcache/ehcache-1.1-r1.ebuild
index aea1bcb65d40..6b43d0dea7af 100644
--- a/dev-java/ehcache/ehcache-1.1-r1.ebuild
+++ b/dev-java/ehcache/ehcache-1.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ehcache-1.1-r1.ebuild,v 1.3 2010/01/03 21:33:56 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ehcache-1.1-r1.ebuild,v 1.4 2013/11/30 08:19:52 tomwij Exp $
inherit java-pkg-2 java-ant-2
@@ -25,27 +25,26 @@ DEPEND=">=virtual/jdk-1.4
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
unzip ${P}-src.zip || die
rm *.jar
rm -rf src/net/sf/ehcache/hibernate
}
src_compile() {
- mkdir ${S}/classes
- cd ${S}/src
+ mkdir "${S}"/classes
+ cd "${S}"/src
- ejavac -d ${S}/classes \
+ ejavac -d "${S}"/classes \
-classpath $(java-pkg_getjars commons-logging,commons-collections) \
$(find . -name "*.java")
- cd ${S}/classes
- jar cf ${S}/${P}.jar * || die
+ cd "${S}"/classes
+ jar cf "${S}"/${P}.jar * || die
}
src_install() {
- cd ${S}
- java-pkg_newjar ${S}/${P}.jar ${PN}.jar
+ java-pkg_newjar "${S}"/${P}.jar ${PN}.jar
dodoc *.txt ehcache.xml ehcache.xsd
if use doc ; then
unzip ${P}-javadoc.zip || die
diff --git a/dev-java/ehcache/ehcache-1.2.4-r2.ebuild b/dev-java/ehcache/ehcache-1.2.4-r2.ebuild
index 020c6d7f9996..11afcfcf2d3e 100644
--- a/dev-java/ehcache/ehcache-1.2.4-r2.ebuild
+++ b/dev-java/ehcache/ehcache-1.2.4-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ehcache-1.2.4-r2.ebuild,v 1.6 2010/05/21 17:58:46 ken69267 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ehcache-1.2.4-r2.ebuild,v 1.7 2013/11/30 08:19:52 tomwij Exp $
JAVA_PKG_IUSE="doc source"
@@ -33,7 +33,7 @@ JAVA_PKG_WANT_TARGET="1.4"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
use doc && unzip -qq ${P}-javadoc.zip
@@ -43,13 +43,13 @@ src_unpack() {
# could use a USE flag, but would result in circular dep
rm -rf net/sf/ehcache/hibernate
- cd ${S}
+ cd "${S}"
rm -f *.jar *.zip
cp "${FILESDIR}/build.xml-${PVR}" build.xml || die
mv "${S}/ehcache.xml" "${S}/ehcache-failsafe.xml" || die
- mkdir ${S}/lib
- cd ${S}/lib
+ mkdir "${S}"/lib
+ cd "${S}"/lib
java-pkg_jarfrom commons-logging
java-pkg_jarfrom commons-collections
@@ -62,11 +62,9 @@ src_compile() {
}
src_install() {
-
java-pkg_dojar ${PN}.jar
dodoc *.txt ehcache.xsd
use source && java-pkg_dosrc src/net
use doc &&java-pkg_dojavadoc docs
-
}
diff --git a/dev-java/ehcache/ehcache-1.2.4.ebuild b/dev-java/ehcache/ehcache-1.2.4.ebuild
index 90ee8b411087..ed2f88973b64 100644
--- a/dev-java/ehcache/ehcache-1.2.4.ebuild
+++ b/dev-java/ehcache/ehcache-1.2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ehcache-1.2.4.ebuild,v 1.1 2007/01/03 03:17:03 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ehcache-1.2.4.ebuild,v 1.2 2013/11/30 08:19:52 tomwij Exp $
inherit java-pkg-2 java-ant-2
@@ -27,26 +27,26 @@ DEPEND=">=virtual/jdk-1.4
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
mkdir src && cd src
unzip -qq ../${P}-sources.jar || die
rm -rf net/sf/ehcache/hibernate
}
src_compile() {
- mkdir ${S}/classes
- cd ${S}/src
+ mkdir "${S}"/classes
+ cd "${S}"/src
- ejavac -d ${S}/classes \
+ ejavac -d "${S}"/classes \
-classpath $(java-pkg_getjars commons-logging,commons-collections,servletapi-2.4) \
$(find . -name "*.java")
- cd ${S}/classes
- jar cf ${S}/${P}.jar * || die "failed to create jar"
+ cd "${S}"/classes
+ jar cf "${S}"/${P}.jar * || die "failed to create jar"
}
src_install() {
- java-pkg_newjar ${S}/${P}.jar
+ java-pkg_newjar "${S}"/${P}.jar
dodoc *.txt ehcache.xml ehcache.xsd
use source && java-pkg_dosrc src
if use doc ; then