summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/ccp4-apps/ChangeLog6
-rw-r--r--sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r10.ebuild6
-rw-r--r--sci-chemistry/ccp4-apps/files/6.1.3-lapack.patch2
3 files changed, 9 insertions, 5 deletions
diff --git a/sci-chemistry/ccp4-apps/ChangeLog b/sci-chemistry/ccp4-apps/ChangeLog
index b42e379a1627..679bf9b96603 100644
--- a/sci-chemistry/ccp4-apps/ChangeLog
+++ b/sci-chemistry/ccp4-apps/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/ccp4-apps
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ChangeLog,v 1.36 2012/04/26 15:46:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ChangeLog,v 1.37 2012/06/01 09:06:21 jlec Exp $
+
+ 01 Jun 2012; Justin Lecher <jlec@gentoo.org> files/6.1.3-lapack.patch,
+ ccp4-apps-6.1.3-r10.ebuild:
+ add missing die, don't rely on lapack -> blas dep chain
26 Apr 2012; Justin Lecher <jlec@gentoo.org> -ccp4-apps-6.1.3-r9.ebuild,
ccp4-apps-6.1.3-r10.ebuild:
diff --git a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r10.ebuild b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r10.ebuild
index cafa6ea88691..dd8fe0a14aa9 100644
--- a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r10.ebuild
+++ b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r10.ebuild,v 1.9 2012/04/26 15:46:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r10.ebuild,v 1.10 2012/06/01 09:06:21 jlec Exp $
EAPI=3
@@ -227,7 +227,7 @@ src_configure() {
# We agree to the license by emerging this, set in LICENSE
sed -i \
-e "s~^\(^agreed=\).*~\1yes~g" \
- "${S}"/configure
+ "${S}"/configure || die
# Fix up variables -- need to reset CCP4_MASTER at install-time
sed -i \
@@ -236,7 +236,7 @@ src_configure() {
-e "s~^\(.*export CBIN=.*\)\$CCP4.*~\1\$CCP4/libexec/ccp4/bin/~g" \
-e "s~^\(.*setenv CBIN .*\)\$CCP4.*~\1\$CCP4/libexec/ccp4/bin/~g" \
-e "s~^\(setenv CCP4I_TCLTK.*\)/usr/local/bin~\1${EPREFIX}/usr/bin~g" \
- "${S}"/include/ccp4.setup*
+ "${S}"/include/ccp4.setup* || die
# Set up variables for build
source "${S}"/include/ccp4.setup-sh
diff --git a/sci-chemistry/ccp4-apps/files/6.1.3-lapack.patch b/sci-chemistry/ccp4-apps/files/6.1.3-lapack.patch
index 2514733f876d..cef286b16b7c 100644
--- a/sci-chemistry/ccp4-apps/files/6.1.3-lapack.patch
+++ b/sci-chemistry/ccp4-apps/files/6.1.3-lapack.patch
@@ -567,7 +567,7 @@ index 833f483..bcfa62d 100755
+ # gentoo is clever
+ make_blas=
+ make_lapack=
-+ BLASLIB=$(pkg-config --libs lapack)
++ BLASLIB=$(pkg-config --libs blas)
+ LAPACKLIB=$(pkg-config --libs lapack)
+ XLAPACK_LIB="${BLASLIB} ${LAPACKLIB}"
+ XFFLAGS_LAPACK="$(pkg-config --cflags lapack blas)"