summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/opencc/ChangeLog9
-rw-r--r--app-i18n/opencc/opencc-0.3.0_pre20120819.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/app-i18n/opencc/ChangeLog b/app-i18n/opencc/ChangeLog
index 579bc6bff63c..56284f8189ae 100644
--- a/app-i18n/opencc/ChangeLog
+++ b/app-i18n/opencc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/opencc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/opencc/ChangeLog,v 1.6 2012/05/18 14:20:03 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/opencc/ChangeLog,v 1.7 2012/08/19 08:45:43 scarabeus Exp $
+
+*opencc-0.3.0_pre20120819 (19 Aug 2012)
+
+ 19 Aug 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ +opencc-0.3.0_pre20120819.ebuild:
+ Fix ppc builds by adding new git snapshot (fedora and suse do the same).
18 May 2012; Joseph Jezak <josejx@gentoo.org> opencc-0.2.0.ebuild:
Marked ~ppc/~ppc64.
@@ -25,4 +31,3 @@
20 Sep 2010; MATSUU Takuto <matsuu@gentoo.org> +opencc-0.1.2.ebuild,
+metadata.xml:
Initial import.
-
diff --git a/app-i18n/opencc/opencc-0.3.0_pre20120819.ebuild b/app-i18n/opencc/opencc-0.3.0_pre20120819.ebuild
new file mode 100644
index 000000000000..4b935a383a0b
--- /dev/null
+++ b/app-i18n/opencc/opencc-0.3.0_pre20120819.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/opencc/opencc-0.3.0_pre20120819.ebuild,v 1.1 2012/08/19 08:45:42 scarabeus Exp $
+
+EAPI=4
+
+inherit cmake-utils multilib
+
+DESCRIPTION="Libraries for Simplified-Traditional Chinese Conversion"
+HOMEPAGE="http://code.google.com/p/open-chinese-convert/"
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS="AUTHORS README"
+
+src_prepare() {
+ sed -i \
+ -e "s:\${CMAKE_\(SHARED\|STATIC\)_LIBRARY_PREFIX}:\"$(get_libdir)\":" \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use_enable nls GETTEXT)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use static-libs || find "${ED}" -name '*.la' -o -name '*.a' -exec rm {} +
+}