summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--virtual/python-argparse/ChangeLog7
-rw-r--r--virtual/python-argparse/python-argparse-1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/virtual/python-argparse/ChangeLog b/virtual/python-argparse/ChangeLog
index 60ed15a25f4b..de08ffc868d5 100644
--- a/virtual/python-argparse/ChangeLog
+++ b/virtual/python-argparse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for virtual/python-argparse
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/ChangeLog,v 1.1 2012/10/28 22:08:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/ChangeLog,v 1.2 2012/10/29 13:55:37 mgorny Exp $
+
+*python-argparse-1 (29 Oct 2012)
+
+ 29 Oct 2012; Michał Górny <mgorny@gentoo.org> +python-argparse-1.ebuild:
+ Update the virtual to depend on target-aware argparse.
*python-argparse-0 (28 Oct 2012)
diff --git a/virtual/python-argparse/python-argparse-1.ebuild b/virtual/python-argparse/python-argparse-1.ebuild
new file mode 100644
index 000000000000..8a5abe11979c
--- /dev/null
+++ b/virtual/python-argparse/python-argparse-1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/python-argparse/python-argparse-1.ebuild,v 1.1 2012/10/29 13:55:37 mgorny Exp $
+
+EAPI=4
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9} jython2_5 )
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python argparse module"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+setup_globals() {
+ local i
+
+ RDEPEND=
+ for i in "${PYTHON_COMPAT[@]}"; do
+ case "${i}" in
+ python2_5|python2_6|jython2_5)
+ local flag=python_targets_${i}
+ # Note: add USE-deps when dev-python/argparse starts
+ # supporting PYTHON_TARGETS
+ RDEPEND+=" ${flag}? ( dev-python/argparse[${flag}] )"
+ ;;
+ *)
+ ;;
+ esac
+ done
+}
+setup_globals